Jak opravit chybu #NENÍ_K_DISPOZICI

Chyba #N/A obecně značí, že vzorec nemůže najít to, co se od něj žádá.

Nejlepší řešení

Nejčastější příčinou chyby #N/A je funkce XLOOKUP, SVYHLEDAT, VVYHLEDAT, VYHLEDAT nebo SHODA, pokud vzorec nemůže najít odkazovanou hodnotu. Třeba když vyhledávací hodnota ve zdrojových datech neexistuje.

Vyhledávací hodnota neexistuje.  Vzorec v buňce E2 je =SVYHLEDAT(D2,$D$6:$E$8,2,NEPRAVDA).  Hodnotu Banán se nepodařilo najít a proto vzorec vrátí chybu #NENÍ_K_DISPOZICI.

V tomto případě položka „Banány“ není uvedena ve vyhledávací tabulce, takže funkce SVYHLEDAT vrátí chybu #N/A.

Řešení:Buď se ujistěte, že vyhledávací hodnota existuje ve zdrojových datech, nebo použijte obslužnou rutinu chyby, například IFERROR ve vzorci. Například =IFERROR(FORMULA();0), který říká:

  • = KDYŽ(váš vzorec vyhodnotí chybu; pak zobrazit 0; jinak zobrazit výsledek vzorce)

Pro zobrazení prázdného pole můžete použít “” nebo můžete doplnit vlastní text: =IFERROR(FORMULA();“Tady bude chybová zpráva.”)

Pokud si v tomto bodě nejste jistí, co udělat nebo jakou pomoc byste přesně potřebovali, můžete zkusit najít podobný dotaz na fóru komunity Excelu nebo tam publikovat svůj vlastní.

Odkaz na fórum komunity Excelu

Pokud se budete chtít posunout dál, použijte tento kontrolní seznam, který obsahuje postupy pro řešení potíží, pomocí kterých můžete zjistit, co by ve vzorcích mohlo být špatně.

Vyhledávací hodnota a zdrojová data jsou různé datové typy. Pokusíte se třeba odkázat funkcí SVYHLEDAT na číslo, ale zdrojová data jsou uložena jako text.

Nesprávné typy hodnot.  Příklad zobrazuje vzorec SVYHLEDAT vracející chybu #NENÍ_K_DISPOZICI, protože vyhledávací hodnota je formátovaná jako číslo, ale vyhledávací tabulka je formátovaná jako text.

Řešení:Ujistěte se, že jsou datové typy stejné. Formáty buněk můžete zkontrolovat tak, že vyberete buňku nebo oblast buněk, kliknete pravým tlačítkem myši a vyberete Formát buněk >Číslo (nebo stisknete kombinaci kláves Ctrl+1) a v případě potřeby změníte formát čísla.

Dialogové okno Formát buněk zobrazující kartu Číslo a vybranou možnost Text

Tip: Pokud potřebujete vynutit změnu formátování celého sloupce, použijte nejdřív požadovaný formát a pak můžete kliknout na Data > Text do sloupců > Dokončit.

Funkci TRIM můžete použít k odebrání všech úvodních nebo koncových mezer. V následujícím příkladu se funkce TRIM vnořená do funkce SVYHLEDAT používá k odebrání úvodních mezer z názvů v A2:A7 a k vrácení názvu oddělení.

Použití funkce SVYHLEDAT s funkcí PROČISTIT v maticovém vzorci k odebrání úvodních a koncových mezer.  Vzorec v buňce E3 je {=SVYHLEDAT(D2,PROČISTIT(A2:B7),2,NEPRAVDA)} a musí být zadaný pomocí kombinace kláves CTRL+SHIFT+ENTER.

=SVYHLEDAT(D2;OŘÍZNOUT(A2:B7);2;NEPRAVDA)

Poznámka: 24. září 2018 – Dynamické maticové vzorce – Pokud máte aktuální verzi Microsoft 365 a odebíráte kanál vydávaných verzí programu Insider Fast, můžete zadat vzorec do horní levé buňky výstupní oblasti a potom stisknutím klávesy Enter vzorec potvrdit jako dynamický maticový vzorec. Jinak musíte vzorec zadat jako starší maticový vzorec tak, že nejprve vyberete výstupní oblast, potom zadáte vzorec do horní levé buňky výstupní oblasti a potvrdíte ho stisknutím Ctrl+Shift+Enter. Excel vloží složené závorky na začátku a konci vzorce. Další informace o maticových vzorcích najdete v tématu s pokyny k používání a příklady maticových vzorců.

Ve výchozím nastavení musí být funkce, které v tabulkách vypadají, seřazeny vzestupně. Funkce listu SVYHLEDAT a VVYHLEDAT ale obsahují argument range_lookup, který funkci nabádá, aby našla přesnou shodu, i když tabulka není seřazená. Pokud chcete najít přesnou shodu, nastavte range_lookup hodnotu NEPRAVDA. Všimněte si, že pomocí funkce PRAVDA, která říká, že funkce má hledat přibližnou shodu, může mít nejen za následek chybu #N/A, ale může také vrátit chybné výsledky, jak je vidět v následujícím příkladu.

Příklad použití funkce SVYHLEDAT s hodnotou PRAVDA argumentu typ, které může mít nesprávné výsledky.

V tomto příkladu nejenže vznikne chyba #N/A u položky „Banány“, ale u položky „Pomeranče“ navíc funkce vrátí špatnou cenu. Ta je způsobená použitím argumentu PRAVDA, který funkci SVYHLEDAT říká, že má hledat přibližnou shodu místo přesné shody. Položka „Banány“ blízkou shodu nemá a položka „Pomela“ abecedně předchází položku „Pomeranče“. V tomto případě by funkce SVYHLEDAT s argumentem NEPRAVDA vrátila správnou cenu pro položku „Pomeranče“, ale u položky „Banány“ by pořád zůstala chyba #N/A, protože nic, co by odpovídalo položce „Banány“, v seznamu vyhledávání neexistuje.

Pokud používáte funkci POZVYHLEDAT, zkuste změnit hodnotu argumentu shoda tak, aby určovala pořadí řazení v tabulce. Pokud chcete najít přesnou shodu, nastavte argument shoda na hodnotu 0 (nula).

Pokud chcete tento problém vyřešit, zajistěte, aby oblast, na kterou odkazuje maticový vzorec, obsahovala stejný počet řádků a sloupců jako oblast buněk, do které je vložený maticový vzorec, nebo zadejte maticový vzorec do menšího nebo většího počtu buněk tak, aby odpovídal odkazu na oblast dat ve vzorci.

V tomto příkladu buňka E2 odkazovala na neodpovídající oblasti:

Příklad maticového vzorce s neodpovídajícími odkazy na oblasti, jejichž výsledkem je chyba #NENÍ_K_DISPOZICI.  Vzorec v buňce E2 je {=SUMA(KDYŽ(A2:A11=D2,B2:B5))} a musí být zadaný pomocí kombinace kláves CTRL+SHIFT+ENTER.

=SUMA(KDYŽ(A2:A11=D2;B2:B5))

Pokud má vzorec provést správný výpočet, musí se změnit tak, aby obě oblasti zohledňovaly řádky 2–11.

=SUMA(KDYŽ(A2:A11=D2;B2:B11))

Poznámka: 24. září 2018 – Dynamické maticové vzorce – Pokud máte aktuální verzi Microsoft 365 a odebíráte kanál vydávaných verzí programu Insider Fast, můžete zadat vzorec do horní levé buňky výstupní oblasti a potom stisknutím klávesy Enter vzorec potvrdit jako dynamický maticový vzorec. Jinak musíte vzorec zadat jako starší maticový vzorec tak, že nejprve vyberete výstupní oblast, potom zadáte vzorec do horní levé buňky výstupní oblasti a potvrdíte ho stisknutím Ctrl+Shift+Enter. Excel vloží složené závorky na začátku a konci vzorce. Další informace o maticových vzorcích najdete v tématu s pokyny k používání a příklady maticových vzorců.

Příklad hodnot #NENÍ_K_DISPOZICI zadaných do buněk bránících správnému výpočtu vzorce SUMA.

V tomto případě květen až prosinec mají hodnoty #N/A, takže celkový součet nejde vypočítat a místo něj vznikne chyba #N/A.

Pokud chcete tento problém vyřešit, zkontrolujte ve vzorci, který vrací chybu, syntaxi u používané funkce, a zadejte všechny požadované argumenty. Ke kontrole této funkce budete možná potřebovat Visual Basic Editor (VBE). Do VBE se dostanete z karty Vývojář nebo stisknutím kombinace kláves Alt+F11.

Pokud to chcete opravit, zkontrolujte, jestli je sešit, který obsahuje uživatelem definovanou funkci, otevřený a jestli funkce správně funguje.

Pokud to chcete opravit, zkontrolujte, jestli jsou argumenty ve funkci správné a na správné pozici.

Tyto chyby můžete opravit stisknutím kombinace kláves Ctr+Alt+F9, aby se list přepočítal.

Použijte Průvodce funkcí, který vám pomůže, když si nejste jistí, jaký argument máte použít. Vyberte buňku s tímto vzorcem, přejděte na kartu Vzorec na pásu karet a stiskněte Vložit funkci.

Tlačítko Vložit funkci.

Excel načte Průvodce automaticky za vás:

Příklad dialogového okna průvodce vzorcem.

Při kliknutí na jednotlivé argumenty vám Excel nabídne příslušné informace pro každý z nich.

Hodnota #N/A může být užitečná! Je běžně ji používat, když máte data, jako jsou třeba v následujícím příkladu s grafy, protože hodnota #N/A se na graf nevykreslí. Toto jsou příklady, jak vypadá graf, když ho vykreslíte s nulami oproti tomu, když ho vykreslíte s hodnotou #N/A.

Příklad spojnicového grafu vykreslujícího 0 hodnot.

V předchozím příkladu uvidíte, že se hodnoty 0 vykreslují a zobrazují se v dolní části grafu jako plochou čáru a potom se vysílá nahoru, aby se zobrazí součet. V následujícím příkladu uvidíte hodnoty 0 nahrazené #N/A.

Příklad spojnicového grafu, který nevykresluje hodnoty #NENÍ_K_DISPOZICI.

Další informace o chybě #N/A u konkrétních funkcí najdete v těchto tématech:

Začátek stránky

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Převod čísel uložených jako text na čísla

SVYHLEDAT

VVYHLEDAT

VYHLEDAT

POZVYHLEDAT

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Klávesové zkratky v Excelu

Všechny funkce Excelu (podle abecedy)

Všechny funkce v Excelu (podle kategorie)

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×