Jak opravit #REF! #BUSY!

Jak opravit #REF! #BUSY!

Chyba #ODKAZ! se zobrazí, když vzorec odkazuje na buňku, která není platná. To se nejčastěji stává, když se buňky, na které vzorce odkazují, odstraní nebo se do nich vloží něco jiného.

Příklad: #REF! způsobená odstraněním sloupce

Následující příklad používá ve sloupci E vzorec =SUMA(B2;C2;D2).

Vzorec, který používá explicitní odkazy na buňky jako =SUMA(B2;C2;D2), může způsobit #REF! pokud odstraníte sloupec.

Pokud byste odstranili sloupec B, C nebo D, způsobilo by #REF! . V tomto případě odstraníme sloupec C (Prodej 2007) a vzorec teď bude =SUMA(B2;#REF!;C2). Pokud použijete explicitní odkazy na buňky jako tento (když odkazujete na jednotlivé buňky oddělené čárkou) a odstraníte odkazovaný řádek nebo sloupec, Excel ho nemůže vyřešit, takže vrátí #REF! . To je hlavní důvod, proč se nedoporučuje používat explicitní odkazy na buňky ve funkcích.

Příklad #REF! způsobená odstraněním sloupce.

Řešení

  • Pokud jste odstranili řádky nebo sloupce omylem, můžete okamžitě kliknout na tlačítko Zpět na panelu nástrojů Rychlý přístup (nebo stisknout kombinaci kláves CTRL+Z) a obnovit je.

  • Upravte vzorec tak, aby používal odkaz na oblast místo odkazu na jednotlivé buňky, jako =SUMA(B2:D2). Když teď odstraníte kterýkoli sloupec z této oblasti, Excel vzorec automaticky upraví. Pro součet řádků můžete použít =SUMA(B2:B5).

Příklad funkce SVYHLEDAT s odkazy na nesprávné oblasti

V následujícím příkladu vrátí funkce =SVYHLEDAT(A8;A2:D5;5;NEPRAVDA) #REF! protože hledá hodnotu, která by se vrátila ze sloupce 5, ale referenční oblast je A:D, což jsou jenom 4 sloupce.

Příklad vzorce SVYHLEDAT s nesprávnou oblast  Vzorec je =VLOOKU(A8;A2:D5;5;NEPRAVDA).  V oblasti funkce SVYHLEDAT neexistuje pátý sloupec, takže číslo 5 #REF. .

Řešení

Buď zvětšete oblast nebo zmenšete vyhledávací hodnotu sloupce tak, aby odpovídala odkazované oblasti. Vzorec =SVYHLEDAT(A8;A2:E5;5;NEPRAVDA) by byl platný odkaz, stejně jako vzorec =SVYHLEDAT(A8;A2:D5;4;NEPRAVDA).

Příklad funkce INDEX se špatným odkazem na řádek nebo sloupec

V tomto příkladu vrátí vzorec =INDEX(B2:E5;5;5) #REF! protože oblast INDEX má 4 řádky na 4 sloupce, ale vzorec žádá, aby vrátil, co je v 5. řádku a 5. sloupci.

Příklad vzorce INDEX s neplatným odkazem na oblast  Vzorec je =INDEX(B2:E5;5;5), ale oblast je pouze 4 řádky krát 4 sloupce.

Řešení

Upravte odkazy na řádky nebo sloupce tak, aby patřily do prohledávané oblasti funkce INDEX. Vzorec =INDEX(B2:E5;4;4) by vrátil platný výsledek.

Příklad funkce NEPŘÍMÝ.ODKAZ odkazující na uzavřený sešit

V následujícím příkladu se funkce NEPŘÍMÝ.ODKAZ pokouší odkazovat na sešit, který je zavřený, což způsobuje #REF! .

Příklad #REF! způsobená NEPŘÍMÝM odkazováním na zavřený sešit.

Řešení

Otevřete odkazovaný sešit. Se stejnou chybou se setkáte při odkazování na zavřený sešit pomocí dynamické maticové funkce.

Problémy OLE

Pokud jste použili odkaz OLE (Object Linking and Embedding), který vrací #REF! a pak spusťte program, na který se odkaz volá.

Poznámka: OLE je technologie, kterou můžete použít ke sdílení informací mezi programy.

Problémy s DDE

Pokud jste použili téma DDE (Dynamic Data Exchange), které vrací #REF! nejdřív zkontrolujte, jestli odkazujete na správné téma. Pokud ještě pořád dostáváte e-#REF! zkontrolujte nastavení Centra zabezpečení pro externí obsah podle pokynů v části Blokování nebo odblokování externího obsahu v dokumentech Office.

Poznámka: DDE (Dynamic Data Exchange)je zavedený protokol pro výměnu dat mezi programy Microsoftu, které jsou založené na Windows.

Problémy s makry

Pokud makro na listu zadá funkci, která odkazuje na buňku nad funkcí, a buňka, která tuto funkci obsahuje, je na řádku 1, vrátí funkce #REF!. protože nad řádkem 1 nejsou žádné buňky. Zkontrolujte ve funkci, jestli argument odkazuje na buňku nebo oblast buněk, která není platná. To může vyžadovat úpravu makra ve Visual Basic Editoru (VBE), aby se tato situace brala v úvahu.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Viz také

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Funkce Excelu (podle abecedy)

Funkce Excelu (podle kategorie)

Potřebujete další pomoc?

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×