Jak opravit #REF! #BUSY!

Chyba #ODKAZ! se zobrazí, když vzorec odkazuje na buňku, která není platná. To se nejčastěji stává, když se buňky, na které vzorce odkazují, odstraní nebo se do nich vloží něco jiného.

Příklad – #REF! chyba způsobená odstraněním sloupce

Následující příklad používá ve sloupci E vzorec =SUMA(B2;C2;D2).

Vzorec, který používá explicitní odkazy na buňky, například =SUMA(B2;C2;D2), může způsobit #REF! pokud je sloupec odstraněný.

Pokud byste odstranili sloupec B, C nebo D, způsobilo by to #REF! . V takovém případě odstraníme sloupec C (Prodej 2007) a vzorec teď přečte =SUMA(B2;#REF!;C2). Pokud použijete explicitní odkazy na buňky, jako je tento (kde odkazujete na jednotlivé buňky oddělené čárkou) a odstraníte odkazovaný řádek nebo sloupec, Excel ji nemůže vyřešit, takže vrátí #REF! . To je hlavní důvod, proč se nedoporučuje používat explicitní odkazy na buňky ve funkcích.

Příklad #REF! způsobená odstraněním sloupce.

Řešení

  • Pokud jste odstranili řádky nebo sloupce omylem, můžete okamžitě kliknout na tlačítko Zpět na panelu nástrojů Rychlý přístup (nebo stisknout kombinaci kláves CTRL+Z) a obnovit je.

  • Upravte vzorec tak, aby používal odkaz na oblast místo odkazu na jednotlivé buňky, jako =SUMA(B2:D2). Když teď odstraníte kterýkoli sloupec z této oblasti, Excel vzorec automaticky upraví. Pro součet řádků můžete použít =SUMA(B2:B5).

Příklad funkce SVYHLEDAT s odkazy na nesprávné oblasti

V následujícím příkladu vrátí funkce =SVYHLEDAT(A8;A2:D5;5;NEPRAVDA) #REF! protože hledá hodnotu, která se má vrátit ze sloupce 5, ale oblast odkazů je A:D, což jsou jenom 4 sloupce.

Příklad vzorce SVYHLEDAT s nesprávnou oblastí  Vzorec je =VLOOKU(A8;A2:D5;5;NEPRAVDA).  V oblasti SVYHLEDAT není žádný pátý sloupec, takže 5 způsobí, že #REF! .

Řešení

Buď zvětšete oblast nebo zmenšete vyhledávací hodnotu sloupce tak, aby odpovídala odkazované oblasti. Vzorec =SVYHLEDAT(A8;A2:E5;5;NEPRAVDA) by byl platný odkaz, stejně jako vzorec =SVYHLEDAT(A8;A2:D5;4;NEPRAVDA).

Příklad funkce INDEX se špatným odkazem na řádek nebo sloupec

V tomto příkladu vrátí vzorec =INDEX(B2:E5;5;5) #REF! protože oblast INDEX je 4 řádky po 4 sloupcích, ale vzorec žádá, aby vrátil, co je v 5. řádku a 5. sloupci.

Příklad vzorce INDEX s neplatným odkazem na oblast  Vzorec je =INDEX(B2:E5;5;5), ale oblast je jenom 4 řádky po 4 sloupcích.

Řešení

Upravte odkazy na řádky nebo sloupce tak, aby patřily do prohledávané oblasti funkce INDEX. Vzorec =INDEX(B2:E5;4;4) by vrátil platný výsledek.

Příklad funkce NEPŘÍMÝ.ODKAZ odkazující na uzavřený sešit

V následujícím příkladu se funkce NEPŘÍMÝ ODKAZ pokouší odkazovat na sešit, který je zavřený, což způsobuje #REF! .

Příklad #REF! způsobená odkazem na uzavřený sešit nepřímým odkazem.

Řešení

Otevřete odkazovaný sešit. Ke stejné chybě dojde, pokud odkazujete na uzavřený sešit s dynamickou matici.

Problémy s OLE

Pokud jste použili odkaz OLE (Object Linking and Embedding), který vrací #REF! a pak spusťte program, který volá odkaz.

Poznámka: OLE je technologie, kterou můžete použít ke sdílení informací mezi programy.

Problémy s DDE

Pokud jste použili téma dynamického Exchange (DDE), které vrací #REF! zkontrolujte, jestli odkazujete na správné téma. Pokud pořád dostáváte #REF! zkontrolujte, zda v Centru zabezpečení Nastavení externí obsah, jak je uvedeno v části Blokování nebo odblokování externího obsahu v Office dokumentech.

Poznámka: Dynamické datové Exchange (DDE)je zavedený protokol pro výměnu dat mezi Windows microsoftových aplikací.

Problémy s makry

Pokud makro zadá do listu funkci, která odkazuje na buňku nad funkcí, a buňka obsahující tuto funkci je v řádku 1, vrátí funkce #REF! protože nad řádkem 1 nejsou žádné buňky. Zkontrolujte funkci, jestli argument odkazuje na buňku nebo oblast buněk, které nejsou platné. To může vyžadovat úpravy makra v editoru Visual Basic (VBE), aby se tato situace zohlednila.

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Přehled vzorců v Excelu

Jak se vyhnout nefunkčním vzorcům

Zjišťování chyb ve vzorcích

Funkce Excelu (podle abecedy)

Funkce Excelu (podle kategorie)

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×