Oprava chyby #HODNOTA! u funkcí PRŮMĚR a SUMA

Pokud funkce průměr nebo suma odkazuje na buňky obsahující #VALUE chyby, výsledkem vzorců bude #VALUE! Pokud je pozice, kterou uvedete, před první položkou nebo za poslední položkou v poli, bude výsledkem vzorce chyba #REF!.

Chyba #HODNOTA! u funkce PRŮMĚR

Aby se nebraly v úvahu chybové hodnoty, vytvoříme vzorec, který ignoruje chyby v referenční oblasti, a vypočteme průměr se zbývajícími „normálními“ hodnotami.

Tento scénář obejdeme tak, že pomocí kombinace funkcí PRŮMĚR, KDYŽ a JE.CHYBHODN určíme, jestli je v zadané oblasti chyba. Tento konkrétní scénář vyžaduje maticový vzorec:

=PRŮMĚR(KDYŽ(JE.CHYBHODN(B2:D2);"";B2:D2))

Toto je maticový vzorec. Abyste mohli buď stisknout ENTER (jenom v případě, že používáte Microsoft 365 ) nebo CTRL + SHIFT + ENTER ve vzorci.

Poznámka: Pokud máte aktuální verzi Microsoft 365, můžete jednoduše zadat vzorec do výstupní buňky a stisknutím klávesy ENTER vzorec potvrdit jako dynamický maticový vzorec. V opačném případě musí být vzorec zadán jako starší maticový vzorec tak, že nejdříve vyberete výstupní buňku, zadáte vzorec do výstupní buňky a potom ho potvrďte stisknutím kombinace kláves CTRL + SHIFT + ENTER . Excel vloží složené závorky na začátku a konci vzorce za vás. Další informace o maticových vzorcích najdete v tématu s pokyny k používání a příklady maticových vzorců.

Funkce Array v průměru pro vyřešení #VALUE! pomocí funkce KDYŽ

Poznámka: Výše uvedená funkce bude kromě funkce #HODNOTA! fungovat také pro funkce #NENÍ_K_DISPOZICI, #NULL, #DĚLENÍ_NULOU! a další.

Stejným způsobem můžete použít také funkci SUMA:

=SUMA(KDYŽ(JE.CHYBHODN(B2:D2);"";B2:D2))

Máte konkrétní otázku k funkci?

Zadejte dotaz do komunitního fóra Excelu

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Viz také

Oprava chyby #HODNOTA! pomocí funkce KDYŽ

PRŮMĚR

SUMA

Přehled vzorců v Excelu

Zjišťování chyb ve vzorcích

Všechny funkce Excelu (podle abecedy)

Všechny funkce v Excelu (podle kategorie)

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Buďte díky Microsoftu 365 o krok napřed

Potřebujete další pomoc?

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×