Přidání nebo odebrání doplňků v Excelu

Doplňky nabízejí nepovinné příkazy a funkce pro aplikaci Microsoft Excel. Doplňky nejsou ve výchozím nastavení v aplikaci Excel okamžitě k dispozici, a proto je nutné je před použitím nejdříve nainstalovat a (v některých případech) aktivovat.

Hledáte informace o tom, Office doplňky založené na HTML, CSS a JS? Pokud jste, podívejte se na Office doplněk pro Excel.

Některé doplňky, třeba Řešitel a Analytické nástroje, jsou integrované v Excelu. Některé jiné doplňky jsou dostupné na webu Download Center a musí se napřed stáhnout a nainstalovat. Poslední skupinu tvoří doplňky, které vytvořila třetí strana, například programátor ve vaší organizaci nebo poskytovatel softwarových řešení. Můžou to být doplňky modelu COM (Component Object Model), doplňky jazyka VBA (Visual Basic for Applications) a doplňky DLL. I tyto doplňky je nutné nainstalovat, aby bylo možné je používat.

Většina doplňků může být rozdělena do tří různých typů:

  • Doplňky Excelu:    Patří mezi ně obvykle doplňky Excelu (soubory .xlam), doplňky Excelu 97–2003 (soubory .xla) nebo doplňky DLL (soubory .xll), nebo jsou to doplňky pro automatizaci. Některé doplňky Excelu, třeba Řešitel a Analytické nástroje, můžou být dostupné po instalaci Excelu nebo Microsoft Office. Většinou stačí jenom tyto doplňky před použitím aktivovat.

  • Doplňky ke stažení:    Další doplňky pro Excel se dají stáhnout a nainstalovat z části Položky ke stažení na webu Office.com.

  • Vlastní doplňky:    Vývojáři a poskytovatelé řešení obvykle vytvářejí vlastní doplňky modelu COM, doplňky pro automatizaci, doplňky jazyka VBA a doplňky XLL. Tyto doplňky je nutné před použitím nainstalovat.

Po instalaci nebo aktivaci mohou být doplněk a obsažené příkazy k dispozici v jednom z následujících umístění:

  • Karta Data Po instalaci a aktivaci doplňků Analytické nástroje a Řešitel jsou příkazy Analýza dat a Řešitel dostupné ve skupině Analýza.

    Skupina Analýza – tlačítko Analýza dat

  • Karta Vzorce Po instalaci a aktivaci nástrojů měny Euro se ve skupině Řešení zobrazí příkazy Převod měny Euro a Formátování měny Euro.

    Převod měny euro a Formátování měny euro

  • Karta Doplňky Další doplňky můžete přidat na kartu Doplňky. Tato karta se přidá na pás karet při instalaci a aktivaci prvního doplňku, který se zobrazí na kartě Doplňky. Pokud kartu Doplňky nevidíte, měli byste ji ukončit a restartovat Excel.

Další doplňky, například karta Začínáme, jsou v aplikaci Excel k dispozici na jiných místech, například jako karta na pásu karet nebo prostřednictvím makra či vlastní nabídky.

Důležité informace: Jestliže jste vývojáři softwaru, můžete tímto postupem nainstalovat nebo odebrat program pro automatizaci dříve, než vytvoříte programy pro instalaci a odebrání tohoto doplňku.

Aktivace doplňku Excelu    

  1. Klikněte na kartu Soubor, na položku Možnosti a poté na kategorii Doplňky.

  2. V rozevíracím seznamu Spravovat klikněte na položku Doplňky aplikace Excel a potom klikněte na tlačítko Přejít.

    Zobrazí se dialogové okno Doplňky.

  3. V seznamu Doplňky k dispozici zaškrtněte políčko u doplňku, který chcete aktivovat, a potom klikněte na tlačítko OK.

Pokud nemůžete doplněk, který chcete aktivovat, nalézt v seznamu Doplňky k dispozici, pravděpodobně jej bude nutné nainstalovat.

Instalace doplňku Excelu    

  • Když chcete instalovat doplněk, který se obvykle instaluje s Excelem (například doplňky Řešitel nebo Analytické nástroje), spusťte instalační program Excelu nebo Microsoft Office, zvolte Změnit a nainstalujte doplněk. Po restartování Excelu by měl být doplněk zobrazený v seznamu Doplňky k dispozici.

  • Některé doplňky aplikace Excel jsou umístěny v počítači a lze je nainstalovat a aktivovat kliknutím na tlačítko Procházet (v dialogovém okně Doplňky), vyhledáním doplňku a kliknutím na tlačítko OK.

  • Některé doplňky aplikace Excel vyžadují spuštění instalačního balíčku. Pravděpodobně bude nutné stáhnout nebo zkopírovat do počítače instalační balíček (instalační balíček je obvykle soubor s příponou MSI) a spustit jej.

  • Jiné doplňky, které nejsou na počítači dostupné, se dají stáhnout a nainstalovat pomocí webového prohlížeče z webu Soubory ke stažení nebo z jiných webů na internetu nebo ze serveru vaší organizace. Postupujte podle pokynů ke stažení.

Deaktivace doplňku Excelu    

  1. Klikněte na kartu Soubor, na položku Možnosti a poté na kategorii Doplňky.

  2. V rozevíracím seznamu Spravovat klikněte na položku Doplňky aplikace Excel a potom klikněte na tlačítko Přejít.

  3. V seznamu Doplňky k dispozici zrušte zaškrtnutí políčka u doplňku, který chcete dezaktivovat, a potom klikněte na tlačítko OK.

    V mnoha případech je doplněk po dezaktivaci odebrán z příslušné skupiny na pásu karet. V jiných případech bude doplněk odebrán z pásu karet až po opakovaném spuštění aplikace Excel.

    Poznámka:    Dezaktivací doplňku neodeberete doplněk z počítače. Chcete-li doplněk odebrat z počítače, musíte ho odinstalovat.

Odebrání doplňku Excelu    

Důležité informace: Pokud jste doplněk Excelu původně nainstalovali ze síťového souborového serveru nebo sdílené složky, bude nejspíš potřeba doplněk odebrat z tohoto umístění. Pokud jste doplněk Excelu instalovali z disku CD a po instalaci jste jednotce CD přiřadili jiné písmeno, je nutné ho přeinstalovat z disku CD. Pokud spouštíte jakékoliv doplňky Excelu z disku CD, je potřeba doplňky Excelu nejdřív odinstalovat a potom je znova nainstalovat z disku CD.

  1. Klikněte na kartu Soubor a potom na Konec.

  2. V ovládacích panelech klikněte na možnost Programy a funkce (Windows 7 a Windows Vista) nebo Přidat nebo odebrat programy (Windows XP).

  3. Proveďte jeden z následujících kroků:

    • Jestliže jste aplikaci Excel nainstalovali jako součást sady Microsoft Office, klikněte v seznamu nainstalovaných programů na položku Microsoft Office a potom na tlačítko Změnit.

    • Pokud jste aplikaci Excel nainstalovali samostatně, klikněte v seznamu nainstalovaných programů na název aplikace a potom klikněte na tlačítko Změnit.

    • Pokud jste doplněk nainstalovali z webu Download Center, klikněte na název programu v seznamu nainstalovaných programů a potom klikněte na tlačítko Odinstalovat.

  4. Postupujte podle pokynů instalačního programu.

Důležité informace: Jestliže jste vývojáři softwaru, můžete tímto postupem nainstalovat nebo odebrat program pro automatizaci dříve, než vytvoříte programy pro instalaci a odebrání tohoto doplňku. Pokud nejste vývojáři, neměli byste tento postup potřebovat. Pokyny k instalaci nebo odebrání doplňku vám poskytne správce systému, který jej dodal.

Přidání doplňku modelu COM

  1. Klikněte na kartu Soubor, na položku Možnosti a poté na kategorii Doplňky.

  2. V seznamu Spravovat klikněte na Doplňky modelu COM a klikněte na Přejít.

    Zobrazí se dialogové okno Doplňky modelu COM.

  3. Zaškrtněte v seznamu Doplňky k dispozici políčko u doplňku, který chcete nainstalovat, a potom klikněte na tlačítko OK.

    Tip:    Pokud není doplněk, který chcete použít, uveden v seznamu Doplňky k dispozici, klikněte na tlačítko Přidat a požadovaný doplněk vyhledejte.

Odebrání doplňku modelu COM

  1. Klikněte na kartu Soubor, na položku Možnosti a poté na kategorii Doplňky.

  2. V seznamu Spravovat klikněte na Doplňky modelu COM a klikněte na Přejít.

    Zobrazí se dialogové okno Doplňky modelu COM.

  3. V seznamu Doplňky k dispozici zrušte zaškrtnutí políčka u doplňku, který chcete odebrat, a potom klikněte na tlačítko OK.

    Poznámka:    Tím odeberete doplněk z paměti, ale jeho název zůstane zachován v seznamu doplňků, které jsou k dispozici. Touto akcí neodstraníte doplněk z počítače.

  4. Pokud chcete doplněk modelu COM odebrat ze seznamu dostupných doplňků a odstranit jej z počítače, klikněte na název doplňku v seznamu Doplňky k dispozici a potom na tlačítko Odebrat.

Poznámka: Jestliže jste vývojáři softwaru, můžete tímto postupem nainstalovat nebo odebrat program pro automatizaci dříve, než vytvoříte programy pro instalaci a odebrání tohoto doplňku. Pokud nejste vývojáři, neměli byste tento postup potřebovat. Pokyny k instalaci nebo odebrání doplňku vám poskytne správce systému, který jej dodal.

  1. Klikněte na kartu Soubor, na položku Možnosti a poté na kategorii Doplňky.

  2. V rozevíracím seznamu Spravovat klikněte na položku Doplňky aplikace Excel a potom klikněte na tlačítko Přejít.

    Zobrazí se dialogové okno Doplňky.

  3. Pokud chcete nainstalovat doplněk pro automatizaci, klikněte v seznamu Automatizační servery k dispozici na Automatizace a potom na požadovaný doplněk.

    Tip:    Pokud není požadovaný doplněk v seznamu uveden, klikněte na tlačítko Procházet, vyhledejte doplněk a klikněte na tlačítko OK.

  4. Chcete-li doplněk pro automatizaci odebrat, je nutné jej odebrat z registru. Podrobnosti vám poskytne správce systému.

Některé doplňky, třeba Řešitel a Analytické nástroje, jsou integrované v Excelu. Některé jiné doplňky jsou dostupné na webu Download Center a musí se napřed stáhnout a nainstalovat. Poslední skupinu tvoří doplňky, které vytvořila třetí strana, například programátor ve vaší organizaci nebo poskytovatel softwarových řešení. Můžou to být doplňky modelu COM (Component Object Model), doplňky jazyka VBA (Visual Basic for Applications) a doplňky DLL. I tyto doplňky je nutné nainstalovat, aby bylo možné je používat.

Většina doplňků může být rozdělena do tří různých typů:

  • Doplňky Excelu:    Patří mezi ně obvykle doplňky Excelu (soubory .xlam), doplňky Excelu 97–2003 (soubory .xla) nebo doplňky DLL (soubory .xll), nebo jsou to doplňky pro automatizaci. Některé doplňky Excelu, třeba Řešitel a Analytické nástroje, můžou být dostupné po instalaci Excelu nebo Microsoft Office. Většinou stačí jenom tyto doplňky před použitím aktivovat.

  • Doplňky ke stažení:    Další doplňky pro Excel se dají stáhnout a nainstalovat z části Položky ke stažení na webu Office.com.

  • Vlastní doplňky:    Vývojáři a poskytovatelé řešení obvykle vytvářejí vlastní doplňky modelu COM, doplňky pro automatizaci, doplňky jazyka VBA a doplňky XLL. Tyto doplňky je nutné před použitím nainstalovat.

Po instalaci nebo aktivaci mohou být doplněk a obsažené příkazy k dispozici v jednom z následujících umístění:

  • Karta Data Po instalaci a aktivaci doplňků Analytické nástroje a Řešitel jsou příkazy Analýza dat a Řešitel dostupné na kartě Data na pásu karet.

  • Karta Domů Další doplňky můžete přidat na kartu Domů.

Další doplňky, například karta Začínáme, jsou v aplikaci Excel k dispozici na jiných místech, například jako karta na pásu karet nebo prostřednictvím makra či vlastní nabídky.

Důležité informace: Jestliže jste vývojáři softwaru, můžete tímto postupem nainstalovat nebo odebrat program pro automatizaci dříve, než vytvoříte programy pro instalaci a odebrání tohoto doplňku.

Aktivace předinstalovaných Excel doplňku    

  1. V nabídce Nástroje vyberte Doplňky.

  2. V seznamu Doplňky, které jsou k dispozici, zaškrtněte políčko u doplňku, který chcete aktivovat, a potom klikněte na OK.

Instalace doplňku Excelu    

  • Některé Excel jsou umístěné na vašem počítači a instalované nebo aktivované kliknutím na Procházet (v dialogovém okně Doplňky výše) vyhledejte doplněk a potom klikněte na OK.

  • Některé doplňky aplikace Excel vyžadují spuštění instalačního balíčku. Pravděpodobně bude nutné stáhnout nebo zkopírovat do počítače instalační balíček (instalační balíček je obvykle soubor s příponou MSI) a spustit jej.

  • Další doplňky, které nejsou na vašem počítači k dispozici, si můžete stáhnout a nainstalovat prostřednictvím webového prohlížeče ze složky Soubory ke stažení nebo z jiných webů na internetu, serveru ve vaší organizaci nebo pomocí předdefinované možnosti Storu v Excel. Postupujte podle pokynů ke stažení.

    Instalace doplňků ze Storu

    1. Na pásu karet klikněte na kartu Vložení.

    2. Klikněte na tlačítko Store.

    3. K vyhledánídoplňků použijte pole Kategorie nebo Hledat.

    4. Pokud chcete doplněk nainstalovat, klikněte na Přidat.

      Poznámka: Některé doplňky je potřeba koupit.

Odebrání doplňku Excelu    

  1. Klikněte na kartu Vložení a potom klikněte na Moje doplňky.

  2. V Office doplňkyklikněte na nabídku 3 tečky vedle doplňku.

  3. Klikněte na tlačítko Odebrat.

  4. Přečtěte si oznámení, které se zobrazí u jiných zařízení, a klikněte na Odebrat.

Potřebujete další pomoc?

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

×