Používání vnořených funkcí ve vzorcích

Použití funkce jako jednoho z argumentů ve vzorci, který používá funkci, se nazývá vnoření a budeme na tuto funkci odkazovat jako na vnořenou funkci. Když třeba funkce PRŮMĚR a SUMA vnořuje do argumentů funkce KDYŽ, sečte následující vzorec sadu čísel (G2:G5), jenom pokud je průměr jiné sady čísel (F2:F5) větší než 50. V opačném případě vrátí hodnotu 0.

Vnořené funkce

Funkce PRŮMĚR a SUMA jsou vnořené do funkce KDYŽ.

Ve vzorci můžete vnořit až 64 úrovní funkcí.

  1. Klikněte na buňku, do které chcete zadat vzorec.

  2. Pokud chcete začít vzorec s funkcí, klikněte na vložit funkci Obrázek tlačítka na řádku vzorců Obrázek tlačítka .

    Aplikace Excel automaticky vloží symbol rovná se (=).

  3. V poli se seznamem Vybrat kategorii vyberte položku Vše.

    Máte-li zkušenosti s kategoriemi funkcí, můžete také vybrat kategorii.

    Pokud si nejste jisti tím, kterou funkci chcete použít, můžete do pole Vyhledat funkci zadat dotaz, který vystihuje, co si přejete udělat (například text „sečíst čísla“ vrátí funkci SUMA).

  4. Pokud chcete jako argument zadat jinou funkci, zadejte ji do pole argumentu, které chcete.

    Části vzorce zobrazené v dialogovém okně Argumenty funkce odrážejí funkci, kterou jste vybrali v předchozím kroku.

    Pokud jste klikli na KDYŽ, zobrazí se v dialogovém okně Argumenty funkce argumenty funkce KDYŽ. Pokud chcete vnořit jinou funkci, můžete ji zadat do pole argumentu. Můžete třeba zadat SUMA(G2:G5)do Value_if_true funkce KDYŽ.

  5. Zadejte všechny další argumenty, které jsou potřeba k dokončení vzorce.

    Namísto zadávání odkazů na buňky stačí vybrat buňku, na kterou chcete odkazovat. Kliknutím Obrázek tlačítka minimalizovat dialogové okno, vyberte buňky, na které chcete odkazovat, a potom kliknutím Obrázek tlačítka dialogové okno rozbalte znovu.

    Tip: Další informace o funkci a jejích argumentech more získáte kliknutím na položku Nápověda k této funkci.

  6. Po zadání argumentů pro vzorec klikněte na tlačítko OK.

  1. Klikněte na buňku, do které chcete zadat vzorec.

  2. Pokud chcete začít vzorec s funkcí, klikněte na vložit funkci Obrázek tlačítka na řádku vzorců Obrázek tlačítka .

  3. V dialogovém okně Vložit funkci vyberte v poli Vybrat kategoriimožnost Vše.

    Máte-li zkušenosti s kategoriemi funkcí, můžete také vybrat kategorii.

  4. Pokud chcete jako argument zadat jinou funkci, zadejte ji do pole argumentu v Tvůrci vzorců nebo přímo do buňky.

  5. Zadejte všechny další argumenty, které jsou potřeba k dokončení vzorce.

  6. Po dokončení argumentů vzorce stiskněte enter.

Příklad

Následující příklad ukazuje příklad použití vnořených funkcí KDYŽ k přiřazení známek písmen číselného testovacího skóre.

Zkopírujte vzorová data v následující tabulce a vložte je do buňky A1 nového excelového sešitu. Aby vzorce zobrazily výsledky, vyberte je, stiskněte F2 a potom stiskněte Enter. Pokud potřebujete, můžete přizpůsobit šířky sloupců a zobrazit si všechna data.

Skóre

45

90

78

Vzorec

Popis

Výsledek

'=KDYŽ(A2>89;"A";KDYŽ(A2>79;"B"; KDYŽ(A2>69;"C";KDYŽ(A2>59;"D";"F"))))

Používá vnořené podmínky KDYŽ k přiřazení známek k skóre v buňce A2.

=KDYŽ(A2>89;"A";KDYŽ(A2>79;"B";KDYŽ(A2>69;"C";KDYŽ(A2>59;"D";"F"))))

'=KDYŽ(A3>89;"A";KDYŽ(A3>79;"B"; KDYŽ(A3>69;"C";KDYŽ(A3>59;"D";"F"))))

Používá vnořené podmínky KDYŽ k přiřazení známek k skóre v buňce A3.

=KDYŽ(A3>89;"A";KDYŽ(A3>79;"B";KDYŽ(A3>69;"C";KDYŽ(A3>59;"D";"F"))))

'=KDYŽ(A4>89;"A";KDYŽ(A4>79;"B"; KDYŽ(A4>69;"C";KDYŽ(A4>59;"D";"F"))))

Používá vnořené podmínky KDYŽ k přiřazení známek k skóre v buňce A4.

=KDYŽ(A4>89;"A";KDYŽ(A4>79;"B";KDYŽ(A4>69;"C";KDYŽ(A4>59;"D";"F"))))

Tipy: 

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Video: Nested IF functions

Potřebujete další pomoc?

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×