Vkládání čísel stránek na listy

Pokud chcete, aby se čísla při tisku souboru Microsoft Excelu List, můžete čísla stránek vložit do záhlaví nebo zápatí stránek listu. Čísla stránek, která vložíte, se v normálním zobrazení na listu nezobrazují – zobrazují se jenom v zobrazení Rozložení stránky a na vytištěných stránkách.

Poznámka: Snímky obrazovek v tomto článku jsou z Excelu 2016. Pokud máte jinou verzi, může se zobrazení trochu lišit, ale pokud není uvedeno jinak, funkce se nemění.

Vložit čísla stránek do jednoho listu

  1. Klikněte na list, pro který chcete vložit čísla stránek.

  2. Na kartě Vložení klikněte ve skupině Text na položku Záhlaví a zápatí.

    Možnost Záhlaví a zápatí na kartě Vložení

    Aplikace Excel otevře list v zobrazení Rozložení stránky. Toto zobrazení lze také zobrazit Obrázek tlačítka na stavovém řádku kliknutím na tlačítko Rozložení stránky.

  3. Na listu klikněte na položku Kliknutím přidáte záhlaví nebo Kliknutím přidáte zápatí.

    Tím zobrazíte panel Nástroje záhlaví a zápatí a přidáte do něj kartu Návrh.

  4. Chcete-li upřesnit místo , kde se má číslo stránky v záhlaví nebo v zápatí zobrazit, klikněte v záhlaví nebo v zápatí do pole Levý oddíl, Prostřední oddíl nebo Pravý oddíl.

  5. Na kartě Návrh klikněte ve skupinovém rámečku Prvky záhlaví a zápatí na položku Číslo stránky.

    Ve skupině Prvky záhlaví a zápatí klikněte na Číslo stránky

    Ve vybraném oddílu se zobrazí zástupný text &[Stránka].

    Chcete-li přidat celkový počet stránek, napište za zástupným textem &[Stránka] mezeru, napište písmeno z a mezeru a potom ve skupinovém rámečku Prvky záhlaví a zápatí klikněte na položku Počet stránek.

    Ve vybraném oddílu se zobrazí zástupný text &[Stránka] z &[Stránek].

  6. Kliknutím na libovolné místo mimo oblast záhlaví nebo zápatí se v zobrazení Rozložení stránky zobrazí skutečná čísla stránek.

  7. Po dokončení práce v zobrazení Rozložení stránky klikněte na kartě Zobrazení ve skupině Zobrazení sešitů na možnost Normálně.

    Na kartě Zobrazení klikněte na Normálně.

    Můžete taky kliknout na Obrázek tlačítka na stavovém řádku.

    Čísla stránek můžete na list vložit v zobrazení rozložení stránky, kde je uvidíte, nebo můžete použít dialog Vzhled stránky, a to když chcete vložit čísla stránek pro několik listů najednou. U jiných typů listů, jako jsou třeba listy s grafem, můžete čísla stránek vložit jenom pomocí dialogu Vzhled stránky.

Přidání čísel stránek do více listů

Do více listů v sešitě lze čísla stránek vložit pomocí dialogového okna Vzhled stránky. Obsahuje-li například sešit dva dvoustránkové listy, bude první list obsahovat dvě stránky číslované 1 a 2. Druhý list bude obsahovat taky dvě stránky s čísly 1 a 2.

Tip: Pokud chcete přidat čísla stránek tak, aby na jednotlivých listech v sešitu navazovala, je potřeba změnit číslo, kterým číslování na každém listu začíná. Další informace naleznete v části Nastavení jiného čísla pro počáteční stránku.

  1. Klikněte na listy nebo listy s grafem, na které chcete přidat čísla stránek.

Požadovaný výběr

Akce

Jeden list

Klikněte na ouško listu.

Klikněte na ouško listu.

Pokud není požadovaného ouško listu viditelné, klikněte na tlačítka pro pohyb mezi listy tak, aby se zobrazilo. Potom klikněte na ouško listu.

Klikněte na šipky pro pohyb mezi listy.

Dva nebo více sousedících listů

Klikněte na ouško prvního listu. Pak při kliknutí na ouško posledního listu, který chcete vybrat, podržte stisknutou klávesu Shift.

Dva nebo více listů, které spolu nesousedí

Klikněte na ouško prvního listu. Pak při kliknutí na ouška ostatních listů, které chcete vybrat, podržte stisknutou klávesu Ctrl.

Všechny listy v sešitu

Klikněte pravým tlačítkem myši na ouško listu a potom v Místní nabídka klikněte na příkaz Vybrat všechny listy.

Tip: Pokud je vybráno více listů, je v záhlaví v horní části listu zobrazen text [Skupina]. Chcete-li zrušit výběr více listů v sešitu, klikněte na libovolný list, který není vybraný. Jestliže není žádný nevybraný list viditelný, klikněte pravým tlačítkem myši na ouško některého vybraného listu a potom klikněte na příkaz Oddělit listy.

  1. Na kartě Rozložení stránky klikněte ve skupině Vzhled stránky na ikonu pro otevření dialogového okna Obrázek tlačítka vedle možnosti Vzhled stránky.

    Klikněte na šipku v pravém dolním rohu skupiny Vzhled stránky.

  2. V dialogovém okně Vzhled stránky na kartě Záhlaví a zápatí klikněte na tlačítko Vlastní záhlaví nebo Vlastní zápatí.

  3. Chcete-li upřesnit místo , kde se má číslo stránky v záhlaví nebo v zápatí zobrazit, klikněte do pole Levý oddíl, Prostřední oddíl nebo Pravý oddíl.

  4. Pokud chcete vložit čísla, klikněte na tlačítko Vložit číslo stránky Obrázek tlačítka .

    Ve vybraném oddílu se zobrazí zástupný text &[Stránka].

    Poznámky: 

    • Pokud chcete přidat celkový počet stránek, napište za &[Page]mezeru, zadejte slovo následované mezerou a klikněte na tlačítko Vložit počet stránek Obrázek tlačítka .

    • Ve vybraném oddílu se zobrazí zástupný text &[Stránka] z &[Stránek].

Nastavení jiného čísla pro počáteční stránku

Chcete-li stránky v jednotlivých listech v sešitě očíslovat postupně, vložte nejprve čísla stránek do všech listů a poté pomocí následujícího postupu nastavte číslování stránek v jednotlivých listech od odpovídajícího čísla. Pokud například sešit obsahuje dva listy a každý z nich se vytiskne na dvou stránkách, začali byste pomocí uvedeného postupu číslování stránek ve druhém listu od čísla 3.

  1. Na kartě Rozložení stránky klikněte ve skupině Vzhled stránky na ikonu pro otevření dialogového okna Obrázek tlačítka vedle možnosti Vzhled stránky.

    Klikněte na šipku v pravém dolním rohu skupiny Vzhled stránky.

  2. Na kartě Stránka zadejte do pole Číslo první stránky číslo, které chcete použít na první stránce.

    Pokud chcete použít výchozí systém číslování, napište do pole Číslo první stránky slovo automaticky.

Změna pořadí, ve kterém jsou stránky číslovány

Aplikace Excel ve výchozím nastavení čísluje a tiskne stránky na listu odshora dolů a potom zleva doprava, ale můžete to změnit tak, že se stránky budou číslovat a tisknout nejprve zleva doprava a potom odshora dolů.

  1. Klikněte na list, u kterého chcete změnit pořadí číslování.

  2. Na kartě Rozložení stránky klikněte ve skupině Vzhled stránky na ikonu pro otevření dialogového okna Obrázek tlačítka vedle možnosti Vzhled stránky.

    Klikněte na šipku v pravém dolním rohu skupiny Vzhled stránky.

  3. Na kartě List v oddílu Pořadí tisku stránek klikněte na možnost Dolů, pak příčně nebo Příčně, pak dolů.

    Směr každé volby je zobrazen v poli s náhledem.

Odebrání čísel stránek

  1. Klikněte na listy nebo listy s grafy, ze kterých chcete odebrat čísla stránek.

Požadovaný výběr

Akce

Jeden list

Klikněte na ouško listu.

Klikněte na ouško listu.

Pokud není požadovaného ouško listu viditelné, klikněte na tlačítka pro pohyb mezi listy tak, aby se zobrazilo. Potom klikněte na ouško listu.

Klikněte na šipky pro pohyb mezi listy.

Dva nebo více sousedících listů

Klikněte na ouško prvního listu. Pak při kliknutí na ouško posledního listu, který chcete vybrat, podržte stisknutou klávesu Shift.

Dva nebo více listů, které spolu nesousedí

Klikněte na ouško prvního listu. Pak při kliknutí na ouška ostatních listů, které chcete vybrat, podržte stisknutou klávesu Ctrl.

Všechny listy v sešitu

Klikněte pravým tlačítkem myši na ouško listu a potom v Místní nabídka klikněte na příkaz Vybrat všechny listy.

Tip: Pokud je vybráno více listů, je v záhlaví v horní části listu zobrazen text [Skupina]. Chcete-li zrušit výběr více listů v sešitu, klikněte na libovolný list, který není vybraný. Jestliže není žádný nevybraný list viditelný, klikněte pravým tlačítkem myši na ouško některého vybraného listu a potom klikněte v místní nabídce na příkaz Oddělit listy.

  1. Na kartě Rozložení stránky klikněte ve skupině Vzhled stránky na ikonu pro otevření dialogového okna Obrázek tlačítka vedle možnosti Vzhled stránky.

    Klikněte na šipku v pravém dolním rohu skupiny Vzhled stránky.

  2. Na kartě Záhlaví a zápatí klikněte v rozevíracím seznamu Záhlaví nebo Zápatí na položku (Žádné).

    Poznámka: Pravděpodobně bude nutné přejít do horní části seznamu, aby bylo možné kliknout na tlačítko (žádné).

  • Kterou verzi používáte?
  • Novější verze
  • Excel for Mac 2011

Přidání čísel stránek

  1. Na kartě Vložení klikněte na Záhlaví a zápatí.

    Excel automaticky přepne na zobrazení Rozložení stránky.

  2. Na kartě & Záhlaví a zápatí klikněte na Záhlaví nebo Zápatí a potom vyberte formát čísel stránek, který chcete použít.

    Čísla stránek záhlaví se zobrazují v horní části vytištěné stránky a čísla stránek zápatí se zobrazí dole.

  3. Až budete hotovi, můžete zůstat v zobrazení Rozložení stránky nebo můžete přepnout do normálního zobrazení kliknutím na Normální na kartě Zobrazení.

Nastavení jiného čísla pro počáteční stránku

První vytištěný list může začíná jiným číslem stránky než 1. To je užitečné, pokud jsou před listem další vytištěné stránky. Můžete třeba vytisknout 2 stránkový wordový dokument, který bude ovat stránky 1 a 2, a excelový list by pak začal na stránce 3.

  1. Na kartě Rozložení stránky klikněte na Vzhled stránky.

  2. Na kartě Stránka zadejte do pole Číslo první stránky číslo první stránky, které chcete použít. Pokud byste například chtěli, aby číslo první stránky bylo 3,napište číslo 3.

  3. Klikněte na OK.

Pokud používáte formát čísla stránky, který spočítá celkový počet stránek, například: Stránka 3 z 7,je potřeba upravit druhé číslo. Tato úprava zajistí, že na konci nebude něco takového: Stránka 10 ze 7.

  1. In Page Setup,click the Header/Footer tab, and then click either Custom Header or Custom Footer.

  2. Za & [Page] &[Pages] (Stránka)zadejte znaménko plus (+) a potom zadejte počet stránek, které se zobrazí před číslem první stránky.

    Pokud je například číslo první stránky číslo 3, musíte do celkového počtu stránek zahrnout 2 stránky. Na konec stránky zadejte +2: Page &[Page] of &[Pages]+2 a klikněte na OK.

  3. Znovu klikněte na tlačítko OK.

Změna pořadí číslování stránek

  1. Na kartě Rozložení stránky klikněte na Vzhled stránkya potom klikněte na List.

  2. V části Pořadí stránekvyberte požadovanou pořadí číslování stránek.

Odebrání čísel stránek

  1. Na kartě Rozložení stránky klikněte na Vzhled stránkya potom klikněte na Záhlaví a zápatí.

  2. V části Záhlaví nebo zápatívyberte (žádné).

    Abyste v horní části seznamu našli (žádné), budete možná muset zobrazení posunout.

Přidání čísel stránek

  1. Na kartě Rozložení klikněte v části Vzhled stránkyna Záhlaví a & zápatí.

  2. V místní nabídce v části Záhlavínebozápatí vyberte formát čísla stránky, který chcete přidat.

    Formáty záhlaví se zobrazují v horní části vytištěné stránky a formáty zápatí se zobrazí dole.

    Tipy: 

    • Zobrazením listu v režimu náhledu se můžete podívat, jak budou čísla stránek vypadat. Na kartě Rozložení klikněte v části Tisk naNáhled.

    • Pokud chcete přidat čísla stránek do více listů v sešitu najednou, vyberte před kliknutím na záhlaví a zápatí & listy. Zvolený formát čísla stránky se použije na všechny vybrané listy.

    • Zcela vlastní záhlaví nebo zápatí s čísly stránek můžete vytvořit kliknutím na Vlastní nastavení záhlaví nebo zápatí a podle uvedených pokynů.

Nastavení jiného čísla pro počáteční stránku

  1. Na kartě Rozložení klikněte v části Vzhled stránkyna Záhlaví a & zápatí.

  2. Přidejte čísla stránek v formátu, který chcete.

  3. Klikněte na Vlastní nastavení záhlaví nebo Přizpůsobit zápatípodle toho, kde se čísla stránek zobrazují.

  4. Vyhledejte kód čísla stránky &[Page]a kliknutím hned za něj přesuňte kurzor na toto místo.

  5. Zadejte znaménko plus (+) a potom zadejte počet stránek, o které chcete přestoupit na počáteční stránku. Pokud třeba chcete začít na stránce 4, zvětšuje se počáteční číslo stránky o tři stránky, takže napíšete +3. Kód se teď zobrazí jako &[Page]+3.

  6. Klikněte na OK.

    V poli Záhlavínebo zápatí se zobrazí nové záhlaví nebo zápatí první stránky.

    Poznámka: Pokud chcete použít formát čísla stránky, který obsahuje celkový počet stránek, například Stránka 4 z 7,nezapomeňte přidat znaménko plus (+) a číslo stránky se zvětšuje k celkovému kódu stránek,&[Pages].

Změna pořadí číslování stránek

  1. Na kartě Rozložení klikněte v části Vzhled stránkyna Záhlaví a & zápatí.

  2. Na kartě List vyberte v části Pořadí stránekpořadí číslování stránek, které chcete použít.

Odebrání čísel stránek

  1. Na kartě Rozložení klikněte v části Vzhled stránkyna Záhlaví a & zápatí.

  2. V místní nabídce v části Záhlaví nebo zápatívyberte (žádné).

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení ve fóru Excel User Voice.

Potřebujete další pomoc?

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×