Vložení objektu do excelové tabulky

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Pomocí OLE (Object Linking and Embedding) můžete zahrnout obsah z jiných programů, jako je Word nebo Excel.

Technologie OLE je podporována mnoha různými programy a technologie OLE se používá ke zpřístupnění obsahu v jedné aplikaci v jiné aplikaci. Můžete například vložit dokument Office Word do sešitu aplikace Office Excel. Pokud chcete zjistit, jaké typy obsahu můžete vložit, klikněte na kartě vložení ve skupině text na objekt . V poli Object Type (typ objektu ) se zobrazí jenom programy, které jsou nainstalované v počítači a které podporují objekty OLE.

Pokud kopírujete informace mezi Excelem nebo aplikací, které podporují OLE, třeba Word, můžete informace zkopírovat jako Propojený objekt nebo jako Vložený objekt. Hlavní rozdíly mezi propojenými a vloženými objekty jsou místo, kde jsou uložena data a jak se po umístění objektu do Cílový soubor aktualizuje. Vložené objekty jsou uložené v sešitu, ve kterém jsou vložené, a nejsou aktualizovány. Propojené objekty zůstanou jako samostatné soubory a mohou být aktualizovány.

Propojené a vložené objekty v dokumentu

Propojené a vložené objekty v dokumentu Office pro Windows

1. vložený objekt nemá žádné připojení ke zdrojovému souboru.

2. propojený objekt je propojený se zdrojovým souborem.

3. zdrojový soubor aktualizuje propojený objekt.

Kdy použít propojené objekty

Pokud chcete, aby se informace v Cílový soubor aktualizovaly při změnách dat ve Zdrojový soubor, použijte propojené objekty.

V případě propojeného objektu zůstávají původní informace uloženy ve zdrojovém souboru. Cílový soubor zobrazí prezentaci propojených informací, ale uloží jenom umístění původních dat (a velikost, pokud je objekt objekt grafu Excelu). Pokud chcete zachovat odkaz na původní data, musí být zdrojový soubor dostupný na vašem počítači nebo v síti.

Propojené informace mohou být automaticky aktualizovány, pokud změníte původní data ve zdrojovém souboru. Pokud například ve wordovém dokumentu vyberete odstavec a potom ho vložíte jako propojený objekt do excelového sešitu, můžete tyto informace aktualizovat v Excelu, pokud změníte informace ve wordovém dokumentu.

Kdy používat vložené objekty

Pokud nechcete zkopírovaná data při změnách ve zdrojovém souboru aktualizovat, použijte vložený objekt. Verze zdroje se v sešitu vloží úplně. Pokud kopírujete informace jako vložený objekt, vyžaduje cílový soubor více místa na disku, než když informace propojíte.

Když uživatel otevře soubor na jiném počítači, může vložený objekt zobrazit bez přístupu k původním datům. Vzhledem k tomu, že vložený objekt neobsahuje žádné odkazy na zdrojový soubor, není při změně původních dat objekt aktualizován. Pokud chcete vložený objekt změnit, poklikejte na něj a otevřete ho ve zdrojové aplikaci. Zdrojový program (nebo jiný program, který by mohl upravit objekt) musí být nainstalovaný v počítači.

Změna způsobu zobrazení objektu OLE

Propojený objekt nebo Vložený objekt můžete v sešitu zobrazit přesně tak, jak se zobrazuje v Zdrojový program nebo jako ikona. Pokud se sešit zobrazí online a nechcete sešit vytisknout, můžete ho zobrazit jako ikonu. Tím se minimalizuje velikost místa, které objekt zabírá. Návštěvníci, kteří chtějí zobrazit informace, můžou poklepat na ikonu.

Vložení objektu do listu

  1. Klikněte do buňky tabulky, kam chcete vložit objekt.

  2. Na kartě vložení klikněte ve skupině text na položku objekt Ikona objektu na pásu karet .
    Vložení objektu

  3. V dialogovém okně objekt klikněte na kartu vytvořit ze souboru .

  4. Klikněte na Procházeta vyberte soubor, který chcete vložit.

  5. Pokud chcete vložit ikonu do tabulky místo zobrazení obsahu souboru, zaškrtněte políčko Zobrazit jako ikonu . Pokud nezaškrtnete žádné políčko, Excel zobrazí první stránku souboru. V obou případech se otevře celý soubor poklikáním. Klikněte na OK.

    Poznámka: Po přidání ikony nebo souboru ji můžete na listu přetáhnout kamkoli. Pomocí úchytů pro změnu velikosti můžete změnit velikost ikony nebo souboru. Pokud chcete úchyty najít, klikněte na něj jednou.

Vložení odkazu na soubor

Místo úplného vkládání můžete jednoduše přidat odkaz na objekt. Tento postup můžete použít, pokud je sešit i objekt, který chcete přidat, uložený na SharePointovém webu, sdílené síťové jednotce nebo podobném umístění a jestli soubory zůstanou stejné. Tato funkce je užitečná, pokud propojený objekt odkazuje na změny, protože odkaz vždy otevře nejaktuálnější dokument.

Poznámka: Pokud propojený soubor přesunete do jiného umístění, nebude už odkaz fungovat.

  1. Klikněte do buňky tabulky, kam chcete vložit objekt.

  2. Na kartě vložení klikněte ve skupině text na položku objekt Ikona objektu na pásu karet .
    Vložení objektu

  3. Klikněte na kartu vytvořit ze souboru .

  4. Klikněte na Procházeta vyberte soubor, který chcete propojit.

  5. Zaškrtněte políčko propojit se souborem a klikněte na tlačítko OK.

Vytvoření nového objektu v aplikaci Excel

Zcela nový objekt můžete vytvořit na základě jiného programu, aniž byste museli opustit sešit. Pokud chcete například do grafu nebo tabulky přidat podrobnější vysvětlení, můžete v Excel vytvořit vložený dokument, třeba Word nebo PowerPoint. Můžete buď nastavit, aby se objekt zobrazoval přímo v listu, nebo přidat ikonu, která soubor otevře.

Tento vložený objekt je wordový dokument.
  1. Klikněte do buňky tabulky, kam chcete vložit objekt.

  2. Na kartě vložení klikněte ve skupině text na položku objekt Ikona objektu na pásu karet .
    Vložení objektu

  3. Na kartě vytvořit novou vyberte z nabídnutého seznamu typ objektu, který chcete vložit. Pokud chcete vložit ikonu do tabulky místo samotného objektu, zaškrtněte políčko Zobrazit jako ikonu .

  4. Klikněte na OK. V závislosti na typu vkládaného souboru se otevře nové okno aplikace nebo se v Excelu zobrazí okno pro úpravy.

  5. Vytvořte nový objekt, který chcete vložit.

    Až skončíte a Excel otevře nové okno aplikace, ve kterém jste vytvořili objekt, můžete pracovat přímo s ním.

    Vložený wordový dokument můžete upravit přímo v Excelu.

    Až budete s práci v okně hotovi, můžete provádět další úkoly bez uložení vloženého objektu. Při zavření sešitu budou nové objekty automaticky uloženy.

    Poznámka: Po přidání můžete objekt přetáhnout kamkoli do listu Excel. Velikost objektu můžete změnit také pomocí úchytů pro změnu velikosti. Úchyty vyhledáte kliknutím na objekt.

Vložení objektu do listu

  1. Klikněte do buňky tabulky, kam chcete vložit objekt.

  2. Na kartě Vložení klikněte ve skupině Text na tlačítko Objekt.

    Možnost Objekt je na kartě Vložení.
  3. Klikněte na kartu vytvořit ze souboru .

    Karta Vytvořit ze souboru v dialogovém okně Objekt
  4. Klikněte na Procházeta vyberte soubor, který chcete vložit.

  5. Pokud chcete vložit ikonu do tabulky místo zobrazení obsahu souboru, zaškrtněte políčko Zobrazit jako ikonu . Pokud nezaškrtnete žádné políčko, Excel zobrazí první stránku souboru. V obou případech se otevře celý soubor poklikáním. Klikněte na OK.

    Poznámka: Po přidání ikony nebo souboru ji můžete na listu přetáhnout kamkoli. Pomocí úchytů pro změnu velikosti můžete změnit velikost ikony nebo souboru. Pokud chcete úchyty najít, klikněte na něj jednou.

Vložení odkazu na soubor

Místo úplného vkládání můžete jednoduše přidat odkaz na objekt. Tento postup můžete použít, pokud je sešit i objekt, který chcete přidat, uložený na SharePointovém webu, sdílené síťové jednotce nebo podobném umístění a jestli soubory zůstanou stejné. Tato funkce je užitečná, pokud propojený objekt odkazuje na změny, protože odkaz vždy otevře nejaktuálnější dokument.

Poznámka: Pokud propojený soubor přesunete do jiného umístění, nebude už odkaz fungovat.

  1. Klikněte do buňky tabulky, kam chcete vložit objekt.

  2. Na kartě Vložení klikněte ve skupině Text na tlačítko Objekt.

    Možnost Objekt je na kartě Vložení.
  3. Klikněte na kartu vytvořit ze souboru .

  4. Klikněte na Procházeta vyberte soubor, který chcete propojit.

  5. Zaškrtněte políčko propojit se souborem a klikněte na tlačítko OK.

    Na kartě Vytvořit ze souboru zaškrtněte políčko Propojit se souborem.

Vytvoření nového objektu v aplikaci Excel

Zcela nový objekt můžete vytvořit na základě jiného programu, aniž byste museli opustit sešit. Pokud chcete například do grafu nebo tabulky přidat podrobnější vysvětlení, můžete v Excel vytvořit vložený dokument, třeba Word nebo PowerPoint. Můžete buď nastavit, aby se objekt zobrazoval přímo v listu, nebo přidat ikonu, která soubor otevře.

Tento vložený objekt je wordový dokument.
  1. Klikněte do buňky tabulky, kam chcete vložit objekt.

  2. Na kartě Vložení klikněte ve skupině Text na tlačítko Objekt.

    Možnost Objekt je na kartě Vložení.
  3. Na kartě vytvořit novou vyberte z nabídnutého seznamu typ objektu, který chcete vložit. Pokud chcete vložit ikonu do tabulky místo samotného objektu, zaškrtněte políčko Zobrazit jako ikonu .

    Karta Vytvořit nový v dialogovém okně Objekt
  4. Klikněte na OK. V závislosti na typu vkládaného souboru se otevře nové okno aplikace nebo se v Excelu zobrazí okno pro úpravy.

  5. Vytvořte nový objekt, který chcete vložit.

    Až skončíte a Excel otevře nové okno aplikace, ve kterém jste vytvořili objekt, můžete pracovat přímo s ním.

    Vložený wordový dokument můžete upravit přímo v Excelu.

    Až budete s práci v okně hotovi, můžete provádět další úkoly bez uložení vloženého objektu. Při zavření sešitu budou nové objekty automaticky uloženy.

    Poznámka: Po přidání můžete objekt přetáhnout kamkoli do listu Excel. Velikost objektu můžete změnit také pomocí úchytů pro změnu velikosti. Úchyty vyhledáte kliknutím na objekt.

Propojení nebo vložení obsahu z jiného programu pomocí OLE

Můžete propojit nebo vložit celý obsah z jiného programu.

Vytvoření odkazu na obsah z jiné aplikace

  1. Klikněte do listu, kam chcete umístit Propojený objekt.

  2. Na kartě Vložení klikněte ve skupině Text na tlačítko Objekt.

    Vzhled pásu karet aplikace Excel

  3. Klikněte na kartu vytvořit ze souboru .

  4. Do pole název souboru zadejte název souboru nebo klikněte na Procházet a vyberte ho ze seznamu.

  5. Zaškrtněte políčko propojit se souborem .

  6. Udělejte jednu z těchto věcí:

    • Pokud chcete zobrazit obsah, zrušte zaškrtnutí políčka Zobrazit jako ikonu .

    • Pokud chcete zobrazit ikonu, zaškrtněte políčko Zobrazit jako ikonu . Pokud chcete změnit výchozí obrázek ikony nebo popisek, klikněte na změnit ikonua pak klikněte na požadovanou ikonu v seznamu ikon nebo zadejte popisek do pole Titulek .

    Poznámka: Pomocí příkazu objekt nelze vkládat obrázky a určité typy souborů. Pokud chcete vložit grafiku nebo soubor, klikněte na kartě vložení ve skupině ilustrace na Obrázek.

Vložení obsahu z jiné aplikace

  1. Klikněte do listu, kam chcete umístit Vložený objekt.

  2. Na kartě Vložení klikněte ve skupině Text na tlačítko Objekt.

    Vzhled pásu karet aplikace Excel

  3. Pokud dokument ještě neexistuje, klikněte na kartu vytvořit novou . V seznamu typ objektu klikněte na typ objektu, který chcete vytvořit.

    Pokud už dokument existuje, klikněte na kartu vytvořit ze souboru . Do pole název souboru zadejte název souboru nebo klikněte na Procházet a vyberte ho ze seznamu.

  4. Zrušte zaškrtnutí políčka propojit se souborem .

  5. Udělejte jednu z těchto věcí:

    • Pokud chcete zobrazit obsah, zrušte zaškrtnutí políčka Zobrazit jako ikonu .

    • Pokud chcete zobrazit ikonu, zaškrtněte políčko Zobrazit jako ikonu . Pokud chcete změnit výchozí obrázek ikony nebo popisek, klikněte na změnit ikonua pak klikněte na požadovanou ikonu v seznamu ikon nebo zadejte popisek do pole Titulek .

Propojení nebo vložení částečného obsahu z jiného programu

  1. Z jiného programu než Excel vyberte informace, které chcete zkopírovat jako propojený nebo Vložený objekt.

  2. Na kartě Domů klikněte ve skupině Schránka na Kopírovat.

    Vzhled pásu karet aplikace Excel

  3. Přejděte na list, do kterého chcete informace umístit, a potom klikněte na místo, kde se mají informace zobrazit.

  4. Na kartě Domů klikněte ve skupině Schránka na šipku pod tlačítkem Vložit a potom klikněte na položku Vložit jinak.

  5. Udělejte jednu z těchto věcí:

    • Pokud chcete informace vložit jako propojený objekt, klikněte na Vložit propojení.

    • Pokud chcete vložit informace jako vložený objekt, klikněte na Vložit. V poli as klikněte na položku obsahující slovo "objekt" v názvu. Pokud jste například zkopírovali informace z wordového dokumentu, klikněte na objekt dokument Microsoft Word.

Změna způsobu zobrazení objektu OLE

  1. Klikněte pravým tlačítkem myši na ikonu nebo objekt, přejděte naobjekttyp objektu(například objekt dokument) a potom klikněte na převést.

  2. Udělejte jednu z těchto věcí:

    • Pokud chcete zobrazit obsah, zrušte zaškrtnutí políčka Zobrazit jako ikonu .

    • Pokud chcete zobrazit ikonu, zaškrtněte políčko Zobrazit jako ikonu . Můžete také změnit výchozí obrázek ikony nebo popisek. To provedete tak, že kliknete na změnit ikonua potom na požadovanou ikonu v seznamu ikon nebo zadáte popisek do pole Titulek .

Aktualizace propojených objektů

Odkazy na jiné programy, které se mají aktualizovat, můžete nastavit následujícími způsoby: automaticky, když otevřete Cílový soubor; ručně, pokud chcete zobrazit předchozí data před aktualizací novými daty z Zdrojový soubor; nebo pokud výslovně požadujete aktualizaci, bez ohledu na to, jestli je zapnutá Automatická nebo ruční aktualizace.

Nastavení ruční aktualizace odkazu na jiný program

  1. Na kartě Data, ve skupině Připojení, klikněte na možnost Upravit propojení.

    Vzhled pásu karet aplikace Excel

    Poznámka: Příkaz Upravit odkazy není dostupný, pokud soubor neobsahuje odkazy na jiné soubory.

  2. Ve sloupci Zdroj klikněte na propojený objekt, který chcete aktualizovat. A ve sloupci Update znamená, že se jedná o automatické propojení, a ve sloupci Update znamená, že odkaz je nastaven na Ruční aktualizaci.

    Tip: Jestliže chcete vybrat více propojených objektů, podržte při klikání na jednotlivé objekty klávesu CTRL. Chcete-li vybrat všechny propojené objekty, stiskněte kombinaci kláves CTRL + A.

  3. Pokud chcete propojený objekt aktualizovat, jenom když kliknete na aktualizovat hodnoty, klikněte na ručně.

Nastavení automatického aktualizace odkazu na jiný program

  1. Na kartě Data, ve skupině Připojení, klikněte na možnost Upravit propojení.

    Vzhled pásu karet aplikace Excel

    Poznámka: Příkaz Upravit odkazy není dostupný, pokud soubor neobsahuje odkazy na jiné soubory.

  2. Ve sloupci Zdroj klikněte na propojený objekt, který chcete aktualizovat. A ve sloupci Update znamená, že se odkaz automaticky aktualizuje a písmeno M ve sloupci aktualizace znamená, že odkaz musí být aktualizován ručně.

    Tip: Jestliže chcete vybrat více propojených objektů, podržte při klikání na jednotlivé objekty klávesu CTRL. Chcete-li vybrat všechny propojené objekty, stiskněte kombinaci kláves CTRL + A.

  3. Klikněte na OK.

Problém: Nemohu aktualizovat automatické vazby na listu

Možnost automaticky lze přepsat možnostmi aktualizovat odkazy na jiný dokument v Excelu.

Chcete-li zajistit, aby automatické aktualizace propojení s objekty OLE byla Automatická?

  1. Klikněte na tlačítko Obrázek tlačítka Microsoft Office, klikněte na Možnosti aplikace Excela pak klikněte na kategorii Upřesnit .

  2. V části při výpočtu tohoto sešituzkontrolujte, že je zaškrtnuté políčko aktualizovat propojení s jinými dokumenty .

Aktualizace odkazu na jiný program

  1. Na kartě Data, ve skupině Připojení, klikněte na možnost Upravit propojení.

    Vzhled pásu karet aplikace Excel

    Poznámka: Pokud soubor neobsahuje propojené informace, není příkaz Upravit odkazy k dispozici.

  2. Ve sloupci Zdroj klikněte na propojený objekt, který chcete aktualizovat.

    Tip: Jestliže chcete vybrat více propojených objektů, podržte při klikání na jednotlivé objekty klávesu CTRL. Chcete-li vybrat všechny propojené objekty, stiskněte kombinaci kláves CTRL + A.

  3. Klikněte na tlačítko Aktualizovat hodnoty.

Úprava obsahu z programu OLE

V Excelu můžete změnit propojený nebo vložený obsah z jiného programu.

Úpravy propojeného objektu ve zdrojové aplikaci

  1. Na kartě Data, ve skupině Připojení, klikněte na možnost Upravit propojení.

    Vzhled pásu karet aplikace Excel

    Poznámka: Pokud soubor neobsahuje propojené informace, není příkaz Upravit odkazy k dispozici.

  2. V seznamu zdrojový soubor klikněte na zdroj Propojený objekt a potom klikněte na otevřít pramen.

  3. Proveďte požadované změny propojeného objektu.

  4. Ukončete Zdrojový program a vraťte se do cílového souboru.

Úpravy vloženého objektu ve zdrojové aplikaci

  1. Poklikáním na Vložený objekt ho otevřete.

  2. Proveďte požadované změny objektu.

  3. Pokud upravujete objekt v otevřeném programu, Kliknutím kamkoli mimo objekt se vrátíte na Cílový soubor.

    Pokud upravujete vložený objekt ve zdrojovém programu v samostatném okně, zavřete zdrojový program a vraťte se do cílového souboru.

Poznámka: Poklikáním na určité vložené objekty, jako jsou třeba videoklipy a zvukové klipy, se objekt neotevře. Pokud chcete upravit jeden z těchto vložených objektů, klikněte na ikonu nebo objekt pravým tlačítkem myši, přejděte naobjekttyp objektu(například mediální klip) a potom klikněte na Upravit.

Úpravy vloženého objektu v jiném než zdrojovém programu

  1. Vyberte Vložený objekt, který chcete upravit.

  2. Klikněte pravým tlačítkem myši na ikonu nebo objekt, přejděte naobjekttyp objektu(například objekt dokument) a potom klikněte na převést.

  3. Udělejte jednu z těchto věcí:

    • Pokud chcete vložený objekt převést na typ, který zadáte v seznamu, klikněte na převést na.

    • Pokud chcete vložený objekt otevřít jako typ, který zadáte v seznamu beze změny vloženého typu objektu, klikněte na aktivovat.

Výběr objektu OLE pomocí klávesnice

  1. Stisknutím kombinace kláves CTRL + G zobrazte dialogové okno Přejít na .

  2. Klikněte na speciální, vyberte objektya potom klikněte na OK.

  3. Opakovaně stiskněte klávesu TAB, dokud nebude vybrán požadovaný objekt.

  4. Stiskněte klávesy SHIFT + F10.

  5. Přejděte na objekt nebo objekt grafua potom klikněte na Upravit.

Problém: když budu klepat na propojený nebo vložený objekt, zobrazí se zpráva "nelze upravovat".

Tato zpráva se zobrazí, pokud nelze otevřít Zdrojový soubor nebo Zdrojový program.

Ujistěte se, že je zdrojová aplikace dostupná     Pokud není zdrojová aplikace na počítači nainstalovaná, převeďte objekt na formát souboru aplikace, kterou máte nainstalovanou.

Ujistěte se, že je paměť přiměřená     Ujistěte se, že máte dostatek paměti ke spuštění zdrojového programu. V případě potřeby uvolněte paměť ukončením ostatních aplikací.

Zavření všech dialogových oken     Pokud je zdrojový program spuštěný, ujistěte se, že neobsahuje žádná dialogová okna. Přepněte do zdrojového programu a zavřete všechna otevřená dialogová okna.

Zavřete zdrojový soubor     Pokud je zdrojový soubor propojený objekt, ujistěte se, že ho jiný uživatel nemá otevřený.

Ujistěte se, že název zdrojového souboru nebyl změněn     Pokud je zdrojový soubor, který chcete upravit, propojený objekt, ujistěte se, že má stejný název jako při vytvoření odkazu a že nebyl přesunut. Vyberte propojený objekt a potom ve skupině připojení na kartě data klikněte na příkaz Upravit odkazy , abyste viděli název zdrojového souboru. Pokud se zdrojový soubor přejmenoval nebo přesunul, použijte tlačítko změnit zdroj v dialogovém okně Upravit odkazy a vyhledejte zdrojový soubor a znovu propojení vytvořte.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×