Vytvoření hlavního projektu propojením projektů v desktopové verzi Projectu

Vytvoření hlavního projektu propojením projektů v desktopové verzi Projectu

Předplatné Office 365, Project Professional 2019, Project Professional 2016, Office 2013, Office 2010

Abyste měli lepší přehled i o větším projektu a měli ho líp uspořádaný, můžete několik projektových souborů propojit, a uspořádat tak projekt do hlavního projektu s dílčími projekty (jako takzvané externí závislosti). Například v jednom hlavním projektu stavby můžete mít několik souborů dílčích projektů pro instalatérské, elektrikářské a tesařské práce.

Propojení souborů Projectu

  1. Pro každý dílčí projekt si vytvořte samostatné soubory Projectu a potom otevřete nebo vytvořte projekt, který má být hlavní.

  2. V hlavním projektu klikněte na Zobrazení > Ganttův diagram.

  3. V poli se seznamem Název úkolu klikněte na řádek, pod který chcete vložit dílčí projekt. Dílčí projekt můžete vložit kamkoliv v seznamu úkolů hlavního projektu.

  4. Klikněte na Projekt > Dílčí projekt.

    Karta na pásu karet s příkazem Vložit dílčí projekt

  5. V dialogu Vložit projekt vyberte dílčí projekt, který chcete vložit.

    • Pokud chcete vložit víc dílčích projektů, podržte stisknutou klávesu Ctrl a postupně klikněte na jednotlivé dílčí projekty v pořadí, v jakém je chcete vložit.

    • Ve většině případů budete chtít nechat políčko Vytvořit vazbu zaškrtnuté, aby se změny udělané v dílčím projektu promítly do hlavního projektu (a naopak). Pokud ale budete chtít jenom dílčí projekt do hlavního projektu zkopírovat a nebudete chtít mít soubory dynamicky propojené, pak zaškrtnutí políčka zrušte.

  6. Klikněte na Vložitnebo pokud chcete vložit projekt ve formátu jen pro čtení, klikněte na šipku na tlačítku Vložit a potom klikněte na Vložit jen pro čtení. Vložením projektu jen pro čtení vytvoříte propojení mezi těmito dvěma projekty, ale zabráníte tak aktualizaci dílčího projektu z hlavního projektu. Pokud ale soubor dílčího projektu aktualizujete přímo, projeví se jeho změny v hlavním projektu. Možnost Vložit jen pro čtení je dostupná jenom v případě, že je zaškrtnuté políčko Propojit s projektem.

Jak se vyhnout duplicitním jménům/názvům zdrojů v propojených projektech

Pokud propojíte projekty, které mají zdroje se stejným názvem, vytvoříte duplicitní názvy zdrojů a to by mohlo způsobovat zmatky. Můžete se tomu vyhnout tak, že zrušíte zaškrtnutí políčka Propojit s projektem v dialogovém okně Vložit projekt. Tím zajistíte, že budou informace o zdroji v hlavním projektu (jako třeba platové sazby, kalendáře zdrojů) mít vyšší postavení než informace o zdrojích dílčího projektu.

Poznámka: Při aktualizaci nepropojeného dílčího projektu z hlavního projektu se změny neprojeví v původním souboru dílčího projektu.

Změna uspořádání dílčích projektů v hlavním projektu

Pokud jste vložili Dílčí projekt do Hlavní projekt a chcete změnit uspořádání seznamu úkolů, můžete Vložený projekt seznam úkolů nahoru nebo dolů.

  1. Zvolte Zobrazení > Ganttově diagramu.

  2. Vyberte Číslo IDsouhrnný úkol, která představuje vložený projekt, který chcete přesunout.

  3. Pokud chcete vložený projekt odebrat, klikněte na něj pravým tlačítkem myši a zvolte Vyjmout.

    Poznámka: Vyříznutím a vložením úkolu změníte Jedinečné ID úkolu (liší se od ID úkolu umístěného v úplně levém sloupci tabulky Položka), když se znovu vsoudí do seznamu úkolů v jiném umístění. Pokud chcete úkol přesunout bez změny jedinečného ID, můžete úkol přetáhnout na nové místo v seznamu úkolů. Pokud chcete úkol přetáhnout, umístěte ukazatel myši na ID úkolu do pole ID. Když se změní na čtyřsměnné šipky, přetáhněte úkol do nového umístění. Informace se odebere jenom z plánu projektu, ne z plánu projektu, dokud je nevrátíte zpátky.

  4. Vyberte ČÍSLO ID úkolu pod polem, kde se má projekt zobrazit v seznamu úkolů.

    Poznámka: Pokud vložíte nebo vložíte projekt pod jiný vložený projekt, který má zobrazenou Souhrnný úkol projektu, přidá se projekt, který vkládáte nebo vkládáte, na stejné úrovni jako vložený projekt nad něj. Pokud ale vložíte nebo vložíte pod vložený projekt, který obsahuje všechny jeho úkoly, stane se z projektu, který vkládáte nebo vkládáte, dílčí projekt vložili nad něj.

  5. Kliknutím na Vložit vložte projekt nad vybraný řádek.

Tyto instrukce platí pro Microsoft Project 2007.

Kdy mám místo závislostí mezi projekty používat propojení mezi projekty?

Pokud má váš projekt konkrétní úkol, který závisí na konkrétním úkolu v jiném projektu, použijte propojení mezi projekty a spojte data úkolů s ostatními. Pokud tak úkol, na který jste závislí, skluzy, projeví se nová data ve vašem vlastním úkolu. Pokud je váš projekt závislý na určitém aspektu jiného projektu a závislost není nutně svázána s určitým úkolem, použijte závislosti mezi projekty a přesně určete, co každý projekt do relace přináší.

  1. Otevřete oba projekty: projekt, který obsahuje úkol, na který chcete vytvořit propojení, a projekt obsahující úkol, ze kterého chcete vytvořit propojení.

    V nabídce Okno jednoho z projektů klikněte na Uspořádat vše.

  2. Klikněte na úkol, pro který chcete vytvořit závislost na externím předchůdci.

  3. Klikněte na Informace o Obrázek tlačítka a potom klikněte na kartu Předchůdci.

  4. Do sloupce ID zadejte název projektu a ČÍSLO ID úkolu externího předchůdce odděleného zpětném lomítkem. Do souboru s názvem Project1 například zadejte Project1\1 pro ID úkolu 1.

Ve výchozím nastavení se vám oznámí, jestli se data v externě propojeném projektu změnila. Externí předchůdci a následníci a vlivy na váš plán se zobrazí při otevření projektu s externími odkazy a můžete přijmout všechny změny.

  • Před propojením s externím úkolem je nutné oba projekty uložit.

  • Když propojíte úkoly v různých projektech uložených na serveru Microsoft Office Project Server, musí být ID úkolu předchůdce správně naformátované. V dialogovém okně Informace o úkolu musí být na kartě Předchůdci ve sloupci ID naformátováno ID úkolu podle následujícího příkladu: <>\project1\42. V tomto příkladu je projekt1 název projektu, který obsahuje předchůdce, a 42 je ID úkolu předchůdce.

  • Externě propojené úkoly se v seznamu úkolů zobrazují šedě. Poklikáním na úkol s externím následníkem nebo externím předchůdcem se otevře projekt, který obsahuje externí úkol, pokud je projekt dostupný.

Propojit úkoly mezi projekty, ale data se neshodují.

Pokud k propojení úkolů použijete možnost Vložit odkaz v dialogovém okně Vložit jinak(nabídka Úpravy), použije Project k propojení propojení objektů a vkládání objektů (OLE). Propojená jsou jenom pole, která jste vybrali. Úkol ale může mít k úkolu přidružených mnoho dalších polí s informacemi, která mají vliv na plánování úkolu, a tato pole mohou být skrytá, pokud máte rozdělené zobrazení obrazovky.

Pokud potřebujete vytvořit závislost mezi úkoly v různých projektech, vytvořte externí závislosti (místo vložení odkazu), abyste zachovali přesný plán.

Když použijete možnost Vložit odkaz, vyberte jednotlivá pole místo celých řádků a propoojte jenom tolik informací, kolik potřebujete, abyste se vyhnuli konfliktním informacím o plánu.

Další informace

Plány v rámci plánů: hlavní projekty a dílčí projekty

Potřebujete další pomoc?

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×