Vytvoření organizačního diagramu automaticky z dat zaměstnanců

Organizační diagram je diagram zobrazující vztahy mezi zaměstnanci, pracovními pozicemi a skupinami.

Pokud máte všechny informace o zaměstnancích v dokumentu, třeba v excelovém sešitu, nebo v adresáři Exchange Serveru, Visio může vygenerovat diagram, který za vás obrazce a spojení přidá. Pokud nechcete graf generovat automaticky, můžete diagram nakreslit bez použití externího zdroje dat.

Pokud chcete spustit Průvodce organizačním diagramem, klikněte na Soubor > Nový, klikněte na kategorii Organizační diagram a potom klikněte na Vytvořit.

Ve Visiu 2016 klikněte na Soubor > Nový >Business > Organization Charta potom klikněte na Vytvořit.

Organizační diagram

Automatické generování diagramu ze stávajícího zdroje dat

Když se rozhodnete pro možnost vytvořit diagram ze šablony, spustí se Průvodce organizačním diagramem. Na první stránce průvodce vyberte Informace již uložené v souboru nebo databázi a potom postupujte podle pokynů v průvodci.

Zdroje dat, které můžete použít

  • List Microsoft Excelu

  • Textový soubor

  • Adresář Microsoft Exchange Serveru

  • Zdroj dat kompatibilní se standardem ODBC

Požadované sloupce ve zdroji dat

Zdroj dat musí mít sloupec pro jméno zaměstnance, jedinečný identifikátor a nadřízeného této osoby. Je jedno, jaké mají sloupce ve zdroji dat názvy, protože v průvodci ručně určíte, které sloupce (nebo názvy polí) obsahují jméno zaměstnance a jméno nadřízeného.

  • Jméno zaměstnance:    Jména zaměstnanců v tomto poli se stejným způsobem zobrazí v obrazcích organizačního diagramu.

  • Jedinečný identifikátor:     Tuto funkci může plnit sloupec Jméno zaměstnance, pokud jsou všechna jména jedinečná. V opačném případě zahrňte sloupec s hodnotou, která jedinečným způsobem identifikuje každého zaměstnance.

  • Nadřízený zaměstnance:    Toto pole musí obsahovat jedinečný identifikátor příslušného vedoucího, to znamená jméno nebo číslo. U zaměstnance na vrcholu organizačního diagramu ponechejte toto pole prázdné.

Příklad textového souboru jako zdroje dat

Následující text obsahuje příklad textového souboru s oddělovači, který má pět sloupců a čtyři řádky, první řádek je řádek záhlaví. Visio vygeneruje tento ukázkový textový soubor za vás – spusťte Průvodce organizačním diagramem, vyberte informace, které zadám pomocí průvodce,a klikněte na Další. Na další stránce vyberte texts oddělovači, zadejte název souboru a klikněte na Další. Visio otevře textový editor s touto ukázkovou datou jako vodítkem.

Jméno,nadřízený,pozice,oddělení,telefon

Jan Vedoucí, ,ředitel, vedení,x5555
Jana Vedoucí,Jan Vedoucí,vedoucí vývoje,vývoj produktů,x6666
John Samplepos,Jana Samplemgr,Vývojář softwaru,Vývoj produktů,x6667

Vytvoření organizačního diagramu z nového datového souboru

Pokud ještě nemáte svoje data v jiném programu a chcete je do něho převést, Visio otevře Excel nebo textový editor s přehledně formátovanými ukázkovými daty. Nahraďte ukázková data vlastními a dokončením průvodce vygenerujte organizační diagram.

  1. Pokud chcete spustit Průvodce organizačním diagramem, klikněte na Soubor > Nový, klikněte na kategorii Organizační diagram a potom klikněte na Vytvořit.

    Ve Visiu 2016 klikněte na Soubor > Nový >Business > Organization Charta potom klikněte na Vytvořit.

  2. Na první stránce průvodce vyberte Informace zadávané prostřednictvím průvodce a pak klikněte na tlačítko Další.

  3. Vyberte excelový text nebo text s oddělovači,zadejte název nového souboru a klikněte na Další.
    Pokud vyberete Excel,otevře se list Microsoft Excelu s ukázkovým textem. Pokud vyberete text s oddělovači,otevře se stránka Poznámkového bloku s ukázkovým textem.

  4. Jakmile se otevře list aplikace Excel nebo stránka Poznámkového bloku, použijte ukázkový text jako příklad požadovaného typu informací a informace přepište vlastními údaji. Sloupce se jménem zaměstnance a nadřízeného jsou povinné, ale jiné sloupce můžete přidávat nebo odstraňovat.

  5. Ukončete Excel nebo Poznámkový blok a pak ukončete průvodce.

Změna rozložení, změna obrazců a vkládání obrázků

Šablony organizačního diagramupřidávají na pás karet kartu Organizační diagram. Pomocí nástrojů na této kartě můžete provádět velké změny vzhledu diagramu.

Skupiny Rozložení a Uspořádat mají nástroje pro změnu rozložení a hierarchie obrazců.

Pomocí galerie Obrazce si můžete vybrat styl obrazců v diagramu. Pomocí nástrojů ve skupině Obrázek vložíte do vybraného obrazce obrázek, odstraníte zástupný obrázek a změníte obrázek po jeho vložení do obrazce. Pokud jste v průvodci nepřidáli obrázky do všech obrazců, můžete je teď přidat. Na kartě Organizační diagram klikněte na Vložit >několik obrázků. Všechny obrázky musí být v jedné složce s názvem souboru ve formátu Jméno zaměstnance.Typ_souboru– například Petr Foster.jpg (jméno musí přesně odpovídat jménu ve zdroji dat).

Skupina Data organizace obsahuje řadu nástrojů pro import dat z externího zdroje pomocí průvodce, který exportuje data organizace do Excelu nebo textového souboru, a srovnání dat v diagramu s externím zdrojem dat.

Zobrazení týmů pomocí rámců týmu nebo tečkovaných čar

Jakmile vytvoříte organizační diagram, můžete změnit uspořádání informací tak, aby odrážely vztahy virtuálního týmu. Související obrazce přesuňte k sobě a pomocí spojovacích tečkovaných linií zobrazte strukturu sekundárních sestav. Nebo zvýrazněte virtuální tým v rámci týmu. Přetáhněte obrazec Rámec týmu z okna Obrazce do výkresu a potom pomocí úchytů po stranách zahrnujte do virtuálního týmu jednotlivce.

Rámec týmu

Aktualizace organizačního diagramu, který používá externí zdroj dat

Pokud chcete promítnout změny ve struktuře organizace, obnovte data diagramu nebo organizační diagram aktualizujte ručně:

  • Klikněte na Data > Externí data > Aktualizovat vše.

Pokud se nová data neshodují s těmi, které tvořily původní diagram, bude nejspíš potřeba přesunout jednotlivé osoby ručně.

Pokud jste vytvořili nový diagram, Visio ho porovná s předchozí verzí a zobrazí provedené změny.

  1. Otevřete buď novou, nebo starou verzi organizačního diagramu.

  2. Klikněte na Organizační diagram > Data organizace > Porovnat. V poli Porovnat data organizace najděte verzi, se kterou chcete diagram porovnat.

  3. V části Typ srovnání vyberte situaci v závislosti na otevřené verzi.

  4. V části Typ sestavy vyberte požadovanou možnost.

  5. Klikněte na OK.

Pokud se i přes to nedaří organizační diagram aktualizovat podle vašich představ, možná ho bude potřeba přepracovat.

Chcete získat další informace?

Vyhledání ukázkových šablon a diagramů Visia z organizačního diagramu

Viz také

Vytvoření organizačního diagramu ve Visio Web Appu

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?
Co ovlivnilo váš názor?

Děkujeme za váš názor!

×