Histogram je sloupcový graf, ve kterém se zobrazují data četnosti.

Poznámka: V tomto tématu se mluví jenom o vytvoření histogramu. Informace o paretových grafech (seřazený histogram) najdete v tématu Vytvoření paretového grafu.

  1. Vyberte data.

    (Toto je typický příklad dat histogramu.)

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Klikněte na Vložení > Vložit statistický graf > Histogram.

    Příkaz Histogram po stisknutí tlačítka Vložit statistický graf

    Histogram můžete vytvořit také na kartě Všechny grafy v části Doporučené grafy.

Tipy: 

  • K přizpůsobení vzhledu grafu použijte karty Návrh a Formát.

  • Pokud tyto karty nevidíte, kliknutím kamkoliv do histogramu přidejte Nástroje grafu na pás karet.

Karty Návrh a Formát pro Nástroje grafu

  1. Klikněte pravým tlačítkem myši na vodorovnou osu grafu, klikněte na Formát osya potom klikněte na Možnosti osy.

    Příkaz Formátovat osu v místní nabídce
  2. Pomocí informací v následující tabulce se můžete rozhodnout, které možnosti chcete nastavit v okně Formát osy podokno úloh.

    Možnost

    Popis

    Podle kategorie:

    Tuto možnost zvolte, pokud jsou kategorie (vodorovná osa) založené na textu místo číselného. Histogram seskupí stejné kategorie a na ose hodnot vynese součet hodnot.

    Tip: Pokud chcete spočítat výskyty textových řetězců, přidejte sloupec a vyplňte ho hodnotou 1, pak vykreslete histogram a nastavte intervaly na Podle kategorie.

    Automaticky:

    Toto je výchozí nastavení histogramů. Šířka přihrádky se vypočítá pomocí Scottova normálního referenčního pravidla.

    Šířka intervalu:

    Zadejte kladné desetinné číslo pro počet datových bodů v každém rozsahu.

    Počet intervalů:

    Zadejte počet intervalů histogramu (včetně intervalů přetečení a podtečení).

    Interval přetečení:

    Zaškrtnutím tohoto políčka vytvoříte přihrádku pro všechny hodnoty nad hodnotou v poli vpravo. Pokud chcete hodnotu změnit, zadejte do pole jiné desetinné číslo.

    Interval podtečení:

    Toto políčko zaškrtněte, pokud chcete vytvořit přihrádku pro všechny hodnoty pod hodnotou nebo se rovnají hodnotě v poli napravo. Pokud chcete hodnotu změnit, zadejte do pole jiné desetinné číslo.

    Podokno úloh Formát osy

Tip: Pokud si chcete přečíst další informace o histogramovém grafu a o tom, jak vám pomáhá vizualizovat statistická data, podívejte se na tento blogový příspěvek na histogramu, paretu a krabicovém grafu a vousy od týmu Excel. Možná vás taky budou zajímat další informace o dalších nových typech grafů popsaných v tomto příspěvku na blogu.

Automatická možnost (Scottova normální referenční pravidlo)   

Možnost vzorce pro automatický výpočet

Scottovo normální referenční pravidlo se snaží minimalizovat odchylku histogramu v porovnání se sadou dat s předpokládaným normálním rozdělením.

Možnost přetékající přihrádky   

Vzorec pro možnost Přetečení přihrádky

Možnost podtečení   

Vzorec pro možnost Podtečení přihrádky
  1. Ujistěte se, že jste načetl analytické nástroje. Další informace najdete v tématu Načtení analytického nástroje do Excel.

  2. V listu zadejte do jednoho sloupce vstupní data. První buňka může obsahovat popisek.

    Použijte kvantitativní číselná data, například množství položek nebo skóre dosažená v testech. Nástroj Histogram nepracuje s kvalitativními číselnými daty, například s identifikačními čísly zadanými jako text.

  3. Do dalšího sloupce zadejte čísla tříd seřazená vzestupně. První buňka může obsahovat popisek.

    Doporučujeme použít vlastní čísla tříd, protože mohou být užitečnější pro vaši analýzu. Pokud nezadáte čísla tříd, nástroj Histogram vytvoří rovnoměrně rozdělené intervaly tříd použitím minimální a maximální hodnoty ve vstupní oblasti jako počátečního a koncového bodu.

  4. Klikněte na Data > Analýza dat.

    Skupina Analýza – tlačítko Analýza dat

  5. Klikněte na Histogram > OK.

    Dialogové okno Analýza dat

  6. Ve skupinovém rámečku Vstup udělejte tohle:

    1. Do pole Vstupní oblast zadejte odkaz na oblast buněk, která obsahuje vstupní čísla.

    2. Do pole Hranice tříd zadejte odkaz na oblast buněk, která obsahuje čísla tříd.

      Pokud jste v listu použili popisky sloupců, můžete je zahrnout do odkazů na buňky.

      Tip: Místo ručního zadávání odkazů můžete kliknutím na Obrázek tlačítka dočasně sbalit dialogové okno a vybrat oblasti na listu. Dalším kliknutím na toto tlačítko se dialogové okno zase rozbalí.

  7. Pokud jste do odkazů na buňky zahrnuli popisky sloupců, zaškrtněte políčko Popisky.

  8. Ve skupinovém rámečku Možnosti výstupu zvolte umístění výstupu.

    Histogram můžete umístit na stejný list, na nový list v aktuálním sešitu nebo na list v novém sešitu.

  9. Zaškrtněte některé z těchhle políček:

    Pareto (tříděný histogram): Data se zobrazí v sestupném pořadí frekvencí.

    Kumulativní procentuální podíl:     Zobrazí se kumulativní procentuální podíly a do grafu histogramu se přidá čára pro kumulativní procentuální podíl.

    Vytvořit graf:     Zobrazí se vložený graf histogramu.

  10. Klikněte na tlačítko OK.

    Pokud chcete histogram přizpůsobit, můžete změnit textové popisky a kliknout kamkoli do grafu histogramu a použít tlačítka Prvky grafu ,Styly grafu a Filtr grafu napravo od grafu.

  1. Vyberte data.

    (Toto je typický příklad dat histogramu.)

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Klikněte na Vložení > Graf.

    Tlačítko Graf ve skupině Ilustrace na kartě Vložit ve Wordu
  3. V dialogovém okně Vložit graf klikněte v části Všechnygrafy na Histogram a potom klikněte na OK.

Tipy: 

  • K přizpůsobení vzhledu grafu použijte karty Návrh a Formát na pásu karet.

  • Pokud tyto karty nevidíte, kliknutím kamkoliv do histogramu přidejte Nástroje grafu na pás karet.

Karty Návrh a Formát pro Nástroje grafu

  1. Klikněte pravým tlačítkem myši na vodorovnou osu grafu, klikněte na Formát osya potom klikněte na Možnosti osy.

    Příkaz Formátovat osu v místní nabídce
  2. Pomocí informací v následující tabulce se můžete rozhodnout, které možnosti chcete nastavit v okně Formát osy podokno úloh.

    Možnost

    Popis

    Podle kategorie:

    Tuto možnost zvolte, pokud jsou kategorie (vodorovná osa) založené na textu místo číselného. Histogram seskupí stejné kategorie a na ose hodnot vynese součet hodnot.

    Tip: Pokud chcete spočítat výskyty textových řetězců, přidejte sloupec a vyplňte ho hodnotou 1, pak vykreslete histogram a nastavte intervaly na Podle kategorie.

    Automaticky:

    Toto je výchozí nastavení histogramů.

    Šířka intervalu:

    Zadejte kladné desetinné číslo pro počet datových bodů v každém rozsahu.

    Počet intervalů:

    Zadejte počet intervalů histogramu (včetně intervalů přetečení a podtečení).

    Interval přetečení:

    Zaškrtnutím tohoto políčka vytvoříte přihrádku pro všechny hodnoty nad hodnotou v poli vpravo. Pokud chcete hodnotu změnit, zadejte do pole jiné desetinné číslo.

    Interval podtečení:

    Toto políčko zaškrtněte, pokud chcete vytvořit přihrádku pro všechny hodnoty pod hodnotou nebo se rovnají hodnotě v poli napravo. Pokud chcete hodnotu změnit, zadejte do pole jiné desetinné číslo.

    Podokno úloh Formát osy

Pokud chcete vytvořit histogram v Excel pro Mac:

  1. Vyberte data.

    (Toto je typický příklad dat histogramu.)

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Na pásu karet klikněte na kartu Vložení, potom klikněte na Ikona statistického grafu (statistická ikona) a v části Histogramvyberte Histogram.

Tipy: 

  • K přizpůsobení vzhledu grafu použijte karty Návrh grafu a Formát.

  • Pokud karty Návrh a Formát grafu nevidíte, přidejte je na pás karet kliknutím kamkoli do histogramu.

Pokud chcete vytvořit histogram v Excel 2011 pro Mac, budete si muset stáhnout doplněk jiného výrobce. Další podrobnosti najdete v článku Analytické nástroje v Excel 2011 pro Mac.

V aplikaci Excel Online můžete zobrazit histogram (sloupcový graf zobrazující frekvenční data), ale nemůžete ho vytvořit, protože vyžaduje doplněk Analytické nástroje, doplněk Excel, který není v aplikaci Excel pro web podporovaný.

Pokud máte desktopové Excel, můžete pomocí tlačítka Upravit v aplikaci Excel otevřít Excel na ploše a vytvořit histogram.

Tlačítko pro úpravy v Excelu

  1. Klepnutím vyberte data.

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Pokud jste na telefonu, klepněte na ikonu pro Ikona Upravit a zobrazte pás karet. a potom klepněte na Domů.

  3. Klepněte na Vložit > grafy > Histogram .

    V případě potřeby můžete přizpůsobit prvky grafu.

    Poznámka: Tato funkce je dostupná jenom v případě, že máte předplatné Office 365. Pokud máte předplatné Microsoft 365, ujistěte se, že máte nejnovější verzi Office.

    Kupte si nebo zkuste Microsoft 365

  1. Klepnutím vyberte data.

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Pokud jste na telefonu, klepněte na ikonu pro Ikona Upravit a zobrazte pás karet a potom klepněte na Domů.

  3. Klepněte na Vložit > grafy > Histogram .

Pokud chcete vytvořit histogram v Excel, zadejte dva typy dat – data, která chcete analyzovat, a čísla bin, která představují intervaly, podle kterých chcete měřit frekvenci. Data je nutné uspořádat do dvou sloupců na listu. Tyto sloupce musí obsahovat následující data:

  • Vstupní data    Jedná se o data, která chcete analyzovat pomocí nástroje Histogram.

  • Čísla přihrádek    Tato čísla představují intervaly, které má nástroj Histogram použít k měření vstupních dat v analýze dat.

Když použijete nástroj Histogram, Excel počet datových bodů v jednotlivých datových přihrádkách. Datový bod se zahrne do určité přihrádky, pokud je číslo větší než nejnižší mez a je rovno nebo menší než největší mez pro datovou přihrádku. Pokud oblast přihrádky vysycháte, Excel vytvoří sadu rovnoměrně rozložených přihrádek mezi minimální a maximální hodnotou vstupních dat.

Výstup analýzy histogramu se zobrazí na novém listu (nebo v novém sešitu) a zobrazí tabulku histogramu a sloupcový graf, který odráží data v tabulce histogramu.

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Vytvoření kaskádového grafu

Vytvoření Paretova grafu

Vytvoření slunečního grafu v Office

Jak vytvořit krabicový graf

Vytvoření stromové mapy v Office

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×