Služba SMS Host Agent se chybově ukončí a zaznamená do protokolu událost s ID 1000 s kódem výjimky 0xc0000005

Platí pro
Windows Server 2008 R2 Standard Windows Server 2008 Standard Windows Server 2012 Standard Windows Server 2012 Standard Windows Server 2012 R2 Standard Microsoft System Center Configuration Manager 2007

Příznaky

V klientském počítači System Center Configuration Manager 2007 Service Pack 2 (ConfigMgr 2007 SP2) se systémem Windows Server 2008 nebo Windows Server 2012 dochází občas k chybovému ukončení služby Agent služby (Ccmexec.exe) serveru Systems Management Server (SMS) a do protokolu aplikace se zaznamená následující chyba Protokol:

Název protokolu: Aplikace
Zdroj: Chyba aplikace
ID události: 1000
Úroveň: Chyba
Klíčová slova: Klasický
Popis:
Název chybující aplikace: CcmExec.exe, verze: 4.0.6425.2000, časové razítko: 0x4a14c745
Název chybujícího modulu: ntdll.dll, verze: 6.1.7600.16385, časové razítko: 0x4a5bdb3b
Kód výjimky: 0xc0000005
Posun chyby: 0x0009cb74
ID chybujícího procesu: 0xa04
Čas spuštění chybující aplikace: 0x01ca273b4637f18e
Cesta k chybující aplikaci: C:\Windows\SysWOW64\CCM\CcmExec.exe
Cesta k chybujícímu modulu: C:\Windows\SysWOW64\ntdll.dll

Příčina

K tomuto problému dochází, protože v modulu Ntdll.dll dojde k narušení přístupu a potom je v modulu Caltrack.dll zavolána nesprávná funkce.

Řešení

Chcete-li tento problém vyřešit, nainstalujte následující opravu hotfix do role primární lokality a role klienta systému System Center Configuration Manager 2007 SP2. Pokud chcete tento problém vyřešit v klientovi System Center Configuration Manager 2007 SP2, nejprve nainstalujte následující balíček oprav hotfix na server primární lokality System Center Configuration Manager 2007 SP2. Poté nasaďte vygenerovaný balíček do klienta System Center Configuration Manager 2007 SP2.

Další informace o nasazení balíčku oprav hotfix na server primární lokality nástroje System Center Configuration Manager 2007 SP2 naleznete v následujícím článku znalostní báze znalostní báze Microsoft Knowledge Base:

2477182 System Center Configuration Manager 2007 Pokyny pro instalaci oprav hotfixPoznámka Následující balíček oprav hotfix lze nainstalovat na server lokality System Center Configuration Manager 2007 SP2, který používá verzi operačního systému založenou na platformě x86 nebo x64:

Sccm2007ac-sp2-kb2724939-x86-enu.msi

Informace o opravě hotfix

Podporovanou opravu hotfix poskytuje Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsaného v tomto článku. Tuto opravu hotfix použijte pouze v systémech, které se potýkají s potížemi popsanými v tomto článku. Tuto opravu hotfix je možné dále otestovat. Pokud se vás tedy tento problém vážně netýká, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix dostupná ke stažení, je k dispozici část "Oprava hotfix ke stažení" v horní části tohoto článku znalostní báze Knowledge Base. Pokud se tato část nezobrazí, obraťte se na služby zákazníkům a podporu společnosti Microsoft a požádejte o opravu hotfix.

Poznámka: Pokud se vyskytnou další problémy nebo je vyžadováno jakékoli řešení potíží, budete pravděpodobně muset vytvořit samostatnou žádost o služby. Další dotazy a problémy týkající se podpory, které se netýkají této konkrétní opravy hotfix, podléhají běžným sazbám za podporu. Úplný seznam telefonních čísel zákaznických služeb a podpory společnosti Microsoft nebo vytvoření samostatné žádosti o služby naleznete na následujícím webu společnosti Microsoft:

http://support.microsoft.com/contactus/?ws=support Poznámka: Formulář "Hotfix download available" (K dispozici je ke stažení opravy hotfix) zobrazuje jazyky, pro které je oprava hotfix k dispozici. Pokud svůj jazyk nevidíte, je to proto, že pro tento jazyk není k dispozici oprava hotfix.

Požadavky

Chcete-li nainstalovat tuto opravu hotfix, musíte mít nainstalovanou aktualizaci Microsoft System Center Configuration Manager 2007 Service Pack 2 (SP2).

Požadavky na restartování

Pokud před instalací této opravy hotfix zavřete konzolu správce aplikace Správce konfigurace, není nutné restartovat počítač.

Informace o nahrazení opravy Hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Informace o souborech

Anglická verze této opravy hotfix (USA) nainstaluje soubory, které mají atributy uvedené v následujících tabulkách. Data a časy u těchto souborů jsou uvedeny v čase UTC (koordinovaný univerzální čas). Data a časy u těchto souborů na vašem místním počítači se zobrazují v místním čase včetně vašeho aktuálního posunu letního času. Kromě toho se data a časy můžou změnit při provádění některých operací se soubory.

System Center Configuration Manager 2007 – poznámky k informacím o souborech

Název souboru Verze souboru Velikost souboru Datum Čas Platforma
Ccm_caltrack.dll 4.0.6487.2210 89,696 01-Únor-2010 18:05 x86
Sccm2007ac-sp2-kb2724939-x86-csy.msp 581,120 01-Únor-2010 18:05

Poznámka: Některé další soubory se můžou aktualizovat kvůli závislostem. Jejich binární soubory se však nezmění.

Stav

Společnost Microsoft potvrdila, že se jedná o problém produktů Microsoft, které jsou uvedeny v sekci Platí pro.

Další informace

Další informace o terminologii aktualizací softwaru naleznete v následujícím článku znalostní báze znalostní báze Microsoft Knowledge Base:

824684 Popis standardní terminologie používané k popisu aktualizací softwaru společnosti Microsoft