Příznaky
Synchronizace na straně serveru je nakonfigurován mezi Dynamics 365 (online) a Exchange Server (místní), obdržíte jednu z následujících chyb po pokusu o povolení poštovní schránky:
-
Zosobnění v došlo k chybě při odesílání e-mailové zprávy "Zkušební zprávu" přístup k poštovní schránce. < Název poštovní schránky > schránky nebyly synchronizovat. Vlastník profilu přidružené e-mailu serveru < název profilu e-mailu serveru > byly oznámeny.
-
Zosobnění v došlo k chybě při příjmu e-mailu přístup k poštovní schránce. < název poštovní schránky > nebyla synchronizace. Vlastník profilu přidružené e-mailu serveru < název profilu e-mailu serveru > byly oznámeny.
Po klepnutí na tlačítko Podrobnosti pro jednu z výše uvedených chyb, zobrazí se následující podrobnosti:
ActivityId: < GUID >
> Chyba: System.Web.Services.Protocols.SoapException: účet nemá oprávnění k zosobnění požadované uživatele.
v System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse (SoapClientMessage zprávu, odpověď WebResponse, responseStream proudu, Boolean asyncCall)
v System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke (IAsyncResult třídu asyncResult)
v Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindItem (IAsyncResult třídu asyncResult)
v Microsoft.Crm.Asynchronous.EmailConnector.FindItemsStep.EndCall()
na ActivityId () Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation: < GUID >
> Chyba: System.Web.Services.Protocols.SoapException: účet nemá oprávnění k zosobnění požadované uživatele.
v System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse (SoapClientMessage zprávu, odpověď WebResponse, responseStream proudu, Boolean asyncCall)
v System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke (IAsyncResult třídu asyncResult)
v Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem (IAsyncResult třídu asyncResult)
v Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()
Příčina
Této chybě může dojít, pokud uživatelský účet zadaný pro přístup k poštovní schránce nemá oprávnění k zosobnění pro poštovní schránku. Účet použitý pro přístup k poštovní schránce je k dispozici v rámci profilu e-mailu serveru záznam přidružený záznam poštovní schránky v Dynamics 365.
Řešení
Přesvědčte se, zda v záznamu profilu e-mailu serveru uživatelský účet má oprávnění zosobnění do každé přidružené poštovní schránky. V záznamu poštovní schránky v Dynamics 365 můžete klepnutím Hodnota profilu serveru a účtu, který je k dispozici v části pověření záznamu profilu serveru e-mailové recenze.
Další informace o konfiguraci serveru Exchange zosobnění naleznete v následujících tématech:
Jak: Konfigurace zosobnění
Konfigurace zosobnění serveru Exchange na serveru Exchange 2010
Zosobnění a EWS v Exchange