Kód chyby 80048539 při pokusu o import opravy řešení v aplikaci Dynamics 365

Příznak

Při pokusu o import opravy řešení v aplikaci Dynamics 365 se zobrazí následující chyba:

Import řešení: [název opravy řešení] se nezdařil. Kód chyby 80048539. "

Pokud soubor protokolu stáhnete a otevřete ho v Excelu, zobrazí se další podrobnosti, třeba:

Podrobnosti o příznak 1:

"Selhání 0x80048539 Import manifestu řešení: Chyba: verze opravy 1.0.1.0 je pro nadřazenou verzi 1.1.0.0 neplatná.

Podrobnosti o příznacích 2:

"Selhání 0x80048539 Import manifestu řešení: Chyba: držení řešení MyPatchTesting_Upgrade už existuje.

Příčina

Podívejte

Pokud používáte make.powerapps.com k importu aktualizace nespravovaného řešení a zobrazí se tato chyba, společnost Microsoft tento problém ví a pracuje na opravě. Pokud chcete problém vyřešit, otevřete rozšířené nastavení a vyberte možnost aktualizovat (nedoporučuje se).

Kód chyby 80048539 označuje, že importovaná oprava je neplatná. Existuje několik možných příčin, mezi které patří:

Příčina 1: Pokud se zobrazí podrobnosti o chybě uvedené v předchozí části o příznacích 1:

Verze opravy řešení je nižší než verze již nainstalovaného řešení. Příklad: řešení s názvem řešení je už nainstalované s verzí 1.1.0.0 a pokoušíte se importovat opravu, která je verze 1.0.1.0.

Příčina 2:Pokud se zobrazí podrobnosti o chybě uvedené v předchozí části s příznakem 2:

K tomu může dojít, pokud už máte upgrade pro toto řešení, ale ještě nebyl použitý. Po importu řešení, které je upgradem existujícího řešení, obsahuje konec importu řešení tlačítko pro použití upgradu řešení. Pokud jste toto tlačítko během předchozího importu upgradu řešení pro toto řešení nepoužili, potřebujete je najít v seznamu řešení a klikněte na tlačítko použít upgrade řešení

Řešení

Řešení 1: Pokud se zobrazí podrobnosti o chybě uvedené v předchozí části o příznacích 1:

Ověření verze opravy řešení, kterou se pokoušíte importovat, je vyšší verze než již nainstalované řešení.

Řešení 2: Pokud se zobrazí podrobnosti o chybě uvedené v předchozí části s příznakem 2:

Přejděte na Nastavení, vlastnínastavení a klikněte na řešení. Vyberte existující nainstalované řešení, které zkoušíte upgradovat, a klikněte na použít upgrade řešení

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Děkujeme za váš názor!

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×