Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Desktopový tok se nepodařilo spustit s kódem chyby NoCandidateMachine nebo s podrobnostmi o chybě Nebyl nalezen žádný počítač, který by mohl spustit desktopový tok.

Příčina

Pokud nejsou k dispozici žádné počítače, Power Automate vytvoří frontu obsahující desktopové toky čekající na spuštění. Jakmile bude počítač dostupný, vybere se další spuštění desktopového toku na základě priority a času požadavku. Pokud po třech hodinách od doby, kdy byl požadován, není k dispozici žádný počítač, vyprší časový limit desktopového toku a selže s chybou NoCandidateMachine.

Jak je uvedeno v chybové zprávě, tato chyba znamená, že orchestrátor nemohl najít dostupný počítač pro spuštění desktopového toku. K této chybě dochází před spuštěním desktopového toku. K tomu dochází, když je desktopový tok ve frontě déle, než je limit časového limitu (3 hodiny), což může nastat z několika důvodů. 

Řešení

Tento kód chyby se obvykle dodává s kódem dílčí chyby. Tady jsou řešení nejběžnějších případů:

  • SessionExistsForTheUserWhenUnattended – to znamená, že se pokoušíte spustit bezobslužný desktopový tok na cílovém počítači, na kterém je uživatel použitý v připojení desktopového toku přihlášený. Relaci je potřeba odhlásit (uzamčená relace způsobí tuto chybu). Zkontrolujte, že nejste na počítači přihlášeni pod stejným uživatelem.

  • NoUnlockedActiveSessionForAttended – nejběžnější způsob, jak se k této chybě dostat, je, když se pokusíte spustit desktopový tok na cílovém počítači, který je uzamčený nebo není přihlášený žádný uživatel. Tato chyba se může zobrazit také v případě, že uživatel Windows, se kterým jste aktuálně přihlášeni na cílovém počítači, neodpovídá uživateli, který jste zadali v připojení. Navštěvované desktopové toky se dají spustit jenom v případě, že je počítač odemknutý v relaci, ve které aktuální uživatel odpovídá tomu z připojení desktopového toku. Zkontrolujte přihlašovací údaje použité ve vašem připojení a ujistěte se, že se používají v odemčené relaci.

  • UIFlowAlreadyRunning – k tomu dochází při spuštění bezobslužného desktopového toku. K tomuto selhání dochází při dosažení limitu počtu aktivních relací na počítači nebo při pokusu o otevření relace pro uživatele, který je již přihlášen.

V případě, že kód dílčí chyby není zadaný, bude potřeba provést několik kontrol.

  • Počítač nebo všechny počítače ve skupině počítačů jsou offline. Spusťte počítač a ujistěte se, že je Power Automate Desktop správně nainstalovaný a dokáže komunikovat s internetem.

  • Skupina počítačů je prázdná. Před přiřazením spuštění desktopového toku se ujistěte, že vaše skupina počítačů obsahuje alespoň jeden počítač.

  • Počítač nebo všechny počítače ve skupině počítačů jsou nepřetržitě zaneprázdněné. Počítače včas nezachytály desktopový tok. Důvodem je pravděpodobně skutečnost, že přidělené prostředky počítače nejsou dostatečně škálované, aby splňovaly požadavky pracovního postupu. Přidání dalších počítačů by pomohlo distribuovat úlohu.

  • Počítač není dostupný kvůli problémům se sítí (včetně proxy serveru nebo brány firewall). Ve spolupráci se správcem IT se ujistěte, že jsou vaše počítače dostupné podle očekávání.

  • Problém je přechodný. Může pomoct změna zásad opakování v nastavení akcí.

  • Počítač nebo všechny počítače ve skupině počítačů se nemůžou připojit k desktopovým tokům. Ujistěte se, že se nepokoušíte spustit bezobslužný tok ve skupině, ve které jsou všechny počítače přihlášené, nebo se pokoušíte spustit tok ve skupině, ve které jsou všechny počítače odhlášené.

  • Počítač už není použitelný. Přidejte nový počítač a pak aktualizujte připojení desktopového toku v cloudových tocích tak, aby používal nový počítač.

V případě, že máte ve frontě spuštění zálohu desktopových toků z některého z výše uvedených důvodů, můžete hromadně zrušit spuštění desktopového toku zrušením spuštění nadřazeného cloudového toku pomocí akce Zrušit spuštění nadřazeného toku na stránce Spuštění desktopového toku. Jakmile se problém s počítačem vyřeší, můžete tyto toky cloudu spustit znovu.

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti

Projít školení >

Získejte nové funkce jako první

ZAPOJTE SE DO PROGRAMU MICROSOFT 365 INSIDER

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?

Děkujeme vám za zpětnou vazbu.

×