Příznaky
Jde o takovouto situaci:
-
Máte počítač se systémem Microsoft BizTalk Server 2009. BizTalk server je nakonfigurován k použití databáze velká a malá písmena.
-
Nainstalujte Microsoft BizTalk ESB Toolkit 2.0 a nakonfigurujete ho k použití databáze velká a malá písmena.
-
Použijete k vytvoření aplikace BizTalk BizTalk ESB Toolkit 2.0.
V tomto případě nelze spustit aplikaci BizTalk. Navíc může zobrazit následující chybová zpráva:
Zprávy odeslané do adaptéru "SQL" v odeslat port "VŠECHNY. Výjimky"s identifikátorem URI" SQL: / / (místní) /EsbExceptionDb/ "je pozastaveno.
Podrobnosti o chybě: došlo k chybě vykonávání potrubí odesílání: "Microsoft.Practices.ESB.ExceptionHandling.Pipelines.ESBFaultProcessor, Microsoft.Practices.ESB.ExceptionHandling.Pipelines, verze = 2.0.0.0, Culture = neutral, PublicKeyToken = 31bf3856ad364e35" Zdroj: "ESB výjimka Encoder" Odeslat Port: "VŠECHNY. Výjimky"identifikátor URI:" SQL: / / (místní) /EsbExceptionDb/ "důvod: Neplatný název objektu 'bts_Application'.
Příčina
K tomuto problému dochází, protože BizTalk ESB Toolkit 2.0 nepodporuje databáze velká a malá písmena.
Řešení
Informace o opravě hotfix
Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.
Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tento oddíl není uveden, odešlete požadavek na Microsoft Zákaznický servis a podporu k získání opravy hotfix.
Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.
Předpoklady
Chcete-li nainstalovat tuto opravu hotfix, musíte mít Microsoft BizTalk ESB Toolkit 2.0.
Požadavek na restartování
Po instalaci této opravy hotfix, není nutné restartovat počítač.
Informace o nahrazení opravy hotfix
Tato oprava hotfix nenahrazuje žádné další opravy hotfix.
Informace o souborech
Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.
Pro všechny podporované verze x86 BizTalk ESB Toolkit 2.0
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Microsoft.practices.esb.adapter.dll |
2.0.0.1 |
42,880 |
03-Nov-2010 |
13:34 |
x86 |
Microsoft.practices.esb.biztalkoperations.dll |
2.0.1.1 |
71,576 |
03-Nov-2010 |
13:34 |
x86 |
Microsoft.practices.esb.exceptionhandling.dll |
2.0.0.1 |
55,192 |
03-Nov-2010 |
13:34 |
x86 |
Microsoft.practices.esb.exceptionhandling.pipelines.dll |
2.0.0.1 |
42,928 |
03-Nov-2010 |
13:34 |
x86 |
Stav
Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Odkazy
Další informace o BizTalk ESB Toolkit naleznete na následujícím webu Microsoft Developer Network (MSDN):
Obecné informace o BizTalk ESB Toolkit
Další informace o opravách hotfix serveru BizTalk Server klepněte na následující číslo článku databáze Microsoft Knowledge Base:
2003907 informace o opravách hotfix serveru BizTalk Server