Příznaky

Pokud se uživatel pokusí nakonfigurovat klienta Microsoft Dynamics CRM pro aplikaci Outlook pomocí Průvodce konfigurací, obdrží uživatel následující chybovou zprávu:

Při komunikaci se serverem Microsoft Dynamics CRM došlo k potížím. Server je pravděpodobně nedostupný. Opakujte akci později. Pokud potíže potrvají, obraťte se na správce.

Příčina

K tomuto problému může dojít z některého z následujících důvodů:

  1. Datum operačního systému v klientském počítači není nastaveno na správné datum.

  2. Čas operačního systému v klientském počítači není nastaven na správný čas.

  3. Časové pásmo operačního systému v klientském počítači není nastaveno na správné časové pásmo.

  4. Existuje několik vazeb HTTP na webu aplikace Microsoft Dynamics CRM v internetové informační službě (IIS).

Řešení

Pro příčiny 1, 2 a 3

  1. Ukončete Průvodce konfigurací aplikace CRM.

  2. Změňte datum a čas operačního systému. Použijte jednu z následujících metod. Metoda 1: Ruční změna času operačního systémuPoznámka : následující kroky jsou pro operační systémy Windows 7 a Windows Server 2008. Chcete-li změnit datum a čas v systému Windows XP ručně, přečtěte si informace v příručce nápovědy k systému Windows XP.

    1. Klepněte na tlačítko Start, klepněte na příkaz Ovládací panely, klepněte na položku hodiny, jazyk a oblasta potom klepněte na tlačítko Datum a čas.

    2. V dialogovém okně Datum a čas klepněte na položku změnit datum a čas a změňte nastavení data a času. Například klepněte na datum, jako například 1. února, 2011 z kalendáře a změňte čas.

    3. Klikněte na tlačítko OK.

    4. Klepněte na položku změnit časové pásmoa vyberte požadované časové pásmo.

    5. Klikněte na tlačítko OK.

    Metoda 2: Konfigurace času operačního systému pro synchronizaci s časovým serverem v Internetu

    1. Klepněte na tlačítko Start, klepněte na příkaz Ovládací panely, klepněte na položku hodiny, jazyk a oblasta potom klepněte na tlačítko Datum a čas.

    2. V dialogovém okně Datum a čas klepněte na kartu čas v Internetu a pak klepněte na tlačítko změnit nastavení.

    3. Klepnutím zaškrtněte políčko synchronizovat s časovým serverem v Internetu , vyberte časový server, klepněte na tlačítko aktualizovata pak klepněte na tlačítko OK.

    Metoda 3: použití příkazu k synchronizaci času s doménou v případě, že je počítač členem domény

    1. Klepněte na tlačítko Start, klepněte na příkaz všechny programy, klepněte na položku příslušenství, klepněte pravým tlačítkem na položku příkazový řádeka potom klepněte na příkaz Spustit jako správce.

    2. Do příkazového řádku zadejte následující text a stiskněte klávesu ENTER:

      NET TIME [{\ \název_počítače |/Domain [:název_domény] |/RTSDOMAIN [:název_domény]}] [/Set]Pokud neznáte název počítače nebo doménu, vyzkoušejte následující jednoduchý příkaz:

      NET TIME/SETPotom zadejte Y a dokončete změnu:alternate text

    Další informace o příkazu net time naleznete na následujícím webu společnosti Microsoft:

    Čistý čas

Metoda 4: vynucení synchronizace klienta NTP (Network Time Protocol) v případě, že počítač používá klienta NTP k synchronizaci se serverem NTPpro příčinu 4na webovém serveru Microsoft Dynamics CRM 2011, spusťte Správce služby IIS a omezte web CRM na jednu vazbu HTTP nebo jednu vazbu protokolu HTTPS, případně obojí. Postupujte podle následujících kroků:

  1. Klepněte na tlačítko Start, na příkaz Spustita do pole otevřít zadejte inetmgr .

  2. Rozbalte stránkya klepněte na web aplikace Microsoft Dynamics CRM.

  3. V podokně akcíklepněte na možnost vazby.

  4. V okně vazby webu se ujistěte, že máte pouze jeden typ vazby HTTP nebo pouze jeden typ vazby https, nebo obojí. Pokud máte více vazeb HTTP nebo více vazeb https, nebo obojí, je nutné odebrat více vazeb.

Poznámka: Vazba, která by měla zůstat, je vazba definovaná ve Správci nasazení. Chcete-li zkontrolovat správné adresy URL, otevřete okno Správce nasazení, klepněte pravým tlačítkem myši na položku Microsoft Dynamics CRM, vyberte příkaz vlastnostia klepněte na kartu Webová adresa . Poznámka Pokud používáte internetové nasazení (IFD), měl by být zachován certifikát, který odpovídá nastavení internetového nasazení.

Další informace

Trasování konfigurace aplikace Outlook (při chybě) pro příčinu 1, 2 a 3

Výjimka byla znovu vyvolána v [0]: v System. Runtime. Remoting. proxy. RealProxy. HandleReturnMessage (IMessage reqMsg, iMesage retMsg) v systému. Runtime. Remoting. proxy. RealProxy. PrivateInvoke (MessageData & msgData, typ Int32) v souboru Microsoft. Xrm. SDK. Discovery. IDiscoveryService. Execute (požadavek Zjistyrequest) v souboru Microsoft. Xrm. SDK. Client. Zjistyserviceproxy. Execute (požadavek Zjistyrequest) na adrese Microsoft. CRM. Application. Outlook. config. DeploymentsInfo. DeploymentInfo. Loadorganizacích (AuthUIMode uiMode) v aplikaci Microsoft. CRM. Application. Outlook. config. DeploymentsInfo. Loadorganizacích (AuthUIMode uiMode) 02:45:29 | Chyba programu | Chyba při připojování k adrese URL: https://dev.crm5.Dynamics.com/XRMServices/2011/Discovery.svcException: System. ServiceModel. Security. MessageSecurityException: od druhé strany byla přijata nezabezpečená nebo nesprávně zabezpečená chyba. Kód chyby a podrobnosti naleznete ve vnitřní chybě FaultException. ---> System. ServiceModel. FaultException: při ověřování zabezpečení zprávy došlo k chybě. ---Konec trasování zásobníku vnitřní výjimkyTrasování platformy serveru Microsoft CRM Server (Chyba při chybě) pro příčinu 4

Chyba: službu/Xrmservices/2011/zjisty.svc nelze aktivovat z důvodu výjimky během kompilace. Zpráva o výjimce je: Tato kolekce již obsahuje adresu s schématem http. V této kolekci může existovat nanejvýš jedna adresa na schéma. Pokud je služba hostitelem služby IIS, můžete problém vyřešit nastavením metody System. serviceModel/serviceHostingEnvironment/multipleSiteBindingsEnabled na hodnotu true nebo zadáním metody System. serviceModel/serviceHostingEnvironment/baseAddressPrefixFilters. Název parametru: položka

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?

Co ovlivnilo váš názor?

Máte další zpětnou vazbu? (Nepovinné)

Děkujeme za váš názor!

×