Při testování připojení pomocí funkce integrace s aplikací Outlook pro produkt Microsoft Dynamics NAV 5.0 chybová zpráva: "Přetečení ve skupinovém rámečku Typ převodu textu na Text"

Šablona: Obecná oprava Hotfix

Chyba č: 80837 (Údržba obsahu)BUG #: 23872 (Vedbaek SE)

Tento článek se týká aplikace Microsoft Dynamics NAV 5.0 ve všech zemích a všechna národní prostředí jazyka.

Příznaky

Test připojení pomocí funkce integrace s aplikací Outlook pro produkt Microsoft Dynamics NAV 5.0, zobrazí se následující chybová zpráva:

Připojení k "Ukázkovou databázi NAV (5-0)" databáze produktu Microsoft Dynamics NAV se nezdařilo.
Program vrátil následující chybu:

Spuštění aplikace Microsoft Dynamics NAV Codeunit pro odpověď Chyba:

Přetečení ve skupinovém rámečku Typ převodu textu na Text.

Poznámka: Funkce integrace s aplikací Outlook pro produkt Microsoft Dynamics NAV 5.0 je doplněk aplikace Microsoft Office Outlook pro aplikaci Microsoft Dynamics NAV 5.0.

K tomuto problému dochází, pokud používáte následující produkty:

  • Microsoft Dynamics NAV 5.0

  • Aplikace Microsoft Office Outlook 2007

  • Funkce integrace s aplikací Outlook pro produkt Microsoft Dynamics NAV 5.0

  • Systém Windows Vista

Příčina

K tomuto problému dochází, protože funkce integrace s aplikací Outlook pro součet zaškrtnutí vrátila nesprávnou délku. Délka součet zaškrtnutí je 32 znaků v systému Windows XP. 40 znaků v systému Windows Vista je však délka součet zaškrtnutí.

Řešení

Podporovaná oprava hotfix je nyní k dispozici od společnosti Microsoft. Tato oprava hotfix řeší problém popsaný v tomto článku. Opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.

Chcete-li tento problém vyřešit okamžitě, obraťte se na technickou podporu Microsoft Dynamics a souvisejících produktů opravu hotfix získat. Můžete přihlásit k webu Microsoft Dynamics a vytvořit novou žádost o podporu. Chcete-li to provést, více se dozvíte na následujícím webu společnosti Microsoft:

https://mbs.microsoft.com/support/newstart.aspxTechnickou podporu Microsoft Dynamics a souvisejících produktů můžete kontaktovat také telefonicky na (888) 477-7877.

Poznámka: Ve zvláštních případech poplatky, které jsou třeba obvykle zaplatit za telefonní hovory mohou být stornovány, jestliže pracovník technické podpory společnosti Microsoft Dynamics a souvisejících produktů Určuje, že konkrétní aktualizace odstraní váš problém. Výdaje na technickou podporu použije pro jakékoli dalších otázek a problémů, které nelze vyřešit konkrétní aktualizací.

Pokud není tato oprava hotfix k volnému stahování (tj. v článku není uvedena veřejná adresa URL opravy hotfix), vyžaduje její distribuce technickým vedoucím, členem týmu a vedoucím přičemž následující předpoklady:

  • Opravu hotfix mohou získat zákazníci se vyskytla chyba, která je uvedena v části "Příznaky".

  • Musí sledovat zákazníci Chcete-li odeslat a dodat v další aktualizaci service Pack, až bude k dispozici (Pokud bude vydána aktualizace service pack).

Tato oprava hotfix je naplánováno mají být zahrnuty s Microsoft Dynamics NAV 5.0 Service Pack 1.



Jak získat opravy hotfix produktu Microsoft Dynamics NAV nebo aktualizaci souborů

Poté, co požadujete opravy hotfix produktu Microsoft Dynamics NAV nebo soubor aktualizace od technické podpory produktů Microsoft Dynamics, hypertextový odkaz bude vám zaslána e-mailem.


E-mailu bude obsahovat hypertextový odkaz a heslo. Můžete použít hypertextový odkaz ke stažení opravy hotfix produktu Microsoft Dynamics NAV nebo aktualizaci souborů. Po klepnutí hypertextový odkaz, otevře se dialogové okno Stažení souboru – upozornění zabezpečení . Potom budete vyzváni ke spuštění, uložit nebo zrušit stahování.


Pokud klepnete na tlačítko Spustitsoubory spusťte stahování a proces extrakce. Musíte zadat složku pro nové soubory a poté zadat heslo.


Pokud klepnete na tlačítko Uložit, musíte zadat cestu pro uložení komprimovaného souboru. Při otevření souboru, který jste uložili se výzva k zadání cesty k souborům. Poté musíte zadat heslo uvedené v e-mailu.


Pokud klepnete na tlačítko Storno, přestane proces stahování.

Jak nainstalovat opravy hotfix produktu Microsoft Dynamics NAV nebo soubor aktualizace

Opravy hotfix produktu Microsoft Dynamics NAV platformu a aktualizace jsou zpřístupněna jako jednotlivé soubory.

Informace o souborech

Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Mapihelper.dll

Není k dispozici

87,504

19-Aug-2007

21:06

x86

Microsoft.dynamics.nav.olsync.common.dll

1.0.0.23559

50,640

20-Aug-2007

02:19

x86

Microsoft.dynamics.nav.olsync.navsyncaddin.dll

5.0.25074.0

759,248

19-Aug-2007

21:06

x86

Chcete-li nainstalovat tuto opravu hotfix, postupujte takto.

  1. Zavřete aplikaci Microsoft Dynamics NAV.

  2. Soubor Microsoft.dynamics.nav.olsync.common.dll přidáte do globální mezipaměť sestavení (GAC). Chcete-li to provést, postupujte takto:

    1. Klepněte na tlačítko Start, na příkaz Ovládací panely, poklepejte na panel Nástroje pro správua potom poklepejte na položku Konfigurace Microsoft rozhraní.NET Framework 2.0.

    2. Klepněte na tlačítko Mezipaměť sestavenía potom přidejte soubor Microsoft.Dynamics.NAV.OLSync.Common.dll do mezipaměti sestavení.

  3. Vložte soubor Microsoft.dynamics.nav.olsync.navsyncaddin.dll a soubor Mapihelper.dll do kořenové složky sady Microsoft Office suite.

    Poznámka: Kořenová složka sady Microsoft Office je následující složky:

    C:\Program Files\Microsoft Office\Office12

  4. Spusťte soubor bat z složku Office12. Následující řádky jsou řádky souboru bat.

    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm.exe Microsoft.Dynamics.NAV.OLSync.NAVSyncAddIn.dll
    /tlb:Microsoft.Dynamics.NAV.OLSync.NAVSyncAddIn.tlb
    copy Microsoft.Dynamics.NAV.OLSync.NAVSyncAddIn.tlb "C:\Program Files\Microsoft Dynamics NAV
    \CSIDEClient\Microsoft.Dynamics.NAV.OLSync.NAVSyncAddIn.tlb"

    Poznámka: Regasm.exe soubor je obvykle umístěn v následující složce:

    C:\Windows\Microsoft .NET\Framework\v2.0.50727

Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:

824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Autor: denmarks
Zapisovatel: v-jozhen
Odborný recenzent: v-jackho
Redaktor: v-nicode

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Děkujeme za váš názor!

×