After upgrade to Dynamics 365, if you try to 'Export As' a solution containing Business Process Flows, a dependency between the Business Process Flow and its entity in the exported solution prevents importing it on to any target CRM 2016 organization

This article provides a resolution for one of the issues that you may meet when importing a solution in Microsoft Dynamics CRM.

Applies to:   Microsoft Dynamics CRM
Original KB number:   4025529

Symptoms

After upgrading a Microsoft Dynamics CRM 2016 organization that contains a Business Process Flow introduced by a solution to Microsoft Dynamics 365, users will be unable to import this solution back in to a Microsoft Dynamics CRM 2016 organization if that solution was packaged via the Export As option from the upgraded organization.

This applies to both online and on-premise customers.

Cause

In Microsoft Dynamics 365, Business Process Flows are represented by entities. These entities will get generated for any Business Process Flows that exist on an organization when it's upgraded to Microsoft Dynamics 365. However, if the Business Process Flows were introduced via a solution, then on upgrade, this solution won't have these generated Business Process Flow entities automatically added to it as part of the upgrade process. In this case, if the user chooses to Export As this solution to 8.1 or 8.0, required dependencies will be missing from the solution that will prevent it from being imported in to a Microsoft Dynamics CRM 2016 organization.

Resolution

Before attempting to Export As such a solution, ensure that for any Business Process Flow that it contains, the corresponding Business Process Flow entity is added to the solution in Microsoft Dynamics 365. Once this is done, creating a solution package for Microsoft Dynamics CRM 2016 via the Export As option in Microsoft Dynamics 365 will generate a usable solution that can be imported successfully.