POTVRZENÍ prohlášení potvrdí dat i v případě, že se zobrazí chyba za běhu v aplikaci Microsoft Dynamics NAV 4.0

Aplikace Microsoft Business Solutions-Navision 4.0 a Microsoft Navision 4.0 jsou nyní součástí produktu Microsoft Dynamics NAV 4.0. Všechny odkazy na aplikaci Microsoft Business Solutions-Navision nebo Microsoft Navision 4.0 se vztahují k produktu Microsoft Dynamics NAV.

Tento článek se týká aplikace Microsoft Dynamics NAV ve všech zemích a všechna národní prostředí jazyka.

Příznaky

Zvažte následující scénář v produktu Microsoft Dynamics NAV 4.0. Můžete určit jednu instanci procedury, která obsahuje příkaz POTVRDIT . Potom spusťte sestavu, která aktualizuje data. Dále můžete sestavu vytisknout. V tomto scénáři příkazu POTVRDIT potvrdí dat i v případě, že se zobrazí chyba za běhu. Tento problém však nedochází při zobrazení náhledu sestavy.

Příčina

K tomuto problému dochází, protože příkaz POTVRDIT v procedura jedné instance potvrdí transakce, které jsou spuštěny v klientovi. Příkaz POTVRDIT to i v případě, že transakce nesouvisejí s jednu instanci procedury.

Řešení

Podporovaná oprava hotfix je nyní k dispozici od společnosti Microsoft. Tato oprava hotfix řeší problém popsaný v tomto článku. Opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.

Chcete-li tento problém vyřešit okamžitě, obraťte se na technickou podporu Microsoft Dynamics a souvisejících produktů opravu hotfix získat. Můžete přihlásit k webu Microsoft Dynamics a vytvořit novou žádost o podporu. Chcete-li to provést, více se dozvíte na následujícím webu společnosti Microsoft:

https://mbs.microsoft.com/support/newstart.aspxTechnickou podporu Microsoft Dynamics a souvisejících produktů můžete kontaktovat také telefonicky na (888) 477-7877.

Poznámka: Ve zvláštních případech poplatky, které jsou třeba obvykle zaplatit za telefonní hovory mohou být stornovány, jestliže pracovník technické podpory společnosti Microsoft Dynamics a souvisejících produktů Určuje, že konkrétní aktualizace odstraní váš problém. Výdaje na technickou podporu použije pro jakékoli dalších otázek a problémů, které nelze vyřešit konkrétní aktualizací.

Jak získat opravy hotfix produktu Microsoft Dynamics NAV nebo aktualizaci souborů

Poté, co požadujete opravy hotfix produktu Microsoft Dynamics NAV nebo soubor aktualizace od technické podpory produktů Microsoft Dynamics, hypertextový odkaz bude vám zaslána e-mailem.


E-mailu bude obsahovat hypertextový odkaz a heslo. Můžete použít hypertextový odkaz ke stažení opravy hotfix produktu Microsoft Dynamics NAV nebo aktualizaci souborů. Po klepnutí hypertextový odkaz, otevře se dialogové okno Stažení souboru – upozornění zabezpečení . Potom budete vyzváni ke spuštění, uložit nebo zrušit stahování.


Pokud klepnete na tlačítko Spustitsoubory spusťte stahování a proces extrakce. Musíte zadat složku pro nové soubory a poté zadat heslo.


Pokud klepnete na tlačítko Uložit, musíte zadat cestu pro uložení komprimovaného souboru. Při otevření souboru, který jste uložili se výzva k zadání cesty k souborům. Poté musíte zadat heslo uvedené v e-mailu.


Pokud klepnete na tlačítko Storno, přestane proces stahování.

Jak nainstalovat opravy hotfix produktu Microsoft Dynamics NAV nebo soubor aktualizace

Opravy hotfix produktu Microsoft Dynamics NAV a aktualizace jsou zpřístupněna jako jednotlivé soubory. Chcete-li nainstalovat opravy hotfix produktu Microsoft Dynamics NAV nebo aktualizace, je nutné nahradit existující soubory instalace produktu Microsoft Dynamics NAV pomocí opravy hotfix produktu Microsoft Dynamics NAV nebo soubor aktualizace. Chcete-li to provést, postupujte takto.

Krok 1: Nahradíte soubory instalace produktu Microsoft Dynamics NAV

V instalaci klienta Microsoft Dynamics NAV nahradí následující soubory pomocí opravy hotfix nebo soubor aktualizace.

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Dbm.dll

4.0.3.25307

345,208

01-Oct-2007

17:57

x86

Fin.exe

4.0.3.25307

8,119,416

01-Oct-2007

17:58

x86

Finhlink.exe

4.0.3.25307

119,928

01-Oct-2007

17:56

x86

Finsql.exe

4.0.3.25307

8,168,568

01-Oct-2007

17:58

x86

Nc_netb.dll

4.0.3.25307

78,968

01-Oct-2007

17:56

x86

Nc_tcp.dll

4.0.3.25307

83,064

01-Oct-2007

17:56

x86

Nc_tcps.dll

4.0.3.25307

91,256

01-Oct-2007

17:56

x86

Ndbcs.dll

4.0.3.25307

1,090,680

01-Oct-2007

17:58

x86

Slave.exe

4.0.3.25307

95,352

01-Oct-2007

17:56

x86

Poznámka: Instalace klienta Microsoft Dynamics NAV je obvykle nainstalován v následujícím adresáři:

C:\Program Files\Microsoft obchodní řešení Navision\ClientChcete-li nahradit existující soubory instalace produktu Microsoft Dynamics NAV, postupujte takto:

  1. Ukončete aplikaci Microsoft Dynamics NAV.

  2. Vyhledejte instalační adresář klienta Microsoft Dynamics NAV.

  3. Zkopírujte soubor, který jste stáhli.

  4. Vložte soubor, který jste stáhli do instalačního adresáře klienta Microsoft Dynamics NAV.

  5. V dialogovém okně Potvrdit nahrazení souboru klepněte na tlačítko Ano chcete přepsat soubory v instalačním adresáři klienta Microsoft Dynamics NAV.

Krok 2: Nahradíte soubory instalace aplikačního serveru Microsoft Dynamics NAV

Při instalaci serveru Microsoft Dynamics NAV Application Server nahradí následující soubory.

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Dbm.dll

4.0.3.25307

345,208

01-Oct-2007

17:48

x86

Nas.exe

4.0.3.25307

1,422,456

01-Oct-2007

17:48

x86

Nassql.exe

4.0.3.25307

1,467,512

01-Oct-2007

17:48

x86

Ndbcs.dll

4.0.3.25307

1,090,680

01-Oct-2007

17:48

x86

Slave.exe

4.0.3.25307

95,352

01-Oct-2007

17:47

x86

Chcete-li nahradit tyto soubory, postupujte takto:

  1. Zastavení serveru Microsoft Dynamics NAV Application Server.

  2. Vyhledejte instalační adresář serveru Microsoft Dynamics NAV Application Server.


    Poznámka: Server aplikace Microsoft Dynamics NAV je obvykle nainstalován v následujícím adresáři:

    C:\Program Files\Microsoft Business Solutions Navision\Application Server

  3. Zkopírujte soubor, který jste stáhli.

  4. Vložte soubor, který jste stáhli do instalačního adresáře serveru Microsoft Dynamics NAV Application Server.

  5. Klepněte na tlačítko Ano chcete přepsat soubory v adresáři instalace serveru Microsoft Dynamics NAV Application Server.

  6. Spuštění serveru Microsoft Dynamics NAV Application Server.

Stav

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Další informace

Pro další informace o terminologii používané v aktualizacích softwaru, klepněte na následující číslo článku k zobrazení článku v databázi Microsoft Knowledge Base:

824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Děkujeme za váš názor!

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×