Důležité upozornění: Tento článek obsahuje informace o úpravě registru. Před úpravou registru se ujistěte, že víte, jak ho obnovit, pokud dojde k problému. Informace o tom, jak to udělat, najdete v tématu nápovědy "obnovení registru" v souboru regedit. exe nebo v tématu nápovědy "obnovení klíče registru" v editoru Regedt32. exe.
Příznaky
Při pokusu o spuštění služby Server může dojít k některému z následujících příznaků:
-
Když se pokusíte spustit službu Server z ovládacího panelu služby, může se zobrazit následující chybová zpráva: službu Server nelze spustit na \ \ <název počítače>. Chyba 1058: Zadaná služba je zakázaná a nejde ji spustit.
-
Když se pokusíte spustit službu serveru z příkazového řádku, může se zobrazit následující chybová zpráva:
Došlo k systémové chybě 1058. Zadaná služba je zakázaná a nejde ji spustit.
-
Když se pokusíte povolit službu Server pro aktuální hardwarový profil, může v seznamu profilů chybět aktuální hardwarový profil nebo může být tlačítko Povolit nedostupné.
Příčina
K tomuto chování může dojít, pokud máte na počítači Dell nainstalovaný systém Windows NT a Windows NT.Poznámka: k tomuto chování nedochází, pokud máte systém Windows NT předinstalovaný v počítači Dell, který je dodán od výrobce, který byl vyroben po 4/6/99.
Řešení
Tento problém vyřešíte pomocí vhodné metody:
Metoda 1
Kontaktujte společnost Dell Corp. Pokud chcete zjistit dostupnost aktualizace, která tento problém řeší. Další informace o kontaktech na výrobce hardwaru a softwaru najdete na následujícím webu společnosti Microsoft:
Metoda 2
Upozornění: nesprávné použití Editoru registru může způsobit vážné problémy, které mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nemůže zaručit, že problémy vyplývající z nesprávného používání editoru registru bude možné vyřešit. Editor registru použijte na vlastní nebezpečí. Informace o tom, jak upravit registr, najdete v tématu nápovědy "Změna klíčů a hodnot" v editoru registru (Regedit. exe) nebo v tématech "Přidání a odstranění informací v registru" a "Úprava dat v registru" v nápovědě k nástroji Regedt32. exe. Nezapomeňte registr před úpravami zálohovat. Odstraňte následující klíče registru a pak restartujte Windows NT: HKEY_LOCAL_MACHINE \system\currentcontrolset\enum\root\ LEGACY_BROWSER HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Enum\Root\ LEGACY_LANMANSERVER HKEY_LOCAL_MACHINE \System\currentcontrolset\enum\root\ LEGACY_MESSENGER HKEY_LOCAL_MACHINE \system\currentcontrolset\enum\root\ LEGACY_SRVPoznámka: Pokud chcete odebrat klíče, které jsou v článku uvedené, musíte zvýšit zabezpečení u oprávnění Everyone na možnost úplné řízení a pak šířit v celém podsložkách pomocí programu Regedt32. exe.
Stav
Společnost Microsoft tento problém prohledá a publikuje nové informace ve znalostní bázi Microsoft Knowledge Base, jakmile bude k dispozici.
Další informace
K tomuto problému dochází jenom u počítačů s nainstalovaným integrovaným zvukovým systémem Yamaha, který se vyskytuje u následujících počítačů:
-
Dell Dimension XPS H266
-
Dell Dimension XPS D300
-
Dell Dimension XPS R400
-
Dell OptiPlex GX1P/T + (P3/500)
-
Dell OptiPlex GX1/m + (PII/450)