Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Jde o takovouto situaci:

  • Máte počítač se systémem Windows 8 nebo Windows Server 2012.

  • Vytisknout soubor pomocí 32bitové aplikace.

  • Tisková úloha byla úspěšně dokončena.

V tomto scénáři nekončí Splwow64.exe proces okamžitě.

Poznámka: Splwow64.exe proces slouží k převodu modelu ovladače 64 bitový operační systém a 32bitové aplikace. Splwow64.exe se používá pro podporu funkce izolace ovladače tiskárny. 32bitové verze systému Windows 8 má svůj vlastní soubor Splwow64.exe a 32bitová verze Splwow64.exe také ovlivněny tento problém. Další informace o izolaci aplikací naleznete na následujícím webu MSDN:

Příčina

K tomuto problému dochází, protože proces Splwow64.exe zůstane v paměti po dobu delší než je nezbytné pro zvýšení výkonu systému po dokončení tiskové úlohy.

Řešení

Tato oprava hotfix je také k dispozici na adrese .

Po použití této opravy hotfix je oprava hotfix nastaví výchozí hodnotu časového limitu pro proces Splwow64.exe zůstávají v paměti až dvě minuty. Proto Splwow64.exe proces končí dvě minuty po dokončení poslední tiskové úlohy. Tato hodnota časového limitu lze navíc nakonfigurovat změnou hodnoty registru. Chcete-li nakonfigurovat hodnotu časového limitu, postupujte takto:

Důležité: Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru mohou nastat závažné problémy Proto se ujistěte, že budete opatrně postupovat podle těchto kroků Pro zvýšení ochrany před úpravou zálohujte registr. Pokud dojde k potížím, pak můžete registr obnovit ze zálohy. Pro další informace o zálohování a obnovení registru klepněte na následující číslo článku databáze Microsoft Knowledge Base:

postup zálohování a obnovení registru v systému Windows

  1. Přejeďte prstem od pravého okraje obrazovky a poté klepněte na tlačítko Hledat. Nebo pokud používáte myš, najeďte ukazatelem do pravého dolního rohu obrazovky a klepněte na tlačítko Hledat.

  2. Do pole Hledat zadejte regedita pak klepněte na položku nebo klepněte na tlačítko regedit.

    UAC Pokud se zobrazí výzva k zadání hesla správce, zadejte heslo. Pokud se zobrazí výzva k zadání potvrzení, poskytnout potvrzení.

  3. Vyhledejte a klepněte na položku nebo klepněte na následující podklíč registru:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print

  4. V nabídce Úpravy přejděte na příkaz Novýa pak klepněte na položku nebo klepněte na příkaz Hodnota DWORD.

  5. Typ SplWOW64TimeOutSeconds.

  6. Stiskněte a podržte SplWOW64TimeOutSeconds, klepněte pravým tlačítkem myši a pak klepněte na položku nebo klepněte na tlačítko změnit.

  7. V poli Údaj hodnoty zadejte hodnotu a pak klepněte na položku nebo klepněte na tlačítko OK.

  8. Ukončete Editor registru.

Poznámka: Musíte zadat hodnotu, která je větší než nula v poli Údaj hodnoty . Hodnota, kterou zadáte je sekund, které systém čeká, pravidelně kontroluje, zda Splwow64.exe proces je uvolněn. K tomuto chování dochází, když uplyne Tento stejný počet sekund poté, co byl uzavřen poslední 32bitový proces tisku. Proto když služba proces tiskne, funkci tisku není uvolněna, dokud ukončí službu a to za nejméně času zadaného v poli Údaj hodnoty překročila. Například do pole Údaj hodnoty zadejte 15 a poslední 32bitový proces trvá dvě minuty k tisku a potom zavřete, funkci tisku je vydána mezi dvě minuty 15 sekund a dvě minuty 30 sekund. Pokud není zadána žádná hodnota časového limitu, je výchozí hodnota časového limitu dvou minut.

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému.

Pokud oprava hotfix je k dispozici ke stažení, je sekce "Oprava Hotfix je k dispozici ke stažení" v horní části tohoto článku znalostní báze Knowledge Base. Pokud tento oddíl není uveden, odešlete požadavek na Microsoft Zákaznický servis a podporu k získání opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:

Poznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musí být spuštěn Windows 8 nebo Windows Server 2012.

Informace o registrech

Pro použití tohoto hotfixu nemusíte provádět žádné změny v registrech.

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Globální verze této opravy hotfix nainstaluje soubory, jejichž atributy jsou uvedeny v následujících tabulkách. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Kalendářní data a časy těchto souborů v místním počítači jsou zobrazeny dle vašeho místního času a také podle aktuálního letního času (DST). Navíc data a časy se mohou změnit při provádění některých operací se soubory.





Poznámky k informacím o soubor pro Windows 8 a Windows Server 2012Důležité: Opravy hotfix pro Windows 8 a Windows Server 2012 opravy hotfix jsou součástí stejné balíčků. Však pouze "Windows 8" je uveden na stránce žádost o opravu Hotfix. Chcete-li požádat o balíčku oprav hotfix, která se vztahuje k jedné nebo obou operačních systémů, vyberte opravu hotfix, která je uvedena v části "Windows 8" na stránce. Vždy se v článcích podívejte v části "Platí pro" na to, pro který operační systém je oprava hotfix určená.

  • Soubory týkající se konkrétního produktu, milníku (RTM, SPn) a složky služby (LDR, GDR) lze identifikovat porovnáním čísel verzí souborů podle následující tabulky:

    Verze

    Výrobek

    Milník

    Složka služby

    6.2.920 0.16 xxx

    Windows 8 a Windows Server 2012

    RTM

    GDR

    6.2.920 xxx 0,20

    Windows 8 a Windows Server 2012

    RTM

    LDR

  • Složky služby GDR obsahují pouze opravy, které byly veřejně vydány k odstranění rozšířených závažných problémů. Větve LDR obsahují kromě veřejně vydaných oprav i opravy hotfix.

  • Soubory MANIFEST (.manifest) a soubory MUM (.mum) instalované pro každé prostředí jsou uvedeny samostatně v části "Další souborů informace pro Windows 8 a Windows Server 2012". MUM a MANIFEST soubory a soubory katalogu (CAT) přidružené zabezpečení, jsou velice důležité k udržení stavu aktualizované součásti. Soubory katalogu zabezpečení, pro něž nejsou uvedeny atributy, jsou podepsané digitálním podpisem společnosti Microsoft.

Pro všechny podporované verze systému Windows 8 x86

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Splwow64.exe

6.2.9200.20738

109,056

07-Jun-2013

03:58

x86

Spoolsv.exe

6.2.9200.16384

496,640

26-Jul-2012

03:20

x86

Pro všechny podporované verze x64 Windows 8 a Windows Server 2012

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Složka služby

Splwow64.exe

6.2.9200.20738

126,464

07-Jun-2013

06:58

x64

AMD64_MICROSOFT-WINDOWS-PRINTING-SP

Spoolsv.exe

6.2.9200.20738

769,024

07-Jun-2013

06:58

x64

AMD64_MICROSOFT-WINDOWS-PRINTING-SP




Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Další informace o podobném problému klepněte na následující čísla článku zobrazení v článcích znalostní báze Microsoft Knowledge Base:

Splwow64.exe proces není ukončen po dokončení tiskové úlohy v 64bitové verzi systému Windows 7 nebo Windows Server 2008 R2

příkaz "runas" nelze použít tisk z jiné uživatelské účty v rámci jedné relace z 32bitového programu v počítači se systémem 64bitové verze systému Windows Server 2008 nebo Windows Vista
Pro další informace o terminologii používané v aktualizacích softwaru, klepněte na následující číslo článku k zobrazení článku v databázi Microsoft Knowledge Base:

Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Další informace o souborech pro systém Windows 8 a Windows Server 2012

Další soubory pro všechny podporované verze systému Windows 8 x86

Název souboru

X86_e34daac0d2b6d45e84ab8ebeed6de725_31bf3856ad364e35_6.2.9200.20738_none_75e00f9569a9cc12.manifest

Verze souboru

Není k dispozici

Velikost souboru

709

Datum (čas UTC)

10-Jun-2013

Čas (UTC)

10:50

Platforma

Není k dispozici

Název souboru

X86_microsoft-windows-printing-spooler-core_31bf3856ad364e35_6.2.9200.20738_none_d3ba6243abe0fabd.manifest

Verze souboru

Není k dispozici

Velikost souboru

242,005

Datum (čas UTC)

10-Jun-2013

Čas (UTC)

10:50

Platforma

Není k dispozici

Další soubory pro všechny podporované verze x64 Windows 8 a Windows Server 2012

Název souboru

Amd64_microsoft-windows-printing-spooler-core_31bf3856ad364e35_6.2.9200.20738_none_2fd8fdc7643e6bf3.manifest

Verze souboru

Není k dispozici

Velikost souboru

242,555

Datum (čas UTC)

07-Jun-2013

Čas (UTC)

21:33

Platforma

Není k dispozici


Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×