Ved hjælp af SQL Server i Windows 8 og nyere versioner af Windows-operativsystemet

Oversigt

Denne artikel indeholder vejledning om, hvordan du bruger forskellige versioner af Microsoft SQL Server på en computer, der kører Windows 10, 2016 for Windows Server, Windows Server 2012 R2, Windows Server 2012, 8.1 på Windows eller Windows 8.

Yderligere oplysninger

SQL Server 2005-oplysninger

Dette afsnit indeholder oplysninger om forekomster af SQL Server 2005 i miljøer med Windows 8.1 eller Windows 8. Det beskriver også, hvilke indstillinger der er tilgængelige for kunder, der bruger SQL Server 2005.

Microsoft SQL Server 2005 (version version og service packs) og tidligere versioner af SQL Server understøttes ikke på Windows 10, 2016 for Windows Server, Windows Server 2012 R2, Windows Server 2012, 8.1 på Windows eller Windows 8. Du modtager en advarsel i Løsningscenter, hvis Windows 10, punkt 8.1 Windows eller Windows 8 registrerer en forekomst af SQL Server 2005.

Du kan løse dette problem ved at opgradere eller fjerne den eksisterende forekomst af SQL Server 2005. Oplysninger om opgradering af SQL Server finder du i opgradere til SQL Server-2014.

Bemærk Dette hyperlink peger på SQL Server-2014. Du kan bruge værktøjet version picker øverst i MSDN-link (Andre versioner) oplysninger om andre versioner.

Oplysninger om Express-udgaver af SQL Server, kan du gå til følgende Microsoft-websteder:

SQL Server 2008 Express Edition (Bemærk du skal manuelt installere Service Pack 4 , når du har installeret SQL Server 2008 Express Edition.)
Yderligere oplysninger om, hvordan du fjerner en eksisterende forekomst af SQL Server 2005, se, hvordan du manuelt fjerner en forekomst af SQL Server 2005 eller Sådan: fjerne en eksisterende forekomst af SQL Server 2005 (installation).

SQL Server version minimumkrav til 10, Windows og Windows Server 2016

I dette afsnit beskrives kravene til installation af SQL Server på en computer, der kører Windows 10 eller Windows Server 2016 minimumversionen.

Før du installerer SQL Server på en computer, der kører Windows 10 eller Windows Server 2016, skal du sikre dig, at du skal opfylde følgende minimumskrav, som passer til din situation.

For SQL Server 2016
Udgivelsen er understøttet version af SQL Server 2016 RTM slippe.

For SQL Server-2014
Du skal anvende SQL Server 2014 Service Pack 1 eller en nyere opdatering. Yderligere oplysninger se, hvordan du anskaffer den nyeste service pack til SQL Server-2014.

For SQL Server 2012
Du skal anvende SQL Server 2012 Service Pack 2 eller en nyere opdatering. Yderligere oplysninger se, hvordan du anskaffer den nyeste service pack til SQL Server 2012.


Noter

  • Sørg for, at du kontrollerer kendte installationsproblemer, når du installerer SQL Server 2012 på 10 til Windows eller Windows Server-2016.
  • Books Online emnet "Hardware- og softwarekravene til installation af SQL Server 2012" er endnu ikke blevet opdateret for at afspejle understøttelsen af Windows Server-2016.
Til SQL Server 2008 R2
SQL Server 2008 R2, understøttes ikke på Windows 10 eller Windows Server-2016.
Til SQL Server 2008
SQL Server 2008 understøttes ikke på Windows 10 eller Windows Server-2016.

Mindste SQL Server-versionskrav til Windows Server 2012 R2 eller Windows 8.1

I dette afsnit beskrives de mindste versionskrav til installation af SQL Server på en computer, der kører Windows Server 2012 R2 eller Windows 8.1.

Før du installerer SQL Server på en computer, der kører Windows Server 2012 R2 eller Windows 8.1, skal du sikre dig, at du skal opfylde følgende minimumskrav, som passer til din situation:
For SQL Server-2014
Du kan installere versionen af SQL Server-2014 eller en nyere version.

Yderligere oplysninger finder du i SQL Server-2014 hovedsiden.
For SQL Server 2012
Du skal anvende SQL Server 2012 Service Pack 1 eller en nyere opdatering. Yderligere oplysninger se, hvordan du anskaffer den nyeste service pack til SQL Server 2012.

Bemærk Kontroller kendte installationsproblemer , når du installerer SQL Server 2012 på Windows 8 eller Windows Server 2012.
Til SQL Server 2008 R2
Du skal anvende SQL Server 2008 R2 Service Pack 2 eller en nyere opdatering. Yderligere oplysninger se, hvordan du anskaffer den nyeste service pack til SQL Server 2008 R2.
Til SQL Server 2008
Du skal anvende SQL Server 2008 Service Pack 3 eller en nyere opdatering.

Bemærk RTM installationen af produktet understøttes. Du har dog installeres de pågældende service packs, når installationen er fuldført. Installationen af SQL Server 2008 understøttes ikke, medmindre du har installeret Service Pack 3, når du har installeret RTM-version. Yderligere oplysninger se, hvordan du anskaffer den nyeste service pack til SQL Server 2008.

Mindste SQL Server-versionskrav til Windows Server 2012 eller Windows 8

I dette afsnit beskrives mindste versionskrav til installation af SQL Server på en computer, der kører Windows Server 2012 eller Windows 8.

Før du installerer SQL Server på en computer, der kører Windows Server 2012 eller Windows 8, skal du sikre dig, at du skal opfylde følgende minimumskrav, som passer til din situation:


For SQL Server-2014
Du kan installere versionen af SQL Server-2014 eller en nyere version.

Yderligere oplysninger finder du tjekke SQL Server-2014 hovedsiden.
For SQL Server 2012
Du kan installere versionen af SQL Server 2012 eller en nyere version.

Bemærk Kontroller kendte installationsproblemer , når du installerer SQL Server 2012 på Windows 8 eller Windows Server 2012.
Til SQL Server 2008 R2
Du skal anvende Microsoft SQL Server 2008 R2 Service Pack 1 eller en nyere opdatering.

Bemærk RTM installationen af produktet understøttes. Du har dog installeres de pågældende service packs, når installationen er fuldført. Følgende meddelelse vises på siden Solution Center:
A screen shot showing the Solution Center page
Yderligere oplysninger se, hvordan du anskaffer den nyeste service pack til SQL Server 2008 R2.
Til SQL Server 2008
Du skal anvende SQL Server 2008 Service Pack 3 eller en nyere opdatering.

Bemærk RTM installationen af produktet understøttes. Du har dog installeres de pågældende service packs, når installationen er fuldført. Installationen af SQL server 2008 understøttes ikke, medmindre du har installeret Service Pack 3, når du har installeret RTM-version. Følgende meddelelse vises på siden Solution Center.

A screen shot showing the Solution Center page

Yderligere oplysninger se, hvordan du anskaffer den nyeste service pack til SQL Server 2008.

Vigtigt Følgende dialogboks vises i SQL Server 2008 R2 og SQL Server 2008, når du kører installationsprogrammet.

A screen shot showing a dialog box that appears in SQL Server 2008 R2 and SQL Server 2008 when running the Setup program

Når SQL Server-installationsprogrammet er afsluttet, er det nødvendigt at installere servicepakker, før du kører SQL Server på denne version af Windows.

For SQL Server 2008, er det nødvendigt at installere Service Pack 3 (SP3) eller en nyere version.

Du har installeret Service Pack 1 (SP1) eller en nyere version, til SQL Server 2008 R2.
SQL Server Compact udgaver
Følgende versioner understøttes i Windows 8.1, Windows 8, 2012 af Windows Server og Windows Server 2012 R2 miljøer:
  • SQL Server Compact 3.5 Service Pack 2 og nyere versioner
  • SQL Server Compact 4.0 og nyere versioner
Bemærk Ingen understøttelse er planlagt til Windows RT enheder.

Understøttelse af switching tilstande i Windows Server 2012 R2 eller Windows Server 2012

Dette afsnit omhandler supportpolitikken, når du skifter Windows Server 2012 R2 eller Windows Server 2012 transporterende tilstande, mens SQL Server er installeret.

Windows Server 2012 R2 og Windows Server 2012 har følgende funktionstilstande eller tilstande:
  • Fuld Server
  • Minimal Server Interface
  • Server Core
Du kan skifte mellem disse funktionstilstande når som helst. Du kan skifte fra Server Core eller Minimal Server Interface fuld Server, når der er installeret en eller flere forekomster af SQL Server-2014 eller SQL Server 2012. Dog være opmærksom på, at du ikke skifte fra én-Server med Minimal Server grænseflade eller Server Core, når en eller flere forekomster af SQL Server-2014 eller SQL Server 2012 er installeret.

Hvis du vil skifte fra fuld Server til Minimal Server Interface eller Server Core, når en eller flere forekomster af SQL Server-2014 eller SQL Server 2012 er installeret, skal du fjerne SQL Server-2014 eller SQL Server 2012, skifte tilstand og derefter geninstallere 2014 til SQL Server eller SQL Server 2012. Du kan dog slå forudsætninger for SQL Server-2014 eller SQL Server 2012 installation i fuld Server-tilstand, skifter til Server Core-tilstand og derefter installere SQL Server-2014 eller SQL Server 2012.

Noter
  • Minimal Server er en Server Core-installation med Server Manager og andre server-værktøjerne er installeret. Derfor udfører installationsprogrammet til SQL Server de samme installationstrin i Windows Server 2012 R2 Minimal Server Interface-tilstand og Windows Server 2012 Minimal Server Interface tilstanden og Server Core. Derudover kan du skifte mellem Server Core og Minimal Server når er installeret en eller flere forekomster af SQL Server-2014 eller SQL Server 2012. Dette er et understøttet scenarie.
  • SQL Server Reporting Services 2012 understøttes ikke på Server Core til Windows Server 2012 R2, Windows Server 2012 Server Core, Windows Server 2012 R2 Minimal Server Interface, eller Windows 2012 Minimal Server Interface-tilstand. Du kan installere SQL Server Reporting Services-2012 på en server, der kører Windows Server 2012 i fuld Server-tilstand og derefter skifte til Windows Server 2012 Server Core-tilstand. Men denne konfiguration understøttes ikke.
  • Vi anbefaler, at du fjerner alle de SQL Server 2012-funktioner understøttes ikke på en server, der kører Windows Server 2012 R2 eller Windows Server 2012 i Server Core-tilstand. Du kan finde oplysninger om, hvordan du gør dette, installere SQL Server 2012 på Server Core.
  • Dette problem gælder ikke for SQL Server 2008- eller SQL Server 2008 R2. SQL Server 2008 og SQL Server 2008 R2, understøttes ikke i Minimal Server Interface eller Server Core-tilstand.

Du kan finde flere oplysninger om de installationsindstillinger, der er tilgængelige, når du installerer Windows Server 2012 Installationsindstillinger for Windows Server.

Kendte problemer med SQL Server 2012 Installation og migrering

Dette afsnit diskuteres installation og migrering af de problemer, der er specifikke for SQL Server 2012.

Generelle bemærkninger
  • Som standard indeholder Windows 8.NET Framework 4.0. 8.1 til Windows og Windows Server 2012 R2 indeholder.NET Framework 4.5, og 10, Windows og Windows Server 2016 Medtag.NET Framework-4.6. Følgende komponenter til SQL Server 2012 afhænger dog af.NET Framework 3.5:
    • SQL Server 2012-databaseprogrammet
    • Replikeringstjenesten
    • SQL Server Data Tools
    • Data Quality Service
    • Master Data Service
    • Reporting Service oprindelig tilstand
    • Fuld tekstsøgning


    Vi anbefaler derfor, at du aktiverer .NET Framework 3.5, før du installerer SQL Server-2014 eller SQL Server 2012 i et enkeltstående eller grupperet for at forhindre enhver mulig SQL Server installation fejl.

    Se, hvordan du aktiverer.NET Framework 3.5 i Windows 8 i denne artikel for at få oplysninger om, hvordan du aktiverer .NET Framework 3.5.
  • SQL Server 2012 installation og konfiguration problemer er løst i de nyeste kumulative opdateringer til SQL Server 2012. Vi anbefaler derfor, at du opretter en slipstream-installationspakke, der indeholder SQL Server 2012 og CU3 eller en nyere opdatering. Oplysninger om, hvordan du gør dette, se, hvordan du programrettelse installationsprogrammet til SQL Server 2012 med en opdateret installationspakke (ved hjælp af UpdateSource for at få en smart Opsætning).

Problemer med installationen af SQL Server 2012, der kan opstå, når.NET Framework 3.5 ikke er aktiveret.

Problem 1 - ufuldstændig failoverklynger i SQL eller separate installationer
Symptomer

På servere, hvor Internet-adgang er begrænset, eller servere, hvor.NET Framework 3.5 allerede ikke er installeret, installerer installationsprogrammet SQL Server 2012 ikke komponenter, der afhænger af.NET Framework 3.5. Installationen af SQL Server 2012 kan derfor være ufuldstændige.
Bemærk 8.1 på Windows eller Windows Server 2012 R2 kan ikke fortsætte installationen.

Kan vises en fejlmeddelelse, der ligner følgende under installationen af SQL Server 2012, når.NET Framework-ikke er aktiveret.

A screen shot showing an error message

Prevention

Du kan undgå dette problem ved at aktivere.NET Framework 3.5 på alle noder i klyngen eller enkeltstående server før du installerer SQL Server 2012.

Opløsning

Du kan løse dette problem på en enkeltstående server, aktiverer.NET Framework 3.5, og kør derefter installationsprogrammet igen for at føje yderligere funktioner.

Du kan løse dette problem i et klyngemiljø, fjerne de ufuldstændige forekomster af SQL Server 2012, aktivere.NET Framework 3.5 og derefter installere SQL Server 2012.

Bemærk Du kan ikke tilføje de funktioner, der blev sprunget over ved at køre installationsprogrammet til SQL Server 2012 igen i et klyngemiljø.

Du kan løse dette problem på en enkeltstående server, aktiverer.NET Framework 3.5, og kør derefter installationsprogrammet til SQL Server.
Problem 2 - brugere fejlagtigt bliver bedt om at hente og installere.NET Framework 3.5
Symptomer

Brugere fejlagtigt kan blive bedt om at hente og installere.NET Framework 3.5, når de forsøger at installere CU1 eller CU2. Dette problem kan opstå, selv om de installerede komponenter ikke afhænger af.NET Framework 3.5.

Brugere kan modtage en fejlmeddelelse, der minder om følgende i denne situation.

A screen shot showing an error message

Årsag

Dette er et kendt problem i SQL Server 2012 CU1 og CU2.

Bemærk Problemet er løst i Samlet opdatering 3 til SQL Server 2012 og nyere versioner.

Forebyggelse

Du kan undgå dette problem ved at benytte en af følgende:
  • Aktiverer.NET Framework 3.5, anvende opdateringspakken CU1 eller CU2 opdateringspakken og derefter deaktivere.NET Framework 3.5.

    Bemærk Du bør kun deaktivere.NET Framework 3.5, hvis din installation ikke indeholder komponenter, der afhænger af.NET Framework 3.5.
  • Du kan installere SQL Server 2012 fra en del af installationsbilledet installationspakke, der indeholder SQL Server 2012 og CU3 eller en nyere version.
  • Anvendelse af samlet opdatering 3 eller en nyere version. Yderligere oplysninger finder du i SQL Server 2012 bygger, der blev udgivet efter SQL Server 2012.
Problem 3 - Windows application compatibility tilstand beskeder vises under en installation
Symptomer

I Windows 8.1, Windows 8, Windows Server 2012 R2, Windows Server 2012, 10 til Windows og Windows Server 2016 er.NET Framework-en funktion On Demand (OD)-komponent. Windows-10, 8.1 til Windows og Windows 8 systempolitikker og systempolitikker 2016 for Windows Server, Windows Server 2012 R2 og Windows Server 2012 kræver desuden brugere besked, når OD komponenter er aktiveret.

Bemærk .NET Framework 4.0 er som standard aktiveret i Windows 8 og Windows Server 2012. Derudover.NET Framework 4.5 er aktiveret i Windows 8.1 og Windows Server 2012 R2, og.NET Framework 4.6 er aktiveret i Windows 10 og i vinduet Server 2016. Dog er.NET Framework 3.5 deaktiveret.

Derfor kan der blive vist en advarsel i programmet kompatibilitet tilstand, der beder brugerne om at hente og installere.NET Framework 3.5 under en uovervåget installation. Disse program compatibility beskeder tilsidesættes ikke. Skærmbilleder af advarsler vises på følgende måde:

Windows Server 2012 R2 og Windows Server 2012 - fuld Server

A screen shot showing alerts for Windows Server 2012 - Full Server

Windows Server 2012 R2 og Windows Server 2012 - Server Core

A screen shot showing alerts for Windows Server 2012 - Server Core

Forebyggelse

For at undgå dette problem, kan brugeren aktivere.NET Framework 3.5, før de udfører en uovervåget installation.

Yderligere problemer med installationen af SQL Server 2012

Problem 1: En.NET Framework, der er opstået en ubehandlet undtagelse kan oprettes, når du forsøger at installere en anden forekomst af SQL Server 2012
Symptomer

Forestil dig følgende:
  • Du kan installere en forekomst af SQL Server 2012.
  • Et.NET Framework 4.0 bruger konfigurationsfilen oprettes, når du installerer forekomsten af SQL Server 2012. Derudover er.NET Framework 3.5 aktiveret under installationen.
  • Du forsøger at installere en anden forekomst af SQL Server 2012.
I dette scenario, kan der oprettes en ikke-afviklet undtagelse. Du kan modtage en fejlmeddelelse, der ligner følgende:

Der opstod en fejl under oprettelsen af konfigurationsafsnittet for userSettings/Microsoft.SqlServer.Configuration.LandingPage.Properties.Settings: kunne ikke indlæse filen eller assemblyen ' System, Version = 4.0.0.0, kultur = neutral, PublicKeyToken = xxxxx' eller en af dens afhængigheder. Systemet kan ikke finde den angivne fil. (C:\Users\Administrator\AppData\Local\Microsoft_Corporation\LandingPage.exe_StrongName_ ryspccglaxmt4nhllj5z3thycltsvyyx\11.0.0.0\user.config)

Fejlmeddelelsen minder om følgende.

A screen shot showing the error message

Årsag

Dette problem opstår i Windows 8 og Windows Server 2012, fordi.NET Framework 4.0 er aktiveret som standard i Windows 8 og Windows Server 2012. Derfor oprettes en konfigurationsfil for.NET Framework 4.0-bruger, når du installerer SQL Server 2012. Derudover er.NET Framework 3.5 aktiveret under installationen.

Når du forsøger at installere den anden forekomst af SQL Server 2012, bruger installationen af.NET Framework 2.0, fordi der allerede er installeret.NET Framework 3.5. Dette er i konflikt med indstillingen i konfigurationsfilen bruger medføre ikke-afviklet undtagelse.

Dette problem opstår, fordi.NET Framework 4.5 er som standard aktiveret i Windows 8.1 og Windows Server 2012 R2 i 8.1 til Windows og Windows Server 2012 R2. Derfor oprettes en konfigurationsfil til.NET Framework 4.5 bruger, når du installerer SQL Server 2012. Derudover er.NET Framework 3.5 aktiveret under installationen.

Når du forsøger at installere den anden forekomst af SQL Server 2012, bruger installationen af.NET Framework 2.0, fordi der allerede er installeret.NET Framework 3.5. Denne konflikt med indstillingen i Brugerkonfigurationen medfører ikke-afviklet undtagelse.

Dette problem opstår, fordi.NET Framework 4.6 er som standard aktiveret i Windows 10 og Windows Server 2016. Derfor oprettes en konfigurationsfil til.NET Framework 4.6 bruger, når du installerer SQL Server 2012. Derudover er.NET Framework 3.5 aktiveret under installationen.

Når du forsøger at installere den anden forekomst af SQL Server 2012, bruger installationen af.NET Framework 2.0, fordi der allerede er installeret.NET Framework 3.5. Dette er i konflikt med indstillingen i konfigurationsfilen bruger medføre ikke-afviklet undtagelse.

Forebyggelse

Slet filen User.config i mappen for at undgå dette problem, før du installerer den anden forekomst af SQL Server 2012:
%userprofile%\AppData\Local\Microsoft_Corporation\LandingPage.exe_StrongName_ryspccglaxmt4nhllj5z3thycltsvyyx\11.0.0.0

Opløsning

Bemærk Problemet er løst i Microsoft SQL Server 2012 Service Pack 1 (SP1).

Hvis den første forekomst allerede har installeret Service Pack 1 bør du ikke opleve dette problem. Hvis du ikke kan installere Service Pack 1 på den første forekomst, og benyt en af følgende fremgangsmåder og derefter installere SQL Server 2012:
  • Installere den anden forekomst af SQL Server 2012 fra en del af installationsbilledet installationspakke , der indeholder SQL Server 2012 og Microsoft SQL Server 2012 Service Pack 1 eller en nyere version.
  • Programrettelse er allerede ved hjælp af SQL Server 2012 SP1-filer:
    • På en computer, hvor SQL Server 2012 RTM ikke er installeret:
      1. Hent og Installer SQL Server 2012 SP1.
      2. Klik på afkrydsningsfeltet jeg accepterer licensbetingelserne på skærmen med licensbetingelserne, og klik derefter på Næste.
        Bemærk Installationsfiler installeres og automatisk lukke installationsguiden.
      3. Kontrol installationen. For at gøre dette skal starte Tilføj eller fjern programmer, og Kontroller, at følgende er angivet:
        • Microsoft SQL Server 2012 Installation, version 11.1.3000.0
        • To poster for Microsoft Visual C++.
    • På en computer, der har en eksisterende forekomst af SQL Server 2012 RTM:
      1. Hent og Installer SQL Server 2012 SP1.
      2. Udpak filerne til SP1 til en lokal mappe. Eksempelvis udpakke filerne til SP1 til c:\sp1.
        Bemærk Du kan ikke køre installationsprogrammet til SQL Server 2012 SP1 i denne situation.
      3. I den mappe, du udpakkede filerne til SP1, skal du dobbeltklikke på SqlSupport.msi og derefter klikke på Ja.
      4. Kontrol installationen. For at gøre dette skal starte Tilføj eller fjern programmer, og Kontroller, at Microsoft SQL Server 2012 Installation, version 11.1.3000.0 er angivet.
    Bemærk Se afsnittet "Installationsvejledning" på SQL Server 2012 SP1 download-siden til at bestemme den korrekte download til din server.
Problem 2: Du kan ikke installere en SQL Server 2012 Failover-klynge med funktionen filshare Stream er aktiveret på Windows Server 2012 R2 eller Windows Server 2012
Symptomer

Du kan modtage en fejlmeddelelse, der ligner følgende, når du forsøger at installere en ny SQL Server 2012 Failover-klynge med FileStream Share-funktionen er aktiveret i Windows Server 2012:

Der opstod en fejl under private egenskaben 'Security0x20Descriptor' til værdien 'System.Byte []' for ressource 'SQL Server Filestream dele (FILESTREAM)'. Fejl: Der opstod en fejl at kalde klynge kode fra en udbyder. Undtagelsesmeddelelse: blev ikke fundet.

Årsag

Dette problem opstår, fordi understøttelse af egenskaben sikkerhedsbeskrivelsen er fjernet i Windows Server 2012.

Forebyggelse

Du kan undgå dette problem ved at installere failover-klynge uden FileStream Share-funktionen aktiveret. Når installationen er fuldført, kan du aktivere funktionen FileStream Share.

Opløsning

Bemærk Problemet er løst i Microsoft SQL Server 2012 Service Pack 1 (SP1).

Du kan løse dette problem, fjerne forekomsten af mislykkede klynge ved hjælp af Tilføj eller fjern programmer, og derefter installere failover-klynge uden FileStream Share-funktionen aktiveret. Når installationen er fuldført, kan du aktivere funktionen FileStream Share.
Problem 3: Fejl under installationen af SQL Server 2012: "det blev forsøgt at indlæse et program med et forkert format"
Symptomer

Forestil dig følgende:
  • Du kan installere en 64-bit version af Windows-10, Windows 8.1 eller Windows 8.
  • Du forsøger at installere SQL Server 2012 i Windows on Windows (WoW) tilstand.
  • Installationen af SQL Server 2012 indeholder Reporting Services.
I dette scenario mislykkes installationen. Derudover modtager du en fejlmeddelelse, der ligner følgende:

Handlingen mislykkedes med 0x8007000B
Det blev forsøgt at indlæse et program med et forkert format.

A screen shot showing the error message

Forebyggelse

Du kan undgå dette problem ved at installere komponenten IIS ASP.NET 3.5 ved hjælp af Serverstyring, før du installerer SQL Server 2012. Yderligere oplysninger finder du i ASP.NET 2.0 og 3.5 ASP.NET fungerer ikke, når du har fjernet ASP.NET 4.5 i Windows 8 eller Windows Server 2012.
Problem 4: Du kan ikke installere en forekomst af failoverklyngetype SQL Server 2012 Enterprise Edition
Symptomer

Forestil dig følgende:
  • Du gør et af følgende:
    • Du kan oprette en del af installationsbilledet installationspakke, der indeholder SQL Server 2012 og CU1.
    • Du programrettelse forhånd ved hjælp af CU1, før du installerer SQL Server 2012.
  • Du kan installere SQL Server 2012 ved hjælp af den UIMODE = EnableUIOnServerCore indstilling.
I dette scenario mislykkes installationen. Du modtager en fejlmeddelelse, som ligner følgende.

A screen shot showing the error message

Ligner følgende oplysninger om fejlen.

A screen shot showing details of the errors

Årsag

Dette problem opstår, fordi funktionen DQ er valgt implicit sammen med komponenten motoren under installationen.

Bemærk DQ-funktion understøttes ikke på Server Core-tilstand.

Opløsning

Bemærk Problemet er løst i SQL Server 2012 RTM CU3 og SQL Server 2012 Service Pack 1.

Du kan løse dette problem ved at benytte en af følgende:
  • Oprette en del af installationsbilledet installationspakke, der indeholder SQL Server 2012 og CU3.
  • Før programrettelse filerne til understøttelse af installationen ved at køre installationspakken CU3.
Problem 5: Fejlmeddelelse, når du forsøger at opgradere Klyngenoden til SQL Server 2012: "de fælles egenskaber for ressource 'SQL netværksnavn (< SQL-Name >)' kunne ikke gemmes"
Du kan finde yderligere oplysninger om problemet og hvordan du løser det, "de fælles egenskaber for ressource 'SQL netværksnavn ()' kunne ikke gemmes" fejl, når du forsøger at opgradere en klyngenode til SQL Server 2012.
Problem 6: Fejlmeddelelse, når du bruger API'EN OpenSQLFileStream: "System.ComponentModel.Win32Exception (0x80004005): anmodningen understøttes ikke."
Symptoms

Forestil dig følgende:
  • Du kan installere en forekomst af SQL Server 2008 R2 på en server, der kører Windows Server 2012.
  • Du kan opgradere forekomsten af SQL Server 2008 R2 til SQL Server 2012 Service Pack 1 (SP1).
  • Du bruger API'EN OpenSQLFileStream.
I dette scenarie modtager du en fejlmeddelelse, der ligner følgende:
System.ComponentModel.Win32Exception (0x80004005): Anmodningen understøttes ikke.

Årsag

Dette problem opstår, fordi SQL Server 2012 opgraderingen sletter forkert følgende nøgle i registreringsdatabasen:
HKEY_LOCALMACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters\FsctlAllowList\FSCTL_SQL_FILESTREAM_FETCH_OLD_CONTENT

Du kan løse problemet

Du kan løse dette problem ved at bruge Registreringseditor til at genoprette følgende nøgle i registreringsdatabasen:
HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters\FsctlAllowList
Dword: FSCTL_SQL_FILESTREAM_FETCH_OLD_CONTENT
Værdi: 0x92560


Kendte installationsproblemer i SQL Server 2008 R2 og SQL Server 2008

Dette afsnit diskuteres installation og migrering af de problemer, der er specifikke for SQL Server 2008 R2 og SQL Server 2008 på en computer, der kører Windows Server 2012 R2, Windows Server 2012, 8.1 på Windows eller Windows 8.

Problem 1: Du kan ikke fjerne SQL Server 2008 Express Edition eller SQL Server 2008 R2 Express Edition
Symptomer

Du kan modtage en fejlmeddelelse, der ligner følgende, når du forsøger at fjerne SQL Server 2008 R2 eller Microsoft SQL Server 2008 Express Edition:

Følgende funktion kunne ikke installeres:
.NET Framework 3.5 (omfatter .NET 2.0 og 3.0)

A screens shot showing the error message

Opløsning

Oplysninger om, hvordan du kan løse dette problem finder du kan ikke fjerne, reparere, tilføje nye funktioner til, eller Tilføj en ny forekomst af SQL Server 2008-eller SQL Server 2008 R2 i Windows 8.

Workaround

Du kan løse dette problem ved at benytte en af følgende:
  • Aktiver.NET Framework 3.5, før du fjerner SQL Server 2008 Express Edition.
  • Kopier filen MediaInfo.xml fra SQL Server 2008 R2-installationsmediet eller SQL Server 2008 Express Edition installationsmediet til følgende mappe, før du forsøger at fjerne SQL Server 2008 R2 eller SQL Server 2008 Express Edition:
    \Programmer filer (x86) \Microsoft SQL Server\100\Setup Bootstrap\SQLServer2008R2
Problem 2: "Klyngetjenesten verification" reglen mislykkes, når du forsøger at installere en forekomst af failoverklyngetype SQL Server 2008 R2
Symptomer

Når du forsøger at installere en forekomst af SQL Server 2008 R2 typen failoverklynge, mislykkes installationen på "klyngetjenesten verification" regel. Når du får vist oplysningerne, modtager du en fejlmeddelelse, der ligner følgende:

A screen shot showing the error message

Årsag

Dette problem opstår, hvis biblioteket COM-baseret MSClus.dll ikke er aktiveret.

Bemærk SQL Server 2008 og SQL Server 2008 R2 klynge installationsprogrammerne afhænger af COM-baseret MSClus.dll-biblioteket. Hvis biblioteket ikke er aktiveret på Klyngenoden, mislykkes installationen.

Opløsning

Du kan løse dette problem ved at benytte en af følgende:
  • Aktiver funktionen Failover-klynge Automation-serveren på hver node ved hjælp af Serverstyring. I Serverstyring, udvid Remote Server-administrationsværktøjer, udvide Funktionen administrationsværktøjer, udvid Failover Clustering værktøjerog klik derefter på Failover Cluster Automation-serveren. (Skærmbilledet for dette trin følger).

    The screen shot for this step
  • Kør følgende Windows PowerShell-cmdlet på hver node for at aktivere funktionen Failover-klynge Automation-serveren:
    Tilføj windowsfeature RSAT-klynger-AutomationServer
    Bemærk Fra en kommandoprompt skal du køre denne cmdlet.

SQL Server 2012 og SQL Server 2008 R2, understøttelse af nye funktioner i Windows 8.1, Windows 8, Windows Server 2012 R2 og Windows Server 2012

Dette afsnit indeholder en oversigt over, hvordan versioner af SQL Server sammen med nogle nye funktioner i Windows 8.1, Windows 8, Windows Server 2012 R2 og Windows Server 2012.


Følgende tabel opsummerer, hvordan versioner af SQL Server sammen med nogle nye funktioner i Windows 8 og Windows Server 2012.

Bemærk Medmindre der er angivet i tabellen nedenfor, understøttes alle funktioner i Windows Server 2012 i alle understøttede versioner af SQL server.

FunktionSQL-funktion eller komponent, der interagerer med denne nye funktionSQL-funktion, der er berørt eller understøttesMindste version og service pack krav til SQLUndtagelser og begrænsningerYderligere oplysninger
Rum til opbevaringSQL Server 2008 R2 Service Pack 1 eller en nyere version, SQL Server 2012 (RTM og nyere versioner)

Bemærk SQL Server 2008 R2 kræver Service Pack 2 på Windows 8.1 og Windows Server 2012 R2.
Denne funktion understøttes med service packs, der er angivet for de respektive versioner.
Robust filsystem (referencer)Referencer understøttes ikke i SQL-2012 og alle andre tidligere versioner. SQL Server-2014 understøtter referencer.
Afhjælpning af fejl i RAM-HardwareLazyWriterKontrolsum side snifferSQL Server 2012Når SQL Server 2012 er installeret på en Windows-2012 operativsystem med hardware, der understøtter forkert Hukommelsesdiagnosticering, vil du bemærke en ny fejlmeddelelser som 854, 855 og 856 i stedet for de 832 fejl, der normalt genererer LazyWriter.
Antal forekomster pr. klyngeHøj tilgængelighedFailover-klyngerSQL Server 201225 pr. failover-klynge, når du bruger drevbogstaver og op til 50, hvis du bruger SMB fil dele storage
Klynge Share diskenheder (CSV)Begynder i 2014 til SQL Server, understøtter AlwaysOn Failover Cluster forekomster grupperet delt diskenheder (CSV) i både Windows Server 2008 R2 og Windows Server 2012. Yderligere oplysninger om CSV, se Forståelse klynge delte drev i en Failover-klynge. CSVs understøttes ikke i tidligere versioner end SQL Server-2014.

Sådan aktiveres.NET Framework 3.5 ved hjælp af Kontrolpanel i Windows 10 og Windows Server 2016

Du kan bruge Kontrolpanel i Windows 10 og Windows Server 2016 aktivere.NET Framework 3.5. Hvis du vil aktivere.NET Framework 3.5, skal du følge disse trin.

Til Windows 10

  1. Gå til Kør linje på Skærmbilledet Start, og skriv "Appwiz.cpl" for at åbne vinduet programmer og funktioner i Kontrolpanel.

    Picture in first step
  2. Vælg Slå Windows-funktioner til eller frai øverste venstre hjørne af vinduet programmer og funktioner .


    Picture in second step
  3. Klik på .NET Framework 3.5 (omfatter .NET 2.0 og 3.0)i vinduet Slå Windows-funktioner til eller fra .


    picture in third step

Til Windows 10

  1. Gå til at køre på skærmbilledet Start, og skriv Appwiz.cpl for at åbne vinduet programmer og funktioner i Kontrolpanel.

    Picture in first step
  2. Server Manager åbnes og begynder at tilføje roller og funktioner guide.


  3. Klik på Næste til at flytte til Vælg installationstypevindue.
  4. Accepter standardværdierne, og vælg Næste for dette vindue.


  5. Vælg Funktioner til venstre i vinduet Vælg destination .


  6. Klik i vinduet Vælg funktioner . NET Framework 3.5.


  7. Klik på .NET Framework3.5 (herunder .NET 2.0 og 3.0)i vinduet Vælg funktioner .

    picture in third step


Sådan aktiveres.NET Framework 3.5 i Windows 8.1, Windows 8, Windows Server 2012 R2 og Windows Server 2012


Forudsætninger for.NET Framework 3.5 i Windows 8 og Windows Server 2012
Følgende forudsætninger er nødvendige for at aktivere.NET Framework 3.5 i 8 til Windows og Windows Server 2012:

Sådan aktiveres.NET Framework 3.5 ved hjælp af Kontrolpanel i Windows 8.1 og Windows 8

Du kan bruge Kontrolpanel i Windows 8.1 eller Windows 8 til at aktivere.NET Framework 3.5. Hvis du vil aktivere.NET Framework 3.5, skal du følge disse trin:
  1. Klik på Indstillingerpå på Skærmbilledet Start type Slå windows-funktioner, og klik derefter på Slå Windows-funktioner til eller fra. (Skærmbilledet for dette trin følger).

    The screen shot for this step
  2. Klik på .net Framework 3.5 (omfatter .NET 2.0 og 3.0), under Slå Windows-funktioner til eller fra.
    Bemærk Guiden søge efter nødvendige filer og derefter bede dig om at hente filerne fra Windows Update.
  3. Klik på Hent filer fra Windows Update.
  4. Klik på Udfør. (Skærmbilledet for dette trin følger).
The screen shot for this step

Sådan aktiveres.NET Framework 3.5 ved hjælp af Tilføj roller og funktioner guiden i Windows Server 2012 R2 og Windows Server 2012

Hvis du vil aktivere.NET Framework 3.5 i Windows Server 2012 eller Windows Server 2012 R2, skal du følge disse trin:
  1. I Serverstyring, skal du klikke på Administrer, og klik derefter på Tilføj roller og funktioner. (Skærmbilledet for dette trin følger).

    The screen shot for this step
  2. Klik på Næstepå skærmbilledet før du begynder .
  3. Klik på rolle- eller funktion-baseret installation på skærmbilledet Vælg installationstype , og klik derefter på Næste.
  4. Vælg destinationsserveren på skærmbilledet Vælg destinationsserver , og klik derefter på Næste.
  5. Klik på Næstepå skærmbilledet Vælg serverroller .
  6. Klik her for at markere afkrydsningsfeltet .NET Framework 3.5 funktioner på skærmbilledet Vælg funktioner , og klik derefter på Næste.
  7. Luk advarslen, og klik derefter på Installer.
    Hvis computeren ikke har forbindelse til internettet, skal du klikke på Angiv en alternativ kildesti, skrive stien til mappen \sources\SxS på installationsmediet og derefter klikke på OK. Luk advarslen, og klik derefter på Installer. (Skærmbilledet for dette trin følger).

    The screen shot for this step

    Bemærk I skærmbilledet, se den sætning, at.NET Framework 3.5 ikke er en del af en typisk installation. Installationsfilerne til er dog tilgængelige i en mappe med side om side-lager. Du har desuden ikke at tilslutte eller peger på en bestemt WIM-kilde.

Bemærk, at hvis du bruger Serverstyring i Windows Server 2012 til at føje en rolle eller funktion til en fjernserver, computerkontoen på fjernserveren kræver adgang til filstien alternativ kilde, fordi handlingen installation kører i systemkonteksten på destinationsserveren.



Integreret SharePoint-tilstand for SQL Server Reporting Services

I dette afsnit beskrives, hvad du skal overveje, når du konfigurerer SQL Server i integreret SharePoint-tilstand.

Se Windows Server 2012 understøtter ikke SharePoint Server 2010for at få oplysninger om, hvordan du planlægger, hvad du skal overveje, når du konfigurerer SQL Server i integreret SharePoint-tilstand.

System Center Advisor regel oplysninger

Regel softwareRegel titelBeskrivelse af regelProduktversioner, som reglen evalueres
System Center AdvisorSQL Server-databasefilerne er placeret i en ikke-understøttet filsystemDenne SQL Server konstateret forekomsten advisor tilstedeværelsen af en eller flere databasefiler, der er bosat under referencer (robust File System) i Windows Server 2012 R2 og Windows Server 2012. Vært-databaser på Windows Server 2012 R2 og Windows Server 2012 referencer filsystemer understøttes ikke til produktionsbrug. Gennemse listen over databaser nedenfor og tager korrigerende handlinger. Se KB-artikel for at få yderligere oplysninger.SQL Server 2008
SQL Server 2008 R2
SQL Server 2012

Referencer

Du kan finde flere oplysninger om, hvordan du installere.NET Framework 3.5 overvejelser om installation af Microsoft.NET Framework 3.5.

Se IIS 8.0 ved hjælp af ASP.NET 3.5 og 4.5 ASP.NETkan finde flere oplysninger om, hvordan du bruger ASP.NET 3.5 og 4.5 ASP.NET i IIS 8.0.

Finde oplysninger om problemer, der kan opstå, når du har installeret ASP.NET 4.5, ASP.NET 2.0 og 3.5 ASP.NET fungerer ikke, når du har fjernet ASP.NET 4.5 i Windows 8 eller Windows Server 2012.

Yderligere oplysninger om nye funktioner i Windows Server 2012, se What's New in Windows Server 2012.

Yderligere oplysninger om, hvordan du installerer failover-klynger i Windows Server 2012 finder du installerer Failover Cluster funktion og værktøjer i Windows Server 2012.
Egenskaber

Artikel-id: 2681562 – Seneste udgave 23. jan. 2017 – Udgave 2

Feedback