Fejlmeddelelsen "Typen 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy' kunne ikke indlæses" om en undtagelse vises efter installation af opdatering 982167 eller opdatering 982168

Support til Windows XP er ophørt

Microsoft ophørte med at yde support til Windows XP den 8. april 2014. Denne ændring har haft indflydelse på dine softwareopdateringer og sikkerhedsindstillinger. Se, hvad det betyder for dig, og hvordan du kan forblive beskyttet.

Support til Windows Server 2003 ophørte den 14. juli 2015

Microsoft afsluttede support til Windows Server 2003 den 14. juli 2015. Denne ændring har haft indflydelse på dine softwareopdateringer og sikkerhedsindstillinger. Se, hvad det betyder for dig, og hvordan du kan forblive beskyttet.

Symptomer
Når du har installeret opdatering 982167 eller opdatering 982168, vises der muligvis en fejlmeddelelse om en undtagelse, som minder om følgende, når du kører applikationer, der er baseret på Windows Communication Foundation:
Typen 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy' kunne ikke indlæses
Årsag
Opdatering 982167 og opdatering 982168 omfatter opdatering af funktionslaget .NET Framework 2.0 i .NET Framework 3.5 SP1 med den nye type 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy'. Denne nye type bruges i den tilsvarende nye funktion i Windows Communication Foundation.

Fejlen opstår, fordi det bagvedliggende funktionslag i .NET Framework 2.0 SP2-netværksklientbiblioteket ikke opdateres, når Windows Communication Foundation-funktionslaget opdateres til at bruge den nye type. Det bagvedliggende funktionslag i .NET Framework 2.0 SP2-netværksklientbiblioteket understøtter ikke den nye type, og derfor vises fejlmeddelelsen.

Denne situation kan opstå af mange forskellige årsager, herunder visse installationsproblemer, der er relateret til Dual Branch Servicing. Du kan finde flere oplysninger ved at klikke på nedenstående artikelnummer for at få vist artiklen i Microsoft Knowledge Base:
960043 Dual Branch Servicing for .NET Framework 2.0 Service Pack 2, .NET Framework 3.0 Service Pack 2 og .NET Framework 3.5 Service Pack 1
Workaround
Du kan løse problemet ved at benytte følgende fremgangsmåde:
  1. Installer hotfix 975954. Du kan hente MSI-opdateringerne på følgende MSDN-webside:
  2. Kør en reparation af produktet. Vi kan reparere produktet for dig automatisk, eller du kan selv reparere det.

    Løs det for mig

    Hvis reparationen af produktet skal køres automatisk, skal du klikke på linket Løs problemet. Klik derefter på Kør i dialogboksen Filoverførsel, og følg fremgangsmåden i denne guide.

    Bemærk! Denne guide er i øjeblikket kun tilgængelig på engelsk. Den automatiske løsning fungerer dog også for andre sprogversioner af Windows.

    Bemærk! Hvis du ikke arbejder på den computer, hvor problemet forekommer, kan du gemme den automatiske løsning på et flashdrev eller på en cd og derefter køre den på den computer, der har problemet.

    Lad mig selv løse det

    Hvis du selv vil reparere produktet, skal du skrive følgende kommando fra en kommandoprompt med administratorrettigheder:
    msiexec /f {C09FB3CD-3D0C-3F2D-899A-6A1D67F2073F}

    Det får alle funktioner i .NET Framework 2.0 SP2-produktet til at undersøge installationstilstanden.
    Det løser problemet, og de respektive datafiler i opdatering 982167 eller 982168 kan nu anvendes.
Bemærk! Hvis trin 1 og 2 ikke fungerer, kan du prøve at fjerne den opdatering, du installerede, før du oplevede fejlen, og derefter installere opdateringen igen.
Status
Microsoft har bekræftet, at dette problem forekommer i de Microsoft-produkter, der er angivet i afsnittet "Gælder for".
Yderligere Information
Du kan finde oplysninger om, hvordan du kører en kommando med administratorrettigheder på følgende Microsoft-webside: Du kan finde flere oplysninger om de kommandolinjeparametre, der understøttes i Windows Installer, på følgende MSDN-webside: Du kan finde flere oplysninger om Windows Installer på følgende MSDN-webside:
security update patch 982167 982168 load type 'System.Security.Authentication.ExtendedProtection.ExtendedProtectionPolicy' WCF fixit fix it
Bemærk! Dette er en artikel til hurtig udgivelse, som er oprettet direkte i Microsofts supportafdeling. Oplysningerne i artiklen præsenteres som de og behandler aktuelle problemer. Fordi artiklen er blevet udgivet hurtigt, kan der forekomme slåfejl, og artiklen kan blive redigeret uden varsel. Se andre forbehold under Vilkår for anvendelse.
Egenskaber

Artikel-id: 2262911 – Seneste udgave 11/29/2013 16:41:00 – Udgave 4.0

Microsoft .NET Framework 3.5 Service Pack 1, Microsoft .NET Framework 2.0 Service Pack 2, Microsoft Windows Server 2003 Service Pack 2, Microsoft Windows XP Service Pack 2

  • kbbug kbexpertiseinter kbinfo kbsecurity kbmsifixme kbfixme KB2262911
Feedback