Du er offline. Venter på, at der oprettes forbindelse til internettet igen

Det er ikke muligt at åbne Office-dokumenter fra et SSL-websted i Internet Explorer

Symptomer
Når du forsøger at åbne eller hente et Microsoft Office-dokument (.doc-fil, .xls-fil, .ppt-fil osv.) fra et sikkert websted i Internet Explorer, kan du få vist en af følgende fejlmeddelelser, selvom dokumentet er tilgængeligt og overført fra serveren:

Fejlmeddelelse 1

Internet Explorer kan ikke indlæse fil fra server.
Internet Explorer kunne ikke åbne dette Internetsted. Det anmodede sted er enten ikke tilgængelig eller kan ikke findes. Prøv igen senere.
Fejlmeddelelse 2

Siden kan ikke vises.
Den side, du leder efter, er ikke tilgængelig. Der kan være tekniske problemer på webstedet, eller det kan være nødvendigt at ændre webbrowserens indstillinger.
Serveren blev ikke fundet, eller der opstod en DNS-fejl
Fejlmeddelelse 3

Navn på Office-program kan ikke åbne filen.
Fejlmeddelelse 4

Publisher kan ikke finde den angivne fil.
Problemet opstår, hvis serveren bruger SSL (Secure Sockets Layer) og har tilføjet en af eller begge følgende HTTP-headere til svarmeddelelsen:
Pragma: no-cacheCache-control: no-cache,max-age=0,must-revalidate				
Årsag
Hvis Internet Explorer skal kunne åbne dokumenter i Office (eller en ekstern ActiveX-dokumentserver), skal Internet Explorer gemme filen i den lokale cachemappe og bede det tilknyttede program om at indlæse filen ved hjælp af IPersistFile::Load. Hvis filen ikke er gemt på en disk, vil denne handling mislykkes.

Når Internet Explorer kommunikerer med et sikkert websted via SSL, gennemtvinger Internet Explorer enhver ikke-cache-anmodning. Hvis der findes en eller flere headere, cachelagrer Internet Explorer ikke filen. Derfor kan filen ikke åbnes i Office.
Løsning
Websteder, der vil tillade denne type handling, skal fjerne den eller de pågældende ikke-cache-headere.
Status
Denne funktionsmåde er tilsigtet.
Yderligere Information
Filer, der er tilknyttet selve Internet Explorer (herunder .txt-filer, .html-filer, .gif-filer, .jpg-filer, .xml-filer osv.), oplever generelt ikke dette problem. Filer, der er tilknyttet ikke-Office-programmer, kan opleve problemet, afhængigt af programmet.

Webudviklere skal være opmærksomme på, at nogle firewalls og sikkerhedsprogrammer muligvis automatisk føjer disse headere til alle udgående HTTP-svar. Selvom du ikke har konfigureret webserveren, ISAPI-udvidelsen (Internet Server Application Programming Interface) eller ASP-scriptet (Active Server Pages) til at returnere disse headere, kan webstedet medtage dem som standard. Spørg firewall- eller sikkerhedsadministratoren, om dette er tilfældet, og diskuter sikkerhedsrisiciene for din virksomhed, hvis du vælger at deaktivere denne indstilling for at tillade cachelagring af disse filer.

Trin til genskabelse af funktionsmåden

  1. Opret en ny ASP-fil i mappen Wwwroot til IIS-serveren. Giv filen navnet Testnocache.asp, og føj derefter følgende kode til filen:
    <% Response.ContentType = "application/msword" Response.AddHeader "Cache-control", "no-cache"%><HTML><BODY>Test filen, der indlæses i Microsoft Word</BODY></HTML>					
  2. Konfigurer IIS-serveren, så den bruger SSL.
  3. På et klientsystemet, hvor Word er installeret, skal du på følgende måde finde ASP-filen ved hjælp af HTTPS:
    https://[servername]/testnocache.asp
    På nogle systemer kan du blive bedt om at åbne eller gemme filen. Uanset, hvilken løsning du vælger (eller hvis du ikke bliver bedt om at åbne eller gemme filen), vil du få vist en fejlmeddelelse, og du vil ikke kunne åbne eller gemme filen.
  4. Fjern linjen AddHeader fra ASP-filen, og find derefter URL'en fra klienten. Dokumentet åbnes i Word.
Referencer
Yderligere oplysninger finder du ved at klikke på nedenstående artikelnummer for at få vist artiklen i Microsoft Knowledge Base:
248107 Oprettelse af servercertifikater ved hjælp af webformularer i Certifikattjenester (artiklen er evt. på engelsk)
Egenskaber

Artikel-id: 316431 – Seneste udgave 02/02/2006 17:24:00 – Udgave 7.1

  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0
  • kbprb KB316431
Feedback