Et program, som bruger filen Sxs.dll, går ned, når du kører programmet på en Windows XP-baseret computer

Support til Windows XP er ophørt

Microsoft ophørte med at yde support til Windows XP den 8. april 2014. Denne ændring har haft indflydelse på dine softwareopdateringer og sikkerhedsindstillinger. Se, hvad det betyder for dig, og hvordan du kan forblive beskyttet.

Symptomer
Når du kører et program, som bruger filen Sxs.dll, på en Windows XP-baseret computer, går programmet muligvis ned.
Årsag
Problemet opstår på grund af en adgangsfejl, som skyldes en beskadiget stak i filen Sxs.dll. Når du kører programmet, kaldes funktionen SxsFindClrClassInformation to gange. Under det første kald beregnes, hvor meget buffer funktionen har brug for. Under det andet kald skrives der data til bufferen. Det tal, som funktionen SxsFindClrClassInformation beregner, er dog mindre end det tal, som funktionen skriver. Dette medfører, at stakken beskadiges.
Løsning

Oplysninger om hotfix

Et understøttet hotfix er tilgængeligt fra Microsoft. Dette hotfix er dog kun beregnet til at afhjælpe det problem, der er beskrevet i denne artikel. Hotfixet må kun anvendes på de systemer, der har dette særlige problem. Dette hotfix testes muligvis yderligere. Hvis du ikke er alvorligt berørt af problemet, anbefales det, at du venter på den næste softwareopdatering, der indeholder dette hotfix.

Hvis hotfixet kan hentes, er dette angivet i et separat afsnit i toppen af denne artikel i Microsoft Knowledge Base. Hvis der ikke findes et afsnit om hentning af hotfixet i artiklen, kan du anskaffe hotfixet ved at kontakte Microsoft-kundesupport.

Bemærk! Hvis der opstår flere problemer, eller hvis der er behov for supplerende fejlfinding, er det muligvis nødvendigt at oprette en separat serviceanmodning. De sædvanlige supportomkostninger gælder for supplerende supportspørgsmål og -problemer, der ikke falder ind under det nævnte hotfix. Du finder en komplet liste over telefonnumre til Microsoft-kundesupport og oplysninger om, hvordan du opretter en serviceanmodning, på følgende Microsoft-websted: Bemærk! De sprog, som hotfixet er tilgængeligt på, er angivet i formularen til hentning af hotfixet. Hvis dit sprog ikke er angivet i formularen, betyder det, at hotfixet ikke er tilgængeligt på det pågældende sprog.

Forudsætninger

Windows XP Service Pack 2 eller Windows XP Service Pack 3 skal installeres, inden du anvender dette hotfix.

Krav om genstart

Genstart computeren, når du har installeret dette hotfix.

Oplysninger om hotfixerstatning

Dette hotfix erstatter ikke et tidligere udgivet hotfix.

Filoplysninger

Den engelske version af dette hotfix indeholder de filattributter, der er angivet i nedenstående tabel (eller nyere attributter). Dato og klokkeslæt for disse filer er angivet i UTC-format (Universal Time Coordinates). Når du får vist filoplysningerne, konverteres de til lokal tid. Brug fanen Tidszone under Dato og klokkeslæt i Kontrolpanel til at finde forskellen mellem UTC og lokal tid.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Sxs.dll5.1.2600.3295713,21617-Jan-200817:59x86SP2SP2QFE
Sxs.dll5.1.2600.5699713,21623-Oct-200813:39x86SP3SP3QFE
Status
Microsoft har bekræftet, at dette problem forekommer i de Microsoft-produkter, der er angivet i afsnittet "Gælder for".
Yderligere Information
Du kan finde flere oplysninger om softwareopdateringsterminologi ved at klikke på nedenstående artikelnummer for at få vist artiklen i Microsoft Knowledge Base:
824684 Beskrivelse af den standardterminologi, der bruges til at beskrive Microsoft-softwareopdateringer
Egenskaber

Artikel-id: 943232 – Seneste udgave 06/30/2009 14:00:38 – Udgave 2.0

Microsoft Windows XP Professional, Microsoft Windows XP Home Edition

  • kbautohotfix kbexpertiseadvanced kbpubtypekc kbqfe kbhotfixserver KB943232
Feedback