Brug af en funktion som et af argumenterne i en formel, der bruger en funktion, kaldes indlejring, og denne funktion omtales som en indlejret funktion. Ved at indlejre funktionen MIDDEL og SUM i argumenterne i funktionen HVIS summerer følgende formel kun et sæt tal (G2:G5), hvis gennemsnittet af et andet sæt tal (F2:F5) er større end 50. Ellers returneres 0.

Indlejrede funktioner

Funktionerne MIDDEL og SUM er indlejret i funktionen HVIS.

Du kan indlejre op til 64 funktionsniveauer i en formel.

  1. Klik på den celle, hvor du vil indtaste formlen.

  2. Hvis du vil starte formlen med funktionen, skal du klikke på Indsæt Knapflade på formellinjen Knapflade.

    Excel indsætter lighedstegnet (=) for dig.

  3. Vælg Alle i feltet Eller vælg en kategori.

    Hvis du kender funktionskategorierne, kan du også vælge en kategori.

    Hvis du ikke er helt sikker på, hvilken funktion du skal bruge, kan du skrive et spørgsmål, som beskriver, hvad du vil gøre, i feltet Søg efter en funktion ("addere tal" returnerer f.eks. funktionen SUM).

  4. Hvis du vil angive en anden funktion som argument, skal du skrive funktionen i det ønskede argumentfelt.

    Delene af formlen, der vises i dialogboksen Funktionsargumenter, afspejler den funktion, du valgte i forrige trin.

    Hvis du klikkede HVIS, viser dialogboksen Funktionsargumenter argumenterne for funktionen HVIS. Hvis du vil indlejre en anden funktion, kan du angive den i argumentfeltet. Du kan f.eks. skrive SUM(G2:G5)i Value_if_true af funktionen HVIS.

  5. Angiv eventuelle yderligere argumenter, der er nødvendige for at fuldføre formlen.

    I stedet for at skrive cellereferencer kan du også markere de celler, du vil referere til. Klik Knapflade for at minimere dialogboksen, markér de celler, du vil referere til, og klik derefter på Knapflade for at udvide dialogboksen igen.

    Tip!: Du kan få flere oplysninger om funktionen og de tilhørende argumenterne ved at klikke på Hjælp til denne funktion.

  6. Når du har angivet argumenterne for formlen, skal du klikke på OK.

  1. Klik på den celle, hvor du vil indtaste formlen.

  2. Hvis du vil starte formlen med funktionen, skal du klikke på Indsæt Knapflade på formellinjen Knapflade.

  3. I dialogboksen Indsæt funktion i feltet Vælg en kategori skal du vælge Alle.

    Hvis du kender funktionskategorierne, kan du også vælge en kategori.

  4. Hvis du vil angive en anden funktion som argument, skal du angive funktionen i argumentfeltet i Formelbygger eller direkte i cellen.

  5. Angiv eventuelle yderligere argumenter, der er nødvendige for at fuldføre formlen.

  6. Tryk på Enter, når du har fuldført argumenterne for formlen.

Eksempler

Følgende viser et eksempel på brug af indlejrede HVIS-funktioner til at tildele et bogstavkarakter til et numerisk testresultat.

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Score

45

90

78

Formel

Beskrivelse

Resultat

'=HVIS(A2>89;"A";HVIS(A2>79;"B"; HVIS(A2>69;"C";HVIS(A2>59;"D";"F"))))

Anvender indlejrede HVIS-betingelser til at tildele karakterer til karakteren i celle A2.

=HVIS(A2>89,"A",HVIS(A2>79,"B",HVIS(A2>69,"C",HVIS(A2>59,"D","F"))))

'=HVIS(A3>89;"A";HVIS(A3>79;"B"; HVIS(A3>69;"C";HVIS(A3>59;"D";"F"))))

Anvender indlejrede HVIS-betingelser til at tildele scoren i celle A3 en karakter.

=HVIS(A3>89,"A",HVIS(A3>79,"B",HVIS(A3>69,"C",HVIS(A3>59,"D","F"))))

'=HVIS(A4>89;"A";HVIS(A4>79;"B"; HVIS(A4>69;"C";HVIS(A4>59;"D";"F"))))

Anvender indlejrede HVIS-betingelser til at tildele karakterer til karakteren i celle A4.

=HVIS(A4>89,"A",HVIS(A4>79,"B",HVIS(A4>69,"C",HVIS(A4>59,"D","F"))))

Tip!: 

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community eller få support i Answers-forummet

Se også

Video: Indlejrede HVIS-funktioner

Har du brug for mere hjælp?

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Deltag i Microsoft Office Insiders

Var disse oplysninger nyttige?

Hvor tilfreds er du med kvaliteten af sproget?
Hvad påvirkede din oplevelse?

Tak for din feedback!

×