Sådan retter du et #REF! fejl

Fejlen #REFERENCE! vises, når en formel refererer til en celle, der ikke er gyldig. Dette sker oftest, når celler, der er refereres til i formler, bliver slettet eller overskrevet.

Eksempel – #REF! forårsaget af sletning af en kolonne

Det følgende eksempel anvender formlen =SUM(B2,C2,D2) i kolonne E.

En formel, der bruger eksplicitte cellereferencer som =SUM(B2,C2,D2) kan forårsage en #REF! -fejlen, hvis en kolonne slettes.

Hvis du slettede kolonne B, C eller D, ville det medføre et #REF! som fejl. I dette tilfælde sletter vi kolonne C (2007-salg), og formlen læser nu =SUM(B2,#REF!,C2). Når du bruger eksplicitte cellereferencer som denne (hvor du refererer til hver celle enkeltvis adskilt af et komma) og sletter en refereret række eller kolonne, kan Excel ikke løse den, så den returnerer #REF! som fejl. Dette er den primære årsag til, at det ikke anbefales at bruge eksplicitte cellereferencer i funktioner.

Eksempel på #REF! fejl, der er opstået ved at slette en kolonne.

Løsning

  • Hvis du ved et uheld sletter rækker eller kolonner, kan du straks klikke på knappen Fortryd på Værktøjslinjen Hurtig adgang (eller trykke på CTRL+Z) for at gendanne dem.

  • Justér formlen, så den bruger et områdereference i stedet for individuelle celler, såsom =SUM(B2:D2). Nu kan du slette enhver kolonne inden for området sum, og så vil Excel justere automatisk formlen. Du kan også bruge =SUM(B2:B5) til en sum af rækker.

Eksempel – VOPSLAG med forkerte områdereferencer

I følgende eksempel returnerer =LOPSLAG(A8,A2:D5,5,FALSK) et #REF! denne fejl, fordi den leder efter en værdi, der skal returneres fra kolonne 5, men referenceområdet er A:D, som kun er 4 kolonner.

Eksempel på en LOPSLAG-formel med et forkert område.  Formlen er = LOPSLAG(A8,A2:D5,5,FALSK).  Der er ingen femte kolonne i området LOPSLAG, så 5 forårsager en #REF! som fejl.

Løsning

Justér området til at være større, eller reducer opslagsværdien for kolonnen for at matche referenceområdet. =VOPSLAG(A8,A2:E5,5,FALSK) ville være et gyldigt referenceområde, ligesom = VOPSLAG(A8,A2:D5,4,FALSK) også ville.

Eksempel – INDEKS med forkert række- eller kolonnereference

I dette eksempel returnerer formlen =INDEKS(B2:E5,5,5) et #REF! denne fejl, fordi indeksområdet er 4 rækker gange 4 kolonner, men formlen beder om at returnere, hvad der er i den 5. række og 5. kolonne.

Eksempel på en INDEKS-formel med en ugyldig områdereference.  Formlen er = INDEKS(B2:E5,5,5), men området er kun 4 rækker med 4 kolonner.

Løsning

Justér referencerne række eller kolonne, så de er inden for INDEKS-opslagsområde. =INDEKS(B2:E5,4,4) ville returnere et gyldigt resultat.

Eksempel – Referering af en lukket projektmappe med INDIREKTE

I følgende eksempel forsøger en indirekte funktion at referere til en projektmappe, der er lukket, hvilket forårsager en #REF! som fejl.

Eksempel på en #REF! forårsaget af indirekte reference til en lukket projektmappe.

Løsning

Åbn den projektmappe, der refereres til. Du vil støde på den samme fejl, hvis du refererer til en lukket projektmappe med en dynamisk matrixfunktion.

OLE-problemer

Hvis du har brugt en OBJEKT-sammenkædning og indlejring (OLE), der returnerer en #REF! og derefter starte det program, som linket ringer til.

Bemærk: OLE er en teknologi, som du kan bruge til at dele oplysninger mellem programmer.

DDE-problemer

Hvis du har brugt et Dynamic Data Exchange (DDE)-emne, der returnerer en #REF! skal du først kontrollere, at du refererer til det korrekte emne. Hvis du stadig modtager en #REF! , skal du kontrollere, om Indstillinger efter eksternt indhold, sådan som det er beskrevet i Blokere eller fjerne blokeringen af eksternt indhold Office dokumenter.

Bemærk! Dynamic Data Exchange (DDE)er en etableret protokol til at udveksle data mellem Microsofts Windows-baserede programmer.

Makroproblemer

Hvis en makro indsætter en funktion i regnearket, der refererer til en celle oven over funktionen, og den celle, der indeholder funktionen, er i række 1, returnerer funktionen #REF! , fordi der ikke er nogen celler over række 1. Kontrollér funktionen for at se, om et argument refererer til en celle eller et celleområde, der ikke er gyldigt. Dette kræver muligvis, at du redigerer makroen i Visual Basic Editor (VBE) for at tage højde for denne situation.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community eller få support i Answers-forummet

Se også

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Har du brug for mere hjælp?

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Deltag i Microsoft insiders

Var disse oplysninger nyttige?

Hvor tilfreds er du med kvaliteten af oversættelsen?
Hvad påvirkede din oplevelse?

Tak for din feedback!

×