Sådan retter du et #SPILL! fejl

Der returneres #OVERLØB!-fejl i Excel, når en formel returnerer flere resultater, som derfor ikke kan returneres i gitteret. Få mere at vide om disse fejltyper i de følgende hjælpeemner:

Denne fejl opstår, når overløbsområdet for en overløbsmatrixformel ikke er tomt.

Fejl med #OVERLØB! – Overløbsområde er ikke tomt

Når formlen er markeret, angiver en stiplet kant det tilsigtede overløbsområde.

Du kan markere fejl floatie og vælge indstillingen Markér blokerende celler for straks at gå til den eller de blokerende celler. Du kan derefter fjerne fejlen ved enten at slette eller flytte den blokerende celles post. Når blokeringen er ryddet, overløber matrixformlen som tilsigtet.

Excel kan ikke fastslå størrelsen på overløbsmatrixen, da den er flygtig og ændrer størrelse mellem beregningsgennemløbene. Den følgende formel udløser f.eks. denne #OVERLØB!-fejl:

=SEKVENS(SLUMPMELLEM(1,1000))

Størrelsesberegninger på dynamiske matrixer kan udløse ekstra beregningsløb for at sikre, at regnearket beregnes fuldt ud. Hvis matrixens størrelse fortsat ændres under disse yderligere gennemløb og ikke Excel, løses den dynamiske matrix som #SPILL!.

Denne fejlværdi er normalt knyttet til brug af funktionerne SLUMP, SLUMPMATRIX og SLUMPMELLEM. Andre flygtige funktioner, som f.eks FORSKYDNING, INDIREKTE og IDAG, returnerer ikke forskellige værdier for hvert beregningsgennemløb. 

Når formlen f.eks. placeres i celle E2 som i eksemplet nedenfor, vil formlen =LOPSLAG(A:A,A:C,2,FALSK) tidligere kun slå id'et op i celle A2. Men i en dynamisk Excel, medfører formlen et #SPILL! denne fejl Excel vil slå hele kolonnen op, returnere 1.048.576 resultater og trykke på slutningen Excel gitteret.

Fejl med #OVERLØB! forårsaget af =LOPSLAG(A:A,A:D,2,FALSK) i celle E2, fordi resultaterne ville overløbe ud over regnearkets kant. Flyt formlen til celle E1, og den vil fungere korrekt.

Der er tre enkle måder at løse dette problem på:

#

Fremgangsmåde

Formel

1

Du skal kun referere til de opslagsværdier, du er interesseret i. Denne type formel returnerer en dynamisk matrix, menvirker ikke sammen med Excel tabeller. 

Brug =LOPSLAG(A2:A7,A:C,2,FALSK) til at returnere en dynamisk matrix, der ikke resulterer i en #SPILL! som fejl.

=LOPSLAG(A2:A7,A:C,2,FALSK)

2

Kun reference til værdien på den samme række, og kopiér derefter formlen ned. Denne traditionelle formeltypografi fungerer i tabeller,men returnerer ikke en dynamisk matrix.

Brug det traditionelle LOPSLAG med en lookup_value reference: =LOPSLAG(A2,A:C,32,FALSK). Denne formel returnerer ikke en dynamisk matrix, men kan bruges sammen med Excel tabeller.

=LOPSLAG(A2,A:C,2,FALSK)

3

Anmod Excel at udføre et implicit skæringspunkt ved hjælp af operatoren @, og kopiér derefter formlen ned. Denne typografi af formler fungerer i tabeller,men returnerer ikke en dynamisk matrix.

Brug operatoren @ , og kopiér ned: = LOPSLAG(@A:A,A:C,2,FALSK). Denne referencetype fungerer i tabeller, men returnerer ikke en dynamisk matrix.

=LOPSLAG(@A:A,A:C,2,FALSK)

Excel-tabeller understøtter ikke overløbsmatrixformler. Prøv at flytte formlen ud af tabellen eller konvertere tabellen til et område (klik på Tabeldesign > Funktioner >Konverter til område).

Fejl med #OVERLØB! – Tabelformel

Den overløbsmatrixformel, du forsøger at indtaste, har Excel at løbe tør for hukommelse. Prøv at referere til en mindre matrix eller et mindre område.

Overløbsmatrixformler kan ikke løbe over i flettede celler. Ophæv fletningen af de pågældende celler, eller flyt formlen til et andet område, der ikke krydser flettede celler.

Fejl med #OVERLØB! – Overløb i flettet celle

Når formlen er markeret, angiver en stiplet kant det tilsigtede overløbsområde.

Du kan markere fejl floatie og vælge indstillingen Markér blokerende celler for straks at gå til den eller de blokerende celler. Når de flettede celler er ryddet, overløber matrixformlen som tilsigtet.

Excel kan ikke genkende eller fastslå årsagen til fejlen. Sørg for, at formlen indeholder alle de påkrævede argumenter til scenariet.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Se også

Funktionen FILTRER

Funktionen SLUMPMATRIX

Funktionen SEKVENS

Funktionen SORTER

Funktionen SORTER.EFTER

Funktionen ENTYDIGE

Dynamiske matrixer og funktionsmåde for overløbsmatrix

Operator for implicit skæringspunkt: @

Har du brug for mere hjælp?

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

×