Sådan retter du fejlen #VÆRDI! fejl i indeks/MATCH-funktioner

I dette emne beskrives de almindelige scenarier, hvor du støder på fejlen #VÆRDI!, når du bruger funktionerne INDEKS og SAMMENLIGN sammen i en formel. En af de mest almindelige årsager til at bruge kombinationen af INDEKS og SAMMENLIGN er, når du vil slå en værdi op i et scenarie, hvor LOPSLAG ikke fungerer for dig – f.eks. hvis din opslagsværdi er længere end 255 tegn.

Problem: Formlen er ikke angivet som en matrix

Hvis du bruger INDEKS som matrixformel sammen med SAMMENLIGN for at kunne hente en værdi, skal du konvertere din formel til en matrixformel. Ellers vises en #VÆRDI!-fejl.

LøsningINDEKS og MATCH skal bruges som en matrixformel, hvilket betyder, at du skal trykke på CTRL + SKIFT + ENTER. Dette vil automatisk ombryde formlen i klammeparenteser {}. Hvis du forsøger at angive dem selv, vil Excel vise formlen som tekst.

Hvis du bruger INDEKS/SAMMENLIGN, når du har en opslagsværdi, der er større end 255 tegn, skal den angives som en matrixformel.  Formlen i celle F3 er =INDEKS(B2:B4,SAMMENLIGN(SAND,A2:A4=F2,0),0), og angives ved at trykke på Ctrl+Skift+Enter

Bemærk!: Hvis du har en aktuel version af Microsoft 365, kan du blot indtaste formlen i output cellen og derefter trykke på Enter for at bekræfte formlen som en dynamisk matrixformel. Ellers skal formlen angives som en ældre matrixformel ved først at markere output cellen, indtaste formlen i output cellen og derefter trykke på CTRL + SKIFT + ENTER for at bekræfte den. Excel indsætter klammeparenteser for dig i begyndelsen og slutningen af formlen. Se Retningslinjer for og eksempler på matrixformler for at få mere at vide om matrixformler.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers-community'et eller foreslå en ny funktion eller forbedring i Excel User Voice.

Se også

Rette fejlen #VÆRDI! fejl

Funktionen INDEKS

Funktionen SAMMENLIGN

Slå værdier op ved hjælp af LOPSLAG, indeks eller Sammenlign

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Bemærk!:  Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Var disse oplysninger nyttige? Her er artiklen på engelsk, så du kan sammenligne.

Har du brug for mere hjælp?

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×