Log på med Microsoft
Log på, eller opret en konto.
Hej
Markér en anden konto.
Du har flere konti
Vælg den konto, du vil logge på med.

Symptom

Et script, der kan udføres korrekt i deltaget tilstand, kører ikke uden opsyn.

Det mislykkes normalt med en meddelelse som f.eks.: "Der opstod et problem med at køre handlingen "Klik på". Der kunne ikke klikkes på linket på websiden."

Årsag

Typiske fejl i automatiserede runs er forårsaget af en af følgende:

  • Script er ikke testet i tilstanden, før der skiftes til uden opsyn

  • Anden konfiguration, der bruges af den uovervågede session

    • En anden Windows, der bruges af automatiseret kørsel, end den, der blev brugt til at oprette flowet

    • Skærmopløsning (se, hvordan du ændrer skærmopløsningen)

    • Browserkonfiguration

      • Bruger

      • Blokering af pop op-vindue

      • Udvidelser (mangler/ ikke aktiveret)

  • Skærmbilleder indlæses ikke helt (manglende forsinkelser)

  • En UAC-prompt, der blokerer brugergrænseflade automatisering, når sessionen starter

Løsning

Da der kan være forskellige årsager, beskriver løsningen nedenfor, hvordan du tilføjer skærmbilleder før og efter en mislykket handling for at få visuel feedback. Ved omhyggeligt at kigge på skærmbillederne efter en automatiseret scriptfejl kunne det hjælpe med at finde en af årsagen, der er angivet ovenfor. 

Hvis du allerede har skærmbilleder i dit flow, og de ikke kan udføres, har du muligvis en UAC-dialogboks (User Account Control), der blokerer udførelse af dit flow. Log på den computer, som genskaber problemet med den konto, du bruger, for at udføre flowet, og se, om du har sådan en blokeringsdialogboks. Hvis du gør det, skal du ændre din startrutine for at forhindre, at dette sker.

Tilføje skærmbilleder til fejlfinding

Start med at logge på den computer, der genskaber problemet med den konto, du bruger i din forbindelse. Kontrollér, at der ikke er nogen UAC-prompt, der blokerer automatisering af brugergrænsefladen.

Hvis der ikke er noget, der blokerer brugergrænseflade automatisering, kan du tage et skærmbillede før og efter et mislykket trin i automatiseret tilstand for at få visuel feedback.

Det mislykkede trin bør fortsætte ved en fejl, så et skærmbillede kan tages efter fejlen.

1. Se efter handlingen "Tag skærmbillede"

Handling for at tage skærmbillede

 2- Træk og slip handlingen "Tag skærmbillede" på scriptsiden

Træk og slip handlingen tag skærmbillede

3- Rediger handlingen, brug"Filer " i stedet for Udklipsholder og"før " i placeringen af filnavnet Udfyld handlingsegenskaberne for Tag skærmbilledet

4 – Kopiér/indsæt derefter, og skift filnavnet på skærmbilledet med filnavnet bagefter Dupliker og udfyld handlingsegenskaberne for Tag skærmbillede

5– Omslut det mislykkede trin med skærmbillederne

Omgiv mislykket fremgangsmåde med skærmbilleder

6– Skift funktionsmåden ved VedFejl for det mislykkede trin

6a- Rediger trinnet, og klik på "onError" nederst

Skift den fejl, der blev vist ved fejl

6b- Indstil flow-kørslen til "Fortsæt flow-kørsel" og "Gå til næste handling"

Fortsæt flow-kørsel, og gå til næste handling

7– Gem, kør lokalt for at teste, at skærmbilleder produceres, og genstart en automatiseret kørsel.

8– Kontrollér de uovervågede skærmbilledesfiler. 

Bemærk!

Som nævnt ovenfor har du muligvis en dialogboks med Kontrol af brugerkonti (UAC), der blokerer udførelse af dit flow, hvis selve skærmbillederne mislykkes. Log på den computer, som genskaber problemet med den konto, du bruger, for at udføre flowet, og se, om du har sådan en blokeringsdialogboks. Hvis du gør det, skal du ændre din startrutine for at forhindre, at dette sker.

Hvis scriptet har andre trin, kan det mislykkes efter, at funktionsmåden blev ændret, så der ikke opstår fejl, så vi kan tage et skærmbillede. Så fejl efter det andet skærmbillede skal ignoreres. 

Når problemet er forstået og rettet, kan du gendanne dit flows oprindelige funktionsmåde for at give fejl.

Har du brug for mere hjælp?

Vil du have flere indstillinger?

Udforsk abonnementsfordele, gennemse kurser, få mere at vide om, hvordan du sikrer din enhed og meget mere.

Communities hjælper dig med at stille og besvare spørgsmål, give feedback og høre fra eksperter med omfattende viden.

Var disse oplysninger nyttige?

Hvor tilfreds er du med kvaliteten af sproget?
Hvad påvirkede din oplevelse?

Tak for din feedback!

×