Fehler beim Verwalten von Startimages in Configuration Manager

In diesem Artikel wird ein Problem behoben, bei dem Sie Startimages in Configuration Manager nicht verwalten können, wenn der WIMMount-Dienst beschädigt, falsch konfiguriert oder fehlt.

Ursprüngliche Produktversion: Configuration Manager (Current Branch), Microsoft System Center 2012 R2 Configuration Manager, Microsoft System Center 2012 Configuration Manager
Ursprüngliche KB-Nummer: 4096324

Symptome

In einer Umgebung, in der das Windows Assessment and Deployment Kit (ADK) installiert und auf dem Server, auf dem der SMS-Anbieter gehostet wird, auf dem neuesten Stand ist, können Sie Startimages nicht mithilfe von Configuration Manager verwalten. Dies umfasst die folgenden Aktionen:

  • Aktualisieren sie Startimages auf Verteilungspunkten.
  • Importieren Sie neue Startimages.
  • Erstellen Sie mithilfe des MDT-Assistenten (Microsoft Deployment Toolkit) neue Startimages.
  • Ändern Sie Startimages, z. B. um Treiber hinzuzufügen.

In diesem Szenario wird der folgende Fehler in der SMSProv.log-Datei auf dem SMS-Anbieterserver protokolliert:

SMS-Anbieter ExecMethodAsync: SMS_BootImagePackage.PackageID="<Boot_Image_Package_ID>"::RefreshPkgSource~
SMS Provider Requested-Klasse =SMS_BootImagePackage~
SMS Provider Requested num keys =1~
SMS-Anbieter IExtClassManager::ValidateAuthenticationLevel...
SMS-Anbieter CExtProviderClassObject::D oExecuteMethod RefreshPkgSource~
SMS-Anbieter wurde wimgapi.dll Version 10.0.16299.15 vom Speicherort "C:\Programme (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64\DISM\wimgapi.dll" geladen.
Der WIM-Index des SMS-Anbieters ist 1.
SMS Provider Image Language ID 1033 and en-US~
SMS-Anbieter hat das Image aus \\<Boot_Image_Path>\boot.wim geladen.
SMS-Anbieter Der temporäre Pfad für die WIM-Datei lautet C:\Windows\TEMP\BootImages\{<Random_GUID>}\temp.
DER SMS-Anbieter hat den Bildindex geladen 1.
FEHLER des SMS-Anbieters> beim Einbinden der WIM-Datei, err=-1052638943~
SMS-Anbieter ~*~*~.. \sspbootimagepackage.cpp(5198): Fehler beim Einfügen von OSD-Binärdateien in die eingebundene WIM-Datei (häufig geschieht, wenn nicht signierte Treiber in ein x64-Startimage eingefügt werden)~*~~*~
SMS-Anbieter ~*~~Fehler beim Einfügen von OSD-Binärdateien in die eingebundene WIM-Datei (häufig geschieht, wenn nicht signierte Treiber in das x64-Startimage eingefügt werden) ~*~*~

Wenn Sie DISM.exe manuell auf dem SMS-Anbieterserver ausführen, wird der folgende Fehler in der DISM.log-Datei protokolliert:

DISM DISM.EXE: Befehle für den Anbieter erfolgreich registriert: Kompatibilitäts-Manager.
[10780] [0x8007007b] OpenFilterPort:(408): Der Dateiname, der Verzeichnisname oder die Volumebezeichnungssyntax ist falsch.
[10780] [0x8007007b] FltCommVerifyFilterPresent:(502): Der Dateiname, der Verzeichnisname oder die Volumebezeichnungssyntax ist falsch.
[10780] [0x8007007b] WIMMountImageHandle:(1089): Der Dateiname, der Verzeichnisname oder die Volumebezeichnungssyntax ist falsch.
[10780] [0x80070002] StateStoreRemoveMountedImage:(1030): Das System kann die angegebene Datei nicht finden.
[10780] [0x80070002] WIMMountImageHandle:(1331): Das System kann die angegebene Datei nicht finden.

DISM DISM WIM-Anbieter: PID=10780 TID=1096 "Fehler beim Einbinden des Images." – CWimImageInfo::Mount(hr:0x8007007b)
DISM DISM WIM-Anbieter: PID=10780 TID=1096 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:2684 - CWimManager::InternalOpMount(hr:0x8007007b)
DISM DISM WIM-Anbieter: PID=10780 TID=1096 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:4028 - CWimManager::InternalCmdMount(hr:0x8007007b)
DISM DISM WIM-Anbieter: PID=10780 TID=1096 "Fehler beim Ausführen des Befehls" – CWimManager::InternalExecuteCmd(hr:0x8007007b)
DISM DISM WIM-Anbieter: PID=10780 TID=1096 onecore\base\ntsetup\opktools\dism\providers\wimprovider\dll\wimmanager.cpp:2201 - CWimManager::ExecuteCmdLine(hr:0x8007007b)

Hinweis

Die Verwendung des Prozessmonitors beim manuellen Ausführen von DISM kann nicht identifizieren, welche Datei oder welches Verzeichnis nicht gefunden werden kann.

Ursache

Dieses Problem tritt auf, wenn der WIMMount-Dienst auf dem SMS-Anbieterserver beschädigt, falsch konfiguriert oder fehlt.

Überprüfen Sie zur Überprüfung den folgenden Registrierungseintrag auf dem Server, auf dem der SMS-Anbieter gehostet wird:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WIMMount\ImagePath

Der Wert dieses Eintrags sollte der Speicherort der Wimmount.sys-Datei sein, die sich im Installationsverzeichnis von Windows ADK befindet.

Hinweis

Der Server, auf dem der SMS-Anbieter gehostet wird, ist möglicherweise nicht der Standort der zentralen Verwaltung oder der primäre Standortserver. Wenn mehrere Server den SMS-Anbieter hosten, stellen Sie sicher, dass Sie diesen Registrierungseintrag auf allen SMS-Anbieterservern überprüfen.

Führen Sie die folgenden Schritte aus, um die Server zu finden, auf denen der SMS-Anbieter an einem Standort gehostet wird:

  1. Wechseln Sie in der Configuration Manager-Konsole zu Verwaltung>Übersicht>Standortkonfigurationsstandorte>.
  2. Klicken Sie mit der rechten Maustaste auf den Standort, und wählen Sie dann Eigenschaften aus.
  3. Suchen Sie auf der Registerkarte Allgemein nach den Servern, die unter SMS-Anbieterstandort aufgeführt sind.

Lösung

Führen Sie die folgenden Schritte aus, um den WIMMount-Dienst neu zu installieren, um das Problem zu beheben:

  1. Navigieren Sie auf dem Server, auf dem der SMS-Anbieter gehostet wird, zu dem Speicherort, an dem Windows ADK installiert ist. Der Standardpfad von Windows ADK 10 ist C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64beispielsweise .

  2. Wechseln Sie zum Ordner DISM, und führen Sie dann den folgenden Befehl aus:

    WimMountAdkSetupAmd64.exe /Install