Fehlermeldung beim Drucken eines Berichts in Microsoft Dynamics SL: "Crystal drucken Engine Fehler: 723... Fehler beim Öffnen eines Rowsets"


 

Problembeschreibung


Beim Drucken eines Berichts in Microsoft Dynamics SL oder in Microsoft Business Solutions - Solomon, erhalten Sie eine Fehlermeldung ähnlich der folgenden:
Crystal Reports-Hilfsprogramm für Solomon IV

Druckauftrag kann nicht gestartet werden.

Bericht: Laufwerk: \Program Files\Solomon\Module_Code\XXXXX. RPT
Crystal Print Engine 723 - Fehler in der Datei Laufwerk: \Program Files\Solomon\Module_Code\XXXXX. BERICHTSKOPF:

Fehler beim Öffnen eines Rowsets.
Hinweis In dieser Fehlermeldung Laufwerk steht für das Laufwerk, auf dem Microsoft Dynamics SL installiert, Module_Code den Modulcode darstellt, der das Modul Microsoft Dynamics SL entspricht in dem Bericht befindet und XXXXX steht für den Dateinamen des Berichts.

Ursache


Dieses Problem tritt für eine oder mehrere der folgenden Gründe.

Ursache 1

Der Bericht enthält Hinweise. Siehe Auflösung 1 im Abschnitt "Lösung".

Ursache 2

Microsoft Solomon 6.0 installiert, und des Berichts, der den Fehler verursacht die Verteilung (01.ACC. DI) Bericht. Siehe Auflösung 2 im Abschnitt "Lösung".

Ursache 3

Der Bericht ist ein benutzerdefinierter Bericht, der einem vorverarbeiten verwendet. Lösung 3 im Abschnitt "Lösung" anzeigen

Ursache 4

Open DataBase Connectivity (ODBC)-Datenquellennamen (DSNs) sind fehlen oder beschädigt. Siehe Auflösung 4 im Abschnitt "Lösung".

Ursache 5

Die Verwendung von ANSI-Bezeichner in Anführungszeichen nicht aktiviert ist. Siehe Auflösung 5 im Abschnitt "Lösung".

Ursache 6

Der Computer mit Microsoft SQL Server und hostet Microsoft Dynamics SL-Datenbanken oder Microsoft Business Solutions - Solomon Datenbanken ist nicht genügend freier Speicherplatz verfügbar. Siehe Auflösung 6 im Abschnitt "Lösung".

Problemlösung


Um dieses Problem zu beheben, verwenden Sie die Lösung.

Lösung 1

Wenn Sie die Fehlermeldung beim Drucken eines Berichts, das Notizen enthält, deaktivieren Sie das Kontrollkästchen Eindeutige Datensätze wählen Sie im Menü Datenbank in Crystal Reports für Solomon. Weitere Informationen zum Deaktivieren dieser Option klicken Sie auf die folgenden Artikelnummer der Microsoft Knowledge Base:

896330 Fehlermeldung eine Crystal drucken Modul Wenn Sie versuchen, eine Microsoft Crystal Reports für Solomon 6.0 Rechnung/Gutschrift Formulare Bericht drucken mit Notizen

Lösung 2

Wenn die Fehlermeldung nur beim Drucken die Verteilung (01.ACC. DI) melden und Microsoft Solomon 6.0 installiert haben, ersetzen Sie die Datei 01acctdi.rpt, die in Ihrer Installation mithilfe der 01acctdi.rpt-Datei von der Installations-CD von Microsoft Solomon 5.5. Weitere Informationen zu diesen Austausch, klicken Sie auf die folgenden Artikelnummer der Microsoft Knowledge Base:

898694 der Verteilung Bericht ist für ein Unternehmen, das nicht master in Microsoft Solomon ist leer

Lösung 3

Wenn Sie die Fehlermeldung angezeigt, wenn Sie versuchen, einen benutzerdefinierten Bericht drucken, eine vorverarbeiten, verwenden Sie eine der folgenden Methoden.

Methode 1

Hinzufügen des benutzerdefinierten Berichts separat in der Menüstruktur Microsoft Dynamics SL. Weitere Informationen die Menüstruktur Elemente hinzuzufügen, klicken Sie auf die folgenden Artikelnummer der Microsoft Knowledge Base:

887345 wie Microsoft Solomon Menü in Version 6.0 ein Fremdanbieter-Programm hinzufügen

Methode 2

Fügen Sie den benutzerdefinierten Bericht als ein neues Berichtformat zu einem vorhandenen Bericht, der keinem vorverarbeiten verwendet an. Gehen Sie folgendermaßen vor, um benutzerdefinierten Bericht hinzuzufügen:
  1. Starten Sie Microsoft Dynamics SL.
  2. Klicken Sie auf das Menü Dienstprogramm auf Bericht Steuerelement Wartung.

    Hinweis Öffnet das Dialogfeld Bericht Steuerelement Wartung (98.300.00) .
  3. Im Feld Nummer die Nummer des Berichts benutzerdefinierten Bericht angefügt werden soll.
  4. Klicken Sie auf Optionen.
  5. Überprüfen Sie das vorab verarbeiten leer. Das Pre-Prozess nicht leer ist, gehen Sie zurück um zu Schritt c und geben Sie dann einen anderen Bericht.
  6. Die erste leere Zeile geben Sie den Anzeigenamen des Berichts im Feld Berichtname Format , und geben Sie den Namen der Berichtdatei im Berichtsformat .

    In diesem Schritt bezieht sich auf die Crystal Reports-Bericht in Microsoft Windows "Bericht". Beispielsweise geben Sie 01accdi im Feld wird der Name der Berichtsdatei 01accdi.rpt.
  7. Klicken Sie auf Speichern. Klicken Sie auf Schließen.

Lösung 4

Entfernen Sie und Neuerstellen Sie der Microsoft Dynamics SL oder Microsoft Solomon Datenbank ODBC-DSNs. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start, klicken Sie auf Systemsteuerungklicken Sie auf Verwaltungund klicken Sie dann auf Datenquellen (ODBC).
  2. Wählen Sie auf der Registerkarte Benutzer-DSN Dynamics SL Datenbank aus und dann auf Entfernen. Wiederholen Sie für alle Dynamics SL-Datenbanken, die in der Liste angezeigt.
  3. Wählen Sie auf der Registerkarte System-DSN ein Systemdatenquellen auf Dynamics SL-Datenbank aus und dann auf Entfernen.
  4. Klicken Sie auf OK.
  5. Um die ODBC-DSNs neu zu erstellen, starten Sie Microsoft Dynamics SL und führen Sie dann eine Seitenansicht eines Berichts.

Lösung 5

Aktivieren Sie ANSI-Anführungszeichen. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start, klicken Sie auf Systemsteuerungklicken Sie auf Verwaltungund klicken Sie dann auf Datenquellen (ODBC).
  2. Wählen Sie auf der Registerkarte Benutzer-DSN die entsprechende Datenbank, und klicken Sie auf Konfigurieren.
  3. Klicken Sie auf Weiter.
  4. Geben Sie die entsprechenden Anmeldeinformationen, und klicken Sie auf Weiter.
  5. Aktivieren Sie das Kontrollkästchen mit ANSI-Anführungszeichen .
  6. Klicken Sie auf Weiter.
  7. Klicken Sie auf Fertig stellen.
  8. Klicken Sie zweimal auf OK.

Auflösung 6

Speicherplatz auf dem Computer. Dazu löschen Sie nicht benötigte Daten oder erhöhen Sie die Speicherkapazität.