Fehlermeldung beim Überprüfen des Anwendungsprotokolls auf dem Computer, auf dem die Microsoft Dynamics AX 4,0-AOS-Dienste ausgeführt werden: "RPC-Ausnahme 1726 ist in Sitzung 10 aufgetreten"

Gilt für: Microsoft Dynamics AX 4.0Axapta Object Server

Problembeschreibung


Wenn Sie das Anwendungsprotokoll auf einem Computer überprüfen, auf dem Microsoft Dynamics AX 4,0 Application Object Server (AOS)-Dienste ausgeführt wird, werden möglicherweise Fehlermeldungen angezeigt, die wie folgt aussehen:
Fehlermeldung 1
Ereignistyp: InformationEvent Quellcode: Dynamics Server 17Date: 7/4/2007 Zeit: 12:30:14 PMEvent Category: NoneDescription: Object Server 01: RPC-Fehler: RPC-Ausnahme 1726 in Sitzung 10
Fehlermeldung 2
Ereignistyp: InformationEvent Quellcode: Dynamics Server 01Event Category: NoneEvent ID: 110Date: 7/4/2007:12:30:33 amüsant: N/AComputer:ComputernameBeschreibung: Objekt Server 01: kein Ping von 10. Beenden der Sitzung
Die erste Fehlermeldung kann der zweiten Fehlermeldung zugeordnet sein. Bis der AOS-Server die Sitzung 10 beendet, reagiert jede Sitzung, die RPC-Fehlermeldungen zurückgibt, nicht mehr. Wenn zu viele Sitzungen nicht mehr reagieren und RPC-Fehlermeldungen zurückgegeben werden, kann der AOS-Server heruntergefahren werden.

Ursache


Dieses Problem kann auftreten, weil Benutzer Microsoft Dynamics AX unanmutig verlassen. Beispielsweise beenden Benutzer den Microsoft Dynamics AX-Prozess mithilfe des Task-Managers. RPC 1726 ist eine allgemeine Fehlermeldung für eine Verbindung. Allerdings kann die RPC 1726-Fehlermeldung dem "kein Ping von 10" zugeordnet sein. Beenden der Sitzung "Fehlermeldung. In diesem Fall wird das Problem in der Regel dadurch verursacht, dass Benutzer Microsoft Dynamics AX unanmutig verlassen.

Fehlerbehebung


Wenn dieses Problem auf dem Microsoft Dynamics AX-Client auftritt, beenden Sie den Client nicht, indem Sie STRG + ALT + ENTF drücken. Wir empfehlen, dass Sie Strg + Pause verwenden und dann warten, bis das System wieder reagiert, oder wenden Sie sich an den Microsoft Dynamics AX-Administrator oder einen anderen Benutzer, der über Rechte für das Online Benutzerformular verfügt. Der Administrator oder der andere Benutzer kann auf Sitzung beenden klicken, um die Clientsitzung zu beenden.

Weitere Informationen


Wenn dieses Problem auf dem AOS-Server auftritt, ist es wichtig, festzustellen, welche Sitzung die Ursache hat und was die Benutzer tun, um das Problem zu verursachen. Führen Sie dazu das folgende Skript aus:
select * from sysuserlog where logouttime = 0 and sessionid = <X> 
Hinweis Ersetzen Sie <X-> durch die Sitzung, die in der RPC-Fehlermeldung angezeigt wird. Notieren Sie sich aus den Ergebnissen der Abfrage die Spalten UserID und Computername . Die Spaltenwerte geben an, wer sich anmeldet und von wo aus. In der Regel werden RPC-Ausnahmen dadurch verursacht, dass die Anwendung unanmutig beendet wird. Die Ausnahmen können jedoch auch darauf hindeuten, dass ein Geschäftsprozess hängen bleibt oder lange Zeit in Anspruch nimmt.

Informationsquellen


Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
953375 So suchen Sie nach einer Benutzer-ID, die einer Sitzungs-ID zugeordnet ist "RPC-Fehler: RPC-Ausnahme 1726 in Sitzung [SessionID]" Fehlermeldung im Anwendungsprotokoll auf dem AOS-Server in Microsoft Dynamics AX
953374 Sie erhalten eine Warnmeldung im Anwendungsprotokoll auf dem AOS-Server in Microsoft Dynamics AX: "SPID [SPID_number] für Sitzungs-ID [SessionID], ist weiterhin in der Datenbank vorhanden. Bitte löschen Sie die SPID aus der Datenbank "