Verbinden von Excel mit SQL Server 2005 Analysis Services


Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
940167 How to connect Excel to SQL Server 2005 Analysis Services

Einführung


Dieser Artikel beschreibt, wie Sie Microsoft Office Excel mit Microsoft SQL Server 2005 Analysis Services verbinden.

Weitere Informationen


Hinweis: Bevor Sie Excel mit SQL Server 2005 Analysis Services verbinden, sollten Sie sicherstellen, dass Microsoft OLE DB-Provider für SQL Server 2005 Analysis Services auf dem Computer installiert ist. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start und auf Ausführen, geben Sie notepad ein, und klicken Sie auf OK.
  2. Klicken Sie im Editor im Menü Datei auf Speichern.
  3. Klicken Sie im Dialogfeld Speichern unter in der Liste Dateityp auf Alle Dateien, geben Sie text.udl in das Dialogfeld Dateiname ein, und klicken Sie dann auf Speichern.
  4. Doppelklicken Sie auf die Datei "text.udl".
  5. Klicken Sie im Dialogfeld Datenverknüpfungseigenschaften auf die Registerkarte Provider, und überprüfen Sie dann, ob Microsoft OLE DB Provider für Analysis Services 9.0 in der Liste der OLE DB-Provider aufgeführt ist.

    Falls Microsoft OLE DB Provider für Analysis Services 9.0 nicht aufgeführt ist, müssen Sie Microsoft OLE DB-Provider für SQL Server 2005 Analysis Services installieren. Besuchen Sie die folgende Microsoft-Website, um Microsoft OLE DB-Provider für SQL Server 2005 Analysis Services zu erhalten:

Verbinden von Excel 2007 mit SQL Server 2005 Analysis Services

Methode 1

  1. Klicken Sie in Microsoft Office Excel 2007 erst auf die Registerkarte Daten, dann in der Gruppe Externe Daten abrufen auf Aus anderen Quellen und anschließend auf Von Analysis Services.
  2. In das Feld Servername geben Sie den Namen des OLAP-Servers ein.
  3. Unter Anmeldeinformationen führen Sie eine der folgenden Aktionen durch:
    • Klicken Sie auf Windows-Zugriffsrechte verwenden, um Ihren aktuellen Microsoft Windows-Benutzernamen zu verwenden.
    • Klicken Sie auf Benutzername und Kennwort verwenden, und geben Sie dann Ihren Benutzernamen und Ihr Kennwort in die Felder Benutzername und Kennwort ein, um Datenbankbenutzer und -kennwort anzugeben.
  4. Klicken Sie auf Weiter.
  5. Unter Wählen Sie die Datenbank, die die benötigten Daten enthält klicken Sie auf eine Datenbank.
  6. Führen Sie die restlichen Schritte im Assistenten durch, um eine Verbindung mit einem SQL Server 2005 Analysis Services-Cube zu erstellen und Daten als Tabelle oder PivotTable-Bericht in Excel zu importieren.

Methode 2

  1. Klicken Sie in Excel 2007 auf die Registerkarte Daten und dann in der Gruppe Verbindungen auf Verbindungen.
  2. Klicken Sie im Dialogfeld Arbeitsmappenverbindungen auf Hinzufügen.
  3. Im Dialogfeld Vorhandene Verbindungen klicken Sie auf Nach weiteren Elementen suchen.
  4. Klicken Sie im Dialogfeld Datenquelle auswählen auf Neue Quelle.
  5. Klicken Sie im Datenverbindungs-Assistenten auf Microsoft SQL Server OLAP Services und dann auf Weiter.
  6. In das Feld Servername geben Sie den Namen des OLAP-Servers ein.
  7. Unter Anmeldeinformationen führen Sie eine der folgenden Aktionen durch:
    • Klicken Sie auf Windows-Zugriffsrechte verwenden, um Ihren aktuellen Windows-Benutzernamen zu verwenden.
    • Klicken Sie auf Benutzername und Kennwort verwenden, und geben Sie dann Ihren Benutzernamen und Ihr Kennwort in die Felder Benutzername und Kennwort ein, um Datenbankbenutzer und -kennwort anzugeben.
  8. Klicken Sie auf Weiter.
  9. Unter Wählen Sie die Datenbank, die die benötigten Daten enthält klicken Sie auf eine Datenbank.
  10. Führen Sie die restlichen Schritte im Assistenten durch, um eine Verbindung mit einem SQL Server 2005 Analysis Services-Cube zu erstellen.
  11. Klicken Sie in Microsoft Office Excel 2007 auf der Registerkarte Daten in der Gruppe Externe Daten abrufen auf Vorhandene Verbindungen und anschließend auf Öffnen, um die Daten als Tabelle oder PivotTable-Bericht in Excel zu importieren.

Verbinden von Excel 2003 oder einer früheren Version mit SQL Server 2005 Analysis Services

Methode 1

  1. In Microsoft Office Excel 2003 oder einer früheren Version von Excel zeigen Sie im Menü Daten auf Externe Daten, und klicken dann auf Daten importieren.
  2. Klicken Sie im Dialogfeld Datenquelle auswählen auf Neue Quelle.
  3. Klicken Sie im Datenverbindungs-Assistenten auf Microsoft SQL Server OLAP Services und dann auf Weiter.
  4. In das Feld Servername geben Sie den Namen des OLAP-Servers ein.
  5. Unter Anmeldeinformationen führen Sie eine der folgenden Aktionen durch:
    • Klicken Sie auf Windows-Zugriffsrechte verwenden, um Ihren aktuellen Windows-Benutzernamen zu verwenden.
    • Klicken Sie auf Folgenden Benutzernamen und folgendes Kennwort verwenden, und geben Sie dann Ihren Benutzernamen und Ihr Kennwort in die Felder Benutzername und Kennwort ein, um Datenbankbenutzer und -kennwort anzugeben.
  6. Klicken Sie auf Weiter.
  7. Unter Wählen Sie die Datenbank, die die benötigten Daten enthält klicken Sie auf eine Datenbank.
  8. Führen Sie die restlichen Schritte im Assistenten durch, um eine Verbindung mit einem SQL Server 2005 Analysis Services-Cube zu erstellen und Daten als Tabelle oder PivotTable-Bericht in Excel zu importieren.

Methode 2

  1. Klicken Sie in Excel 2003 und in früheren Excel-Versionen im Menü Daten auf PivotTable- und PivotChart-Bericht.
  2. Klicken Sie unter Welche Daten möchten Sie analysieren? auf Externe Datenquelle und dann auf Weiter.
  3. Klicken Sie auf Daten abrufen.
  4. Doppelklicken Sie auf der Registerkarte OLAP-Cubes auf Neue Datenquelle.
  5. Geben Sie im Dialogfeld Neue Datenquelle erstellen einen Namen für die Datenquelle an, klicken in der Liste Wählen Sie einen OLAP-Anbieter xxx für die gewünschte Datenbank auf Microsoft OLE DB Provider for Analysis Services 9.0, klicken Sie auf Verbinden und dann auf OK.
  6. Klicken Sie auf die neu erstellte OLAP-Cube-Verbindung und anschließend auf OK.
  7. Führen Sie die restlichen Schritte im Assistenten durch, um Daten als PivotTable-Bericht in Excel zu importieren.
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.