Windows-Startfehler 0xc0000034 auf einem virtuellen Azure-Computer

Dieser Artikel bietet eine Lösung für ein Problem, bei dem der virtuelle Windows-Computer nicht mit einem Fehlercode 0xc0000034 beginnt.

Ursprüngliche Produktversion: Virtueller Computer, auf dem Windows ausgeführt wird
Ursprüngliche KB-Nummer: 4010140

Symptome

Windows wird nicht gestartet. Stattdessen generiert das System einen Fehler, der dem folgenden ähnelt:

Datei: \Boot\BCD
Fehlercode: 0xc0000034
Info: Sie müssen die Wiederherstellungstools auf Ihren Installationsmedien verwenden. Wenn Sie über keine Installationsmedien verfügen, wenden Sie sich an Ihren Systemadministrator oder PC-Hersteller.

Ursache

Es liegt eine BCD-Beschädigung vor, die es der Startpartition nicht erlaubt, den Ordner \Windows zu finden.

Lösung

Tipp

Wenn Sie über eine aktuelle Sicherung der VM verfügen, können Sie versuchen, die VM aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.

Führen Sie die folgenden Schritte aus, um das Problem zu beheben.

Schritt 1: Anfügen des Betriebssystemdatenträgers des virtuellen Computers als Datenträger an einen anderen virtuellen Computer

  1. Löschen Sie den virtuellen Computer (VM). Stellen Sie sicher, dass Sie die Option Datenträger beibehalten auswählen, wenn Sie dies tun.

  2. Fügen Sie den Betriebssystemdatenträger einer anderen VM (VM, auf der Sie die Problembehandlung ausführen) als Datenträger an. Weitere Informationen finden Sie unter Anfügen eines Datenträgers an eine Windows VM im Azure-Portal.

  3. Stellen Sie eine Verbindung mit der Problembehebungs-VM her. Öffnen Sie Computerverwaltung>Datenträgerverwaltung. Stellen Sie sicher, dass der Betriebssystemdatenträger online ist und dass den Partitionen Laufwerksbuchstaben zugewiesen sind.

  4. Ermitteln Sie die Startpartition und die Windows-Partition. Wenn nur eine Partition auf dem Betriebssystemdatenträger vorhanden ist, ist diese Partition die Startpartition und die Windows-Partition.

    Wenn der Betriebssystemdatenträger mehr als eine Partition enthält, können Sie diese ermitteln, indem Sie sich die Ordner in den Partitionen ansehen:

    • Die Windows-Partition enthält einen Ordner namens "Windows", und diese Partition ist größer als die anderen.
    • Die Startpartition enthält einen Ordner namens "Boot". Dieser Ordner ist standardmäßig ausgeblendet. Um den Ordner anzuzeigen, müssen Sie die ausgeblendeten Dateien und Ordner anzeigen und die Option Geschützte Betriebssystemdateien ausblenden (empfohlen) deaktivieren. Die Startpartition beträgt in der Regel 300 MB ~ 500 MB.

Schritt 2: Reparieren der Startkonfigurationsdaten

  1. Führen Sie die folgende Befehlszeile als Administrator aus, und notieren Sie sich dann den Bezeichner des Windows-Startladeprogramms (nicht den Windows-Start-Manager). Der Bezeichner ist ein 32-stelligen Code und sieht wie folgt aus: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx. Sie verwenden diesen Bezeichner im nächsten Schritt.

    bcdedit /store <Boot partition>:\boot\bcd /enum /v
    
  2. Reparieren Sie die Startkonfigurationsdaten, indem Sie die folgenden Befehlszeilen ausführen. Sie müssen diese Platzhalter durch die tatsächlichen Werte ersetzen:

    • <Die Windows-Partition> ist die Partition, die einen Ordner mit dem Namen "Windows" enthält.
    • <Die Startpartition> ist die Partition, die einen ausgeblendeten Systemordner mit dem Namen "Boot" enthält.
    • <Identifier> ist der Bezeichner des Windows-Startladeprogramms, den Sie im vorherigen Schritt gefunden haben. Beispiel: {9f25ee7a-e7b7-11db-94b5-f7e662935912}
    bcdedit /store <Boot partition>:\boot\bcd /create {bootmgr}
    
    bcdedit /store <Boot partition>:\boot\bcd /set {bootmgr} description "Windows Boot Manager"
    
    bcdedit /store <Boot partition>:\boot\bcd /set {bootmgr} locale en-us
    
    bcdedit /store <Boot partition>:\boot\bcd /set {bootmgr} inherit {globalsettings}
    
    bcdedit /store <Boot partition>:\boot\bcd /set {bootmgr} displayorder <Identifier>
    
    bcdedit /store <Boot partition>:\boot\bcd /set {bootmgr} timeout 30
    
  3. Trennen Sie den Betriebssystemdatenträger von der VM, auf der Sie die Problembehandlung ausführen. Erstellen Sie eine neue VM auf Grundlage des Betriebssystemdatenträgers.

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