Programme, die die Funktion QueryPerformanceCounter möglicherweise schlecht in Windows 2000 Server, Windows Server 2003 und Windows XP ausführen.

Problembeschreibung


In der folgenden Bootmanager benutzen:
WindowsServer 2000
Windows XP
Windows Server 2003
Windows 2000 Server-Gast-Betriebssystem
Windows XP-Gast-Betriebssystem
Windows Server 2003-Gast-Betriebssystem

Ein Programm, das die Funktion QueryPerformanceCounter Systemzeit Abfrage verwendet möglicherweise schlecht ausführen.


Beispiel:

Wenn Sie den Pingbefehl (ICMP = Internet Control Message Protocol) Pakete an einen Remotecomputer senden verwenden, kann die Antwort negativ reagieren anzeigen Der folgenden Pingbefehl kann beispielsweise die folgenden Antworten generieren:

C:\ > ping x.x.x.x

Ping x.x.x.x mit 32 Bytes Daten:

Antwort von x.x.x.x: Bytes = 32 Zeit = 59ms TTL = 128
Antwort von x.x.x.x: Bytes = 32 Zeit = 59ms TTL = 128
Antwort von x.x.x.x: Bytes = 32 Zeit = 59ms TTL = 128
Antwort von x.x.x.x: Bytes = 32 Zeit = 59ms TTL = 128


Außerdem verwenden Sie Leistungsindikatoren für logische Datenträger oder Festplatte möglicherweise falsch zeigen Sie Wartezeitwert an.


Hinweis: Dieses Problem tritt auf einem Computer mit einer X86-basierten Version von Windows oder eine X64-basierte Version von Windows.


Ursache

Dieses Problem hat AMD Cool'n'Quiet-Technologie (AMD dual-Kerne) im BIOS oder einige Intel Multi-Core-Prozessoren. Multi-Core- oder Multiprozessorsystemen Time Stamp Zähler (TSC) Drift tritt möglicherweise zwischen verschiedenen Kerne nicht synchronisiert ist. Betriebssysteme die TSC Zeitbestimmung Ressource verwenden kann das Problem auftreten.

Problemlösung

Beheben dieses Problem überprüfen Sie den Hersteller der Hardware, um festzustellen, ob ein neuer Treiber/Firmware steht Update das Problem zu beheben.

Hinweis Die Installation des Treibers können Sie/usepmtimer -Schalter in der Datei Boot.ini hinzufügen. Diese Option wird im Abschnitt "Abhilfe" beschrieben.

PROBLEMUMGEHUNG

Um dieses Problem zu umgehen, aktualisieren Sie das BIOS auf dem Computer. Oder ändern die Datei Boot.ini, damit Sie/usepmtimer -Schalter verwenden. Gehen Sie hierzu folgendermaßen vor:
  1. Melden Sie sich am Computer mit einem Konto mit Administratorrechten an.
  2. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie Notepad c:\boot.iniund klicken Sie dann auf OK.
  3. Eine Zeile mit "Default beginnt" befindet sich in der Datei Boot.ini im Abschnitt "[Bootloader]". Diese Zeile gibt den Speicherort des Standard-Betriebssystems. Die Zeile kann wie folgt aussehen:
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    Suchen Sie im Abschnitt "[Operating Systems]" Zeile für das Betriebssystem, das die Zeile "Default" entspricht. Z. B. wenn der Computer Microsoft Windows Server 2003 Enterprise X64 Edition sollte die Zeile folgendermaßen aussehen:
    mehrfach (0) Festplatte (0) Rdisk (0) Partition (2) \WINDOWS="Windows Server 2003 Enterprise X64 Edition" / fastdetect/noexecute = OptIn
  4. Leerzeichen Sie am Ende der Zeile, und geben Sie/usepmtimer. Die Zeile sollte nun folgendermaßen aussehen.
    mehrfach (0) Festplatte (0) Rdisk (0) Partition (2) \WINDOWS="Windows Server 2003 Enterprise X64 Edition" / fastdetect/noexecute = OptIn Sie/usepmtimer
  5. Speichern Sie die Datei, und beenden Sie Notepad.
  6. Starten Sie den Computer neu.
Folgendes ist eine Boot.ini-Beispieldatei für ein System, das Sie/usepmtimer Switch enthält.
[Bootloader]
timeout=0
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[Operating Systems]
mehrfach (0) Festplatte (0) Rdisk (0) Partition (2) \WINDOWS="Windows Server 2003 Enterprise X64 Edition" / fastdetect/noexecute = OptIn Sie/usepmtimer
Hinweis Die Datei "Boot.ini" befindet sich im Stammverzeichnis des Systemlaufwerks.

Hinweis: Verwenden Sie/usepmtimer Einstellung kann Leistungseinbußen führen.

Weitere Informationen

Weitere Informationen über Hardware-Unterstützung für ACPI und zu nutzen klicken Sie auf die folgenden Artikelnummer der Microsoft Knowledge Base:

309283 HAL-Optionen nach Windows XP oder Windows Server 2003

Support für X64-basierten Versionen von Microsoft Windows

Wenn Ihre Hardware mit einem Microsoft Windows X64 Edition bereits installiert war, bietet der Hardwarehersteller technischen Support und Unterstützung für Windows X64 Edition. In diesem Fall bietet Hardwarehersteller Unterstützung, da Windows X64 Edition mit Ihrer Hardware geliefert wurde. Hardwarehersteller kann die Windows X64 Edition verändert durch einzelne Komponenten. Komponenten könnten bestimmte Gerätetreiber oder gehören Einstellungsoptionen um die Leistung der Hardware zu maximieren. Wenn Sie technische Hilfe zu einer Windows X64 Edition benötigen, bietet Microsoft Unterstützung in angemessenem. Sie müssen jedoch Ihre direkt beim Hersteller. Der Hersteller ihm am besten Software zu unterstützen, die der Hersteller der Hardware installiert. Wenn Sie eine Windows X64 Edition wie eine Edition von Microsoft Windows Server 2003 X64 separat erworben haben, erhalten Sie von Microsoft technischen Support.

Produktinformationen zu Microsoft Windows XP Professional X64 Edition finden Sie auf der folgenden Microsoft-Website:Produktinformationen zu X64-basierten Versionen von Microsoft Windows Server 2003 finden Sie auf der folgenden Microsoft-Website:Die in diesem Artikel erörterten Produkte von Drittanbietern werden von Unternehmen hergestellt, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in die Leistung oder Zuverlässigkeit dieser Produkte.

Eigenschaften

Artikelnummer: 895980 – Letzte Überarbeitung: 16.01.2017 – Revision: 1

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