Fehlermeldungen beim Drucken oder Vorschau ein benutzerdefiniertes Berichts im Microsoft Dynamics SL: "Crystal drucken Fehler 536" oder "System Messaage 7014"


Problembeschreibung


Wenn Sie einen benutzerdefinierten Bericht drucken oder Vorschau für einen benutzerdefinierten Bericht vor dem Drucken in Microsoft Dynamics SL, erhalten Sie die folgenden Fehlermeldungen:
: Crystal Print Engine 536-Fehler in Datei. Keine Verbindung: falsche Parameter anmelden.
Meldung 7014: Ausführung fehlgeschlagen 536.
.

Ursache


Ursache 1

Vertrauenswürdige Verbindungsparameter in die Berichtsdatei wird auf 1 festgelegt. Lösung 1 anzeigen

Ursache 2

Die Open Database Connectivity (ODBC) Verbindung auf der Arbeitsstation ist beschädigt. Lösung 2 anzeigen

Ursache 3

Der Bericht verweist auf zwei verschiedene Datenbanken. Lösung 3 anzeigen

Ursache 4

E7F575915A2E4897A517779C0DD7CE-Anmeldekonto in SQL Server 2005 oder SQL Server 2008 ist deaktiviert oder wurde ein falsches Kennwort. Lösung 4 anzeigen

Problemlösung


Lösung 1

Zum Beheben dieses Problems festlegen Sie den Trusted Connection -Parameter in der Berichtsdatei auf 0 (null). Gehen Sie hierzu folgendermaßen vor:

  1. Starten Sie Crystal Reports 10 für Solomon.
  2. Klicken Sie auf Öffnen, wählen Sie den benutzerdefinierten Bericht und klicken Sie auf Öffnen.
  3. Klicken Sie im Menü Datenbank auf Datasource Speicherort festlegen.
  4. Erweitern Sie im Dialogfeld Datenquelle Speicherort definieren aktuelle Datenquelle: Eigenschaften.
  5. Unter aktuelle Datenquelle: Eigenschaften, suchen Sie die Vertrauenswürdige Verbindung: 1 Parameter.
    Hinweis Wenn Vertrauenswürdige Verbindung Parameter nicht aufgeführt ist, wurde Vertrauenswürdige Verbindung -Option nicht ausgewählt, wenn der Bericht erstellt wurde, und dies nicht die Ursache des Fehlers ist.
  6. Mit der rechten Maustaste Vertrauenswürdige Verbindung: 1, und klicken Sie dann auf Bearbeiten.
  7. Geben Sie 0ein.
  8. Klicken Sie auf Schließen.
  9. Klicken Sie auf Speichern.

Lösung 2

Um dieses Problem zu beheben, löschen Sie Microsoft Dynamics SL ODBC-Verbindung. Lassen Sie Microsoft Dynamics SL die Verbindung neu erstellen. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start, klicken Sie auf Systemsteuerungklicken Sie auf Verwaltungund klicken Sie dann auf Datenquellen (ODBC).
  2. Entfernen Sie auf der Registerkarte Benutzer-DSN Elemente, die auf Ihre Microsoft Dynamics SL Anwendungsdatenbanken.
  3. Auf der Registerkarte System-DSN auf Ihre Microsoft Dynamics SL Anwendungsdatenbanken Elemente entfernen
  4. Führen Sie den Bericht in Microsoft Dynamics SL erneut aus. Die ODBC-Verbindungen werden beim Ausführen eines Berichts in Microsoft Dynamics SL automatisch neu erstellt.

Lösung 3

Um dieses Problem zu beheben, Zurücksetzen des Datenquelle in Crystal Reports. Gehen Sie hierzu folgendermaßen vor:
  1. Starten Sie Crystal Reports 10 für Solomon.
  2. Klicken Sie auf Öffnen, wählen Sie den benutzerdefinierten Bericht und klicken Sie auf Öffnen.
  3. Klicken Sie im Menü Datenbank auf Datasource Speicherort festlegen.
  4. In das Feld Ersetzen durch erweitern Sie Neu erstellenund dann ODBC (RDO).
  5. Klicken Sie auf die Microsoft Dynamics SL-Datenbank und klicken Sie dann auf Weiter.
  6. Geben Sie Ihre Anmeldeinformationen ein. Aktivieren Sie das Kontrollkästchen Vertraute Verbindung nicht.
  7. Klicken Sie auf Fertig stellen.
  8. Klicken Sie auf die Datenbank in das Feld Ersetzen durch . Klicken Sie im Aktuellen Datenquelle die Datenbank an.
  9. Klicken Sie auf Aktualisieren.
  10. Wenn Sie Datenbanken im Aktuellen Datenquelle haben, wiederholen Sie die Schritte 8 und 9 für jede Datenbank.
  11. Klicken Sie auf Speichern, und beenden Sie Crystal Reports.

Lösung 4

Um dieses Problem zu beheben, aktivieren Sie E7F575915A2E4897A517779C0DD7CE-Anmeldekonto in SQL Server 2005 oder SQL Server 2008 zu, und führen Sie Aktualisierungsszenario synchronisieren alle Eigentum und Sicherheit im Bildschirm Wartung (98.290.00) Microsoft Dynamics SL. Gehen Sie hierzu folgendermaßen vor:
  1. Starten Sie SQL Server Management Studio und Verbinden mit dem Server hostet Microsoft Dynamics SL-Datenbanken.
  2. Klicken Sie im Objekt-Explorer erweitern Sie Sicherheitund dann Benutzernamen.
  3. Unter BenutzernamenMaustaste auf E7F575915A2E4897A517779C0DD7CE, und klicken Sie auf Eigenschaften.
  4. Klicken Sie im Bereich eine Seite auf Statusund klicken Sie unter der Option Anmeldungauf aktiviert .
  5. Klicken Sie auf OK, und schließen Sie SQL Server Management Studio.
  6. Bedienfeldklicken Sie auf Verwaltungund dann auf Microsoft Dynamics SL-Datenbankwartung.
  7. Verbindung zur Instanz von SQL Server, die Microsoft Dynamics SL-Datenbanken hostet.
  8. Klicken Sie auf Datenbank aktualisieren .
  9. In der Liste Aktualisieren auf synchronisieren alle Besitzer und Sicherheit, und klicken Sie auf Datenbank aktualisieren.
  10. Am unteren Bildschirmrand Datenbankwartung (98.290.00) bestätigen Sie, dass die Statusleiste hat und klicken Sie dann auf Schließen.