Häufige Fehler und Problembehandlungsschritte Netzwerkkonnektivitätsprobleme an Microsoft Dynamics Retail System Speicher oder im Microsoft Dynamics Management System Auszugsposition


Problembeschreibung


Sie erhalten an Microsoft Dynamics Retail System Speicher oder Microsoft Dynamics Management System Auszugsposition folgenden Fehlermeldungen:
Fehlermeldung 1
Verbindung verloren, werden geschlossen Fehler #-2147467259 [DBNETLIB] [ConnectionWrite (WrapperWrite()).] Allgemeiner Netzwerkfehler. Überprüfen Sie die Dokumentation. (Quelle: Microsoft OLE DB Provider für SQL Server) (SQL-Status: 08S01) (Systemeigener Fehler: 11) Keine Hilfe verfügbar wählen als GETDATE() CurrentDateTime

Hinweis Die aktuelle Microsoft SQL Server Wählen -Anweisung am Ende der Fehlermeldung möglicherweise länger und komplexer. Diese Anweisung steht der Tabelle OrderEntry-Tabelle und der Tabelle "Debitor". Sie müssen die letzte Anweisung einschließen, wenn untersuchen und beheben Sie dieses Problem, da die Anweisung Lokalisieren des Problems helfen kann. Die Anweisung gibt die Tabellen, die die Anwendung zugegriffen hat, bei der die Unterbrechung aufgetreten ist.
Fehlermeldung 2
SQL Server existiert nicht oder Zugriff verweigert.
Fehlermeldung 3
ConnectionOpen CreateFile (Connect())
Fehlermeldung 4
Fehler: die Tabelle '#temp' kann nicht gelöscht werden, da sie nicht im Systemkatalog vorhanden ist.
Fehlermeldung 5
Laufzeitfehler '5': Ungültiger Prozeduraufruf oder Argument
Fehlermeldung 6
"Allgemein Fehler, Laufzeitfehler 5

Ursache


Betrieb und zentrale erfordern zuverlässige Verbindung zwischen dem Server und den Client-Computern. Die im Abschnitt "Symptome" aufgeführten Fehler beziehen sich Setup Netzwerkprobleme oder Hardwareprobleme Setup. Fehler Betrieb oder zentrale beziehen sich nicht.

Probleme bei der Netzwerkkonnektivität können verschiedene Ursachen haben. Diese Probleme haben jedoch in der Regel eine oder mehrere der folgenden Ursachen:
  • Netzwerkadapter, die falsch konfiguriert sind
  • Optionen falsch festgelegt
  • Fehlerhafte hardware
  • Probleme mit Gerätetreibern
Manche Verbindungsprobleme treten nur sporadisch auf und weisen nicht eindeutig auf bestimmte Ursache.

Die folgende Liste zeigt häufige Ursachen für Probleme bei der Netzwerkkonnektivität:
  1. Beschädigt oder unzuverlässige Kabelverbindung eines fehlerhaften Netzwerkadapters oder fehlgeschlagenen hub
  2. Ein falscher Treiber bzw. falsche
  3. Die Installation von einer früheren Version von MDAC auf jeder Arbeitsstation als auf dem server
  4. Energiesparfunktionen der Netzwerkadapter deaktivieren, wenn Microsoft Dynamics RMS ausgeführt wird
  5. Ein IP-Adressenkonflikt
  6. Einstellung in der SQL Server-Clientkonfiguration falsch konfiguriert sind
  7. Die falsch konfigurierten Einstellungen in der SQL Server-Netzwerkkonfiguration
  8. Ein Mangel an verfügbaren Netzwerkbandbreite da Systemressourcen verfügbare Netzwerkbandbreite verwenden
  9. Falsche Einstellung für einen bestimmten Zahlungsmitteltyp für Peripheriegeräte oder zu registrieren
  10. Drahtlose Netzwerkkonfiguration
  11. Konflikt mit Einstellungen für Add-Ins von Drittanbietern oder Anpassung

Problemlösung


Verwenden Sie zum Beheben dieses Problems die Auflösung, die den entsprechenden Netzwerkkonnektivitätsproblem entspricht, die im Abschnitt "Ursache" aufgeführt ist.

Lösung 1

  1. Tritt das Problem nur auf einem bestimmten Computer, könnte das Problem die Hardware auf diesem Computer. Untersuchen Sie das Kabel, um sicherzustellen, dass das Netzwerkkabel angeschlossen ist. Tauschen sie den Netzwerkadapter zu ersetzen, mit denselben Adapter.
  2. Tritt dieses Problem auf mehreren Computern, untersuchen Sie die Netzwerkkomponenten, die die Computer verbinden. Stellen Sie sicher, dass der Router eingeschaltet ist. Exchange-Netzwerkkabel oder neue alte Kabel ersetzen.
  3. Alle Arbeitsstationen sicher, dass Datei- und Druckerfreigabe aktiviert. Gehen Sie folgendermaßen vor, um die Einstellung zu überprüfen:
    1. Klicken Sie auf Start, und klicken Sie dann auf Systemsteuerung.
    2. Doppelklicken Sie auf Netzwerkanschlüsse.
    3. Maustaste auf Local Area Network (LAN), und klicken Sie dann auf Eigenschaften.
    4. Aktivieren Sie das Kontrollkästchen Datei- und Druckerfreigabe für Microsoft-Netzwerke .

Lösung 2

Viele Adapter verwendet Treiber, die automatisch Einstellungen zu erkennen. Dazu gehören Medientyp Media Connectorund duplex. Gelegentlich werden automatische falsch erkannt. In diesem Fall müssen Sie manuell ändern. Der duplex erfordert in der Regel manueller ändern. Wenn die Treiber-Standardeinstellungen nicht funktionieren, versuchen Sie, jeden Parameter eine manuell ändern. Zeigen Sie die Ergebnisse nach jeder Änderung.

Lösung 3

Stellen Sie sicher, dass die neueste Version von MDAC auf jeder Workstation installiert ist. Sie bestimmen die Version von MDAC, die anhand der Registrierung ausgeführt werden. Die Versionsinformationen befindet sich im folgenden Registrierungsunterschlüssel:
HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccess\FullInstallVer
Gehen Sie folgendermaßen vor, um die Registrierung zu überprüfen:

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie regedit einund klicken Sie dann auf OK.
  2. Suchen Sie im Navigationsbereich den folgenden Unterschlüssel:
    HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccess
  3. Suchen Sie im Ergebnisbereich Wert FullInstallVer und Version -Wert in der Spalte Name. Diese Schlüssel haben entsprechende Informationen in der Spalte .

    Hinweis MDAC-Komponente möglicherweise beschädigt oder fehlt. Sie können das Problem durch die Neuinstallation von MDAC sein. Suchen und downloaden die neueste Version von MDAC finden Sie auf der folgenden Microsoft-Website:
    http://support.microsoft.com/select/?target=hub

Lösung 4

Energiesparfunktionen in Microsoft Windows kann der Netzwerkadapter deaktiviert beim Betrieb oder zentrale ausgeführt wird. Die Programme zugreifen regelmäßig dem Datenbankserver-Computer aktualisieren Programm Lizenz und Zeitstempel. Programme erfordern daher eine Netzwerkverbindung.

Um dieses Problem zu beheben, müssen Sie alle Energiesparfunktionen, die im BIOS und im Betriebssystem deaktivieren. Überprüfen Sie die Einstellungen des Computers und des Netzwerkadapters. Stellen Sie sicher, dass der Computer nicht so deaktivieren Sie den Netzwerkadapter Energiesparmodus festgelegt ist. Um die Energieoptionen für den Netzwerkadapter zuzugreifen, gehen Sie folgendermaßen vor:
  1. Klicken Sie auf Startund dann auf Bedienfeld.
  2. Doppelklicken Sie auf Verwaltung, und doppelklicken Sie auf Computer Management.
  3. Klicken Sie auf Geräte-Manager, erweitern Sie den Ordner Netzwerkadapter Maustaste Adapter-Komponente und klicken Sie dann auf Eigenschaften.
  4. Klicken Sie auf Power Management .
  5. Deaktivieren Sie das Kontrollkästchen Computer Gerät ausschalten, um Energie zu sparen kann .

Lösung 5

Wenn Sie TCP/IP und eine feste IP-Adresse verwenden, stellen Sie sicher, dass keine zwei Computer im Netzwerk die IP-Adresse. Verwenden Sie den Befehl Ping oder Ipconfig/all um sicherzustellen, dass Sie die IP-Adresse nicht auf mehreren Computern verwenden. Ermitteln die IP-Adresse der Computer im Netzwerk und stellen Sie sicher, dass Sie zwischen Server und Clientcomputer anpingen können, gehen Sie folgendermaßen vor:
  1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie cmd ein, und klicken Sie auf OK.
  2. Typ Ipconfig/all, und klicken Sie dann auf OK.
  3. Pingen Sie den Server von dem Computer Konnektivitätsfehler mithilfe der IP-Adresse und den Computernamen. Pingen Sie den Computer Konnektivitätsfehler auf dem Server mit der IP-Adresse und den Computernamen. In der Befehlszeile beispielsweise Ping < Servername >.

    Hinweise
    • In diesem Befehl repräsentiert < Servername > der tatsächliche Name des Computers, die Sie Ping.
    • T-Pingbefehl können Sie über das Netzwerk einen Konstanten Ping abgeschlossen. Sie können diese Ganztägig Befehl Ping-Pakete protokollieren, die von der Workstation an den Server übertragen. Gehen Sie folgendermaßen vor, um alle Timeouts zu suchen:
      1. Maustaste im Eingabeaufforderungsfenster und klicken Sie dann auf Suchen.
      2. Geben Sie in das Feld Suchen nach Die übliche.
      Die Liste der Timeouts gibt an, wie viele Verbindung setzt die Ping-Sitzung aufgetreten. In der Befehlszeile beispielsweise Ping – T < Servername >.
      HinweisIn diesem Befehl < Servername > repräsentiert den tatsächlichen Namen des Computers, die Sie Ping.

Auflösung 6

Überprüfen der Clientkonfiguration. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start, zeigen Sie auf Programme, zeigen Sie auf Microsoft Dynamics RMSund klicken Sie auf Clientkonfiguration.
  2. Überprüfen Sie die Registerkarte Allgemein . Fahren Sie TCP/IP als deaktivierte Protokoll aufgeführt ist, auf Bereich aktiviertes Protokoll TCP/IP. Stellen Sie außerdem sicher, dass TCP/IP zuerst aufgeführt ist.
  3. Wir empfehlen die Registerkarte Alias Alias hinzufügen. Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie auf die Registerkarte Alias und dann auf Hinzufügen.
    2. Suchen Sie den Server, der eine Instanz von Microsoft SQL Server ausgeführt wird, die TCP/IP-Sockets-Clients überwacht. Geben Sie einen eindeutigen Namen für diesen Server. Stellen Sie sicher, dass das Kontrollkästchen TCP/IP .
    3. Geben Sie im Feld Server die Instanz von SQL Server, die TCP/IP-Sockets-Clients überwacht.

      Hinweis Dieser Name dieser Instanz ist normalerweise der Name des Servers. Allerdings hängt der Namen SQL Setup, die auf dem Server. Der Name einer Instanz von SQL Server den Namen des Servers identisch ist, sollten Sie die IP-Adresse des Servers anstelle des Namens verwenden.
    4. Suchen Sie auf der Registerkarte Netzwerkbibliotheken eine Zeile TCP/IP die Netzwerkbibliothek Spalte mit dem Namen, und suchen Sie die Datei Dbnetlib.dll.

      Hinweis Die Datei Dbnetlib.dll ist zugeordneten Bibliotheksdatei. Fehlt die Datei Dbnetlib.dll, kopieren Sie die Datei von einem anderen Computer, oder downloaden Sie die Datei, indem Sie auf der folgenden Website:

      https://mbs.microsoft.com/downloads/customer/dbnetlib.zip
    5. Kopieren der Datei Dbnetlib.dll kommen in den folgenden Ordner auf der Festplatte des Clientcomputers:

      C:\Windows\System32


    Hinweis Entpacken Sie diese Datei vor dem Kopieren in den Ordner System32.

Auflösung 7

Überprüfen Sie die Einstellungen in der SQL Server-Netzwerkkonfiguration auf dem Server. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start, auf Ausführen, und geben Sie dann
    Svrnetcn.
  2. Überprüfen Sie die Registerkarte Allgemein . Fahren Sie TCP/IP als deaktivierte Protokoll aufgeführt ist, auf Bereich aktiviertes Protokoll TCP/IP.

Auflösung 8

Verfolgen Sie die Tageszeit, wenn Fehler auftreten. Fehler können nacheinander konsistent im Laufe des Tages oder der Woche aus verschiedenen Gründen auftreten. Der Datenbankserver kann beispielsweise anderen Aufgaben ausgelastet sein. Oder die Netzwerkbandbreite kann ausgelastet. Bestimmen Sie, ob andere geplante Tasks, Backups, Updates und Tools zum Aufräumen während dieser Zeit auf dem System ausgeführt werden. Überwachen der Serverressourcenverwendung und Netzwerk-Ressourcenverbrauch bestimmt, ob das Problem auf ein hoher Bedarf an Systemressourcen zurückzuführen ist.

Auflösung 9

Überwachen der Prozesse abgeschlossen werden in Betrieb oder zentrale tritt dieses Problem. Häufig werden die Trennung Fehler während der Ausschreibung in Store Operations POS. Das Problem kann ein bestimmtes Angebot Peripheriegeräte oder ein Peripheriegerät, das nur ein Zahlungsmitteltyp erfolgt umfassen.

Bestimmen Sie, welche Peripheriegeräte während der Fehler erfolgt. Deaktivieren Sie alle Geräte. Aktivieren Sie jedes Gerät einzeln dann, bis der Fehler erneut angezeigt werden. Diese Art der Problembehandlung Spitzenzeiten Speicher möglicherweise schwierig auszuführen oder möglicherweise. Jedoch möglicherweise diese Art der Problembehandlung die einzige Möglichkeit, die Ursache des Problems zu finden.

Beachten Sie außerdem Folgendes:
  • Sind alle Peripheriegeräte denselben oder unterschiedlichen in den Speicher?
  • Wird nur ein Register Erfahrung Trennung Fehler oder angezeigt Fehler auf konsistent in allen Registern?
  • Folgt das Problem der Peripherie oder auf das Register bleiben?
Treten Fehler auf nur ein Register, tauschen Sie die Peripheriegeräte, die auf das Register Geräte, die an einem anderen Register sind und, die keinen Fehler.

Die Stromquelle ein bekanntermaßen ähnliche Fehler verursachen. Daher sollten Sie, ob das Gerät über eine externe Stromquelle ausgeführt wird oder ob das Gerät Strom vom Computer erhält. Abhängig vom Computer und ob das Gerät den Computer als Stromquelle verwendet, einige Geräte können die verfügbare Leistung des Computers. Diese abzuleiten verlangsamt Leistung.

Auflösung 10

Prüfen Sie, ob Betrieb oder Sitz in einem drahtlosen Netzwerk eingerichtet ist.

Hinweis Wir unterstützen keine drahtlose Netzwerk mit Betrieb oder zentrale.

Einige drahtlose Netzwerke möglicherweise nicht so stabil wie verkabelte Netzwerke. Da Speichervorgänge und zentrale eine ständige Verbindung mit der Datenbank erforderlich sind, muss die Verbindung stabil sein. Wir empfehlen, ein verkabeltes Netzwerk für ein drahtloses Netzwerk ersetzen.

Auflösung 11

Add-Ins von Drittanbietern oder Anpassungen vor der Buchung Prozess erfolgt während des Postenbuchungsprozesses zugegriffen, oder nach der Buchung Prozess beschädigen oder Schwächen Netzwerkkonnektivität im Betrieb oder im Hauptsitz zugegriffen. Berücksichtigen Sie die folgenden Szenarios möglich Software:
  • Drittanbieterprodukte sind installiert, die Hooks in Betrieb oder zentrale verwenden. Fehler können auftreten, wenn die Hooks neue Fenster Sale angezeigt oder die Hooks SQL-Skripts und Trigger Transaktionsdaten in anderen Datenbanken oder Tabellen ziehen abgeschlossen. Wenn Sie dies tun können, entfernen Sie oder deaktivieren Sie diese Produkte um festzustellen, ob der Fehler nicht mehr. Alternativ installieren Sie Betrieb oder Sitz auf einem neuen Computer. Beinhalten Sie keine Add-Ins oder angepasst.
  • Eine HTML-Statusleiste wird ausgeführt. Fehler können auftreten, wenn eine HTML-Statusleiste ausgeführt wird. Um festzustellen, ob Sie eine HTML-Statusleiste Anzeigeeigenschaften Sale durch Drücken von STRG + F6 anzeigen. Klicken Sie auf der Registerkarte Buchung Bildschirm , um festzustellen, ob das Kontrollkästchen HTML-Anzeige . Haben Sie eine HTML-Statusleiste Fragen Sie folgende:
    • Wurde die HTML-Statusleiste angepasst? Wenn die HTML-Statusleiste angepasst wurde, deaktivieren Sie das Kontrollkästchen. Dann überwachen Sie das System mehrere Tage um festzustellen, ob Fehler beendet wurden.
    • Ist HTML-Status Bar-Datei auf der Festplatte von jedem Client-Computer im Netzwerk oder die Datei auf einem Server? Überprüfen Sie den Speicherort der HTML-Statusleiste überprüfen Sie Store Operations Administrator Configuration Tool im oberen Teil des POS-Bildschirms auf Registrieren . Wenn die HTML-Status Bar-Datei auf einem Server befindet, verschieben Sie die Datei auf der Festplatte jedes Client-Computers.
Hinweis Es empfiehlt sich, die Ursachen und Lösungsansätze, die in diesem Artikel aufgeführt sind. Netzwerk Verbindungsabbrüche können Datenverluste oder unvollständige Updates der Betrieb oder die zentrale Datenbank führen. Je nach die Trennung auftreten werden nicht alle Tabellen der Probleme. Das folgende Szenario. Eine Reihe von Tabellen wird bei der Buchung aktualisiert. Diese Serie beginnt mit der Tabelle und der Tabelle TransactionEntry. Die Serie endet die Stapelverarbeitungstabelle und die Erfassungstabelle. Eine Trennung vom Netzwerk tritt während des Post-Vorgangs. Nachdem dieses Problem auftritt, wird die Transaktion im detaillierte Umsatzbericht, da dieser Bericht die Informationen aus der Tabelle und der Tabelle TransactionEntry zieht. Allerdings erscheinen die Transaktion nicht in den Z-Bericht da Z-Bericht die Informationen aus der Stapelverarbeitungstabelle und der Erfassungstabelle zieht.

Weitere Informationen


Weitere Informationen zur Evaluierung Bereiche, die Leistung beeinflussen, klicken Sie auf die folgenden Artikelnummer der Microsoft Knowledge Base:

180775 -INF: Client-Effekte auf SQL Server-Durchsatz



Weitere Informationen zum Beheben von Netzwerkverbindungsproblemen finden im folgenden Artikel der Microsoft Knowledge Base:

325487 Behandlung von Netzwerkverbindungsproblemen