Wenn Sie versuchen, einen IPP-Drucker über HTTPS hinzuzufügen, erhalten Sie eine Fehlermeldung.

Dieser Artikel bietet eine Lösung für einen Fehler, der auftritt, wenn Sie versuchen, einen IPP-Drucker über HTTPS hinzuzufügen.

Gilt für: Windows 7 Service Pack 1
Ursprüngliche KB-Nummer: 2021626

Symptome

Wenn Sie versuchen, einer Windows Vista- oder Windows 7-Arbeitsstation einen IPP-Drucker über HTTPS hinzuzufügen, kann die Installation der Warteschlange mit folgendem Fehler fehlschlagen:

Drucker hinzufügen
Herstellen einer Verbindung mit dem Drucker
Windows konnte keine Verbindung mit dem Drucker herstellen. Überprüfen Sie den Druckernamen, und versuchen Sie es erneut. Wenn es sich um einen Netzwerkdrucker handelt, stellen Sie sicher, dass der Drucker eingeschaltet und die Adresse des Druckers korrekt ist.

Ursache

Dieses Problem tritt auf, weil Windows das ssl-Zertifikat, das vom Druckserver verwendet wird, nicht als vertrauenswürdig eingestuft oder nicht überprüft werden kann, oder weil der Druckserver ein selbstsigniertes Zertifikat verwendet.

Lösung

Dies kann wie folgt gelöst werden:

  • Konfigurieren des Druckservers für die Verwendung eines gültigen SSL-Zertifikats von einer externen Zertifizierungsstelle, die von der Arbeitsstation als vertrauenswürdig eingestuft wird.
  • Wenn sich sowohl der Druckserver als auch die Arbeitsstation in derselben Domäne befinden, konfigurieren Sie den Druckserver für die Verwendung eines gültigen SSL-Zertifikats einer Unternehmenszertifizierungsstelle.
  • Wenn der Druckserver ein selbstsigniertes Zertifikat verwendet, installieren Sie das selbstsignierte Zertifikat auf der Arbeitsstation.

Installieren des Self-Signed-Zertifikats eines IPP-Druckservers auf einem Windows-Client

Wenn Ihr Druckserver selbstsignierte Zertifikate verwendet, können die folgenden Schritte verwendet werden, um das selbstsignierte Zertifikat auf den Clients zu installieren, damit sie den Drucker verwenden können.

Hinweis

Dies sollte nur für SSL-Zertifikate von Servern erfolgen, die Sie als vertrauenswürdig verwenden.

  1. Melden Sie sich beim Client als Administrator an.
  2. Suchen Sie internet Explorer im Startmenü, klicken Sie mit der rechten Maustaste darauf, und klicken Sie auf Als Administrator ausführen.
  3. Navigieren Sie in Internet Explorer mithilfe von HTTPS (z. Bhttps://PrintServerName/. ) zum Druckerserver.
  4. In der Adressleiste sollten die Wörter "Zertifikatfehler" auf der rechten Seite neben einem roten Schildsymbol angezeigt werden – klicken Sie auf den Fehler.
  5. Klicken Sie auf Zertifikate anzeigen.
  6. Klicken Sie im Zertifikatfenster auf Zertifikat installieren....
  7. Wählen Sie Alle Zertifikate im folgenden Speicher speichern aus.
  8. Klicken Sie auf Durchsuchen....
  9. Wählen Sie Vertrauenswürdige Stammzertifizierungsstellen aus, und klicken Sie auf OK.
  10. Klicken Sie auf Weiter und dann auf Fertig stellen.
  11. Es wird eine Sicherheitswarnung angezeigt, dass Sie ein Zertifikat aus einer Quelle hinzufügen, die nicht überprüft werden kann. Klicken Sie auf Ja , um diesem SSL-Zertifikat zu vertrauen.
  12. Schließen Sie Internet Explorer.
  13. Der Drucker kann jetzt installiert werden.

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Fragen der Benutzerfreundlichkeit ausführen.