Informationen zur AutoVervollständigen-Liste von Outlook

Gilt für: Outlook 2016Outlook 2013Microsoft Office Outlook 2003

Zusammenfassung


Dieser Artikel enthält eine Übersicht über die AutoVervollständigen-Liste von Microsoft Outlook (auch als Auto-Vervollständigen-Liste von Outlook bezeichnet). Zusätzlich zu einer Beschreibung der Funktion enthält dieser Artikel weitere Informationen und schrittweise Anweisungen für fortgeschrittene Benutzer zur Verwaltung der Liste.

Weitere Informationen


Outlook verwaltet die AutoVervollständigen-Liste. Die Liste wird sowohl von der automatischen Namensprüfungsfunktion als auch von der Funktion zur automatischen Vervollständigung verwendet. Die AutoVervollständigen-Liste, auch als Spitznamen-Zwischenspeicher bezeichnet, wird automatisch generiert, wenn Sie E-Mail-Nachrichten von Outlook senden. Die Liste enthält SMTP-Adressen, LegacyExchangeDN-Einträge und Anzeigenamen für Personen, an die Sie in der Vergangenheit E-Mails gesendet haben.

Hinweis: Die AutoVervollständigen-Liste für Outlook wird nur von Outlook und nicht von Outlook Web App (OWA) verwendet. OWA verwaltet eine eigene AutoVervollständigen-Liste.

In den folgenden Abschnitten finden Sie Informationen zur AutoVervollständigen-Funktion.
 

Begrenzung der Anzahl von Einträgen

Outlook begrenzt die Anzahl der Einträge, die Sie in der AutoVervollständigen-Liste speichern können. Wenn Sie diese Grenze erreicht haben, verwendet Outlook einen internen Algorithmus, um die Namen zu bestimmen, die am besten aus der Liste entfernt werden sollen. Outlook verwendet dazu eine Nutzungsgewichtung. Aus diesem Grund stellen Sie möglicherweise fest, dass bestimmte Namen unerwartet aus Ihrem Spitznamen-Zwischenspeicher entfernt wurden. Es gibt zwei allgemeine Ansätze, mit denen Sie diese Situation vermeiden können:
  1. Sie können nicht mehr benötigte Einträge der AutoVervollständigen-Liste proaktiv löschen. Dies ist der bevorzugte Ansatz. Weitere Informationen zur entsprechenden Vorgehensweise finden Sie im Abschnitt mit dem Titel „Entfernen einzelner Einträge aus der AutoVervollständigen-Liste“.
  2. Sie können die Grenze für den Spitznamen-Zwischenspeicher erhöhen. Da diese Konfiguration nicht getestet wurde, empfehlen wir sie nicht. Wenn Sie einen größeren Spitznamen-Zwischenspeicher haben, könnten Sie auch eine größere Anzahl zwischengespeicherter Einträge verlieren, wenn Ihr Spitznamen-Zwischenspeicher aufgrund von Beschädigung unbrauchbar wird. Weitere Informationen dazu, wie Sie die Grenze erhöhen, finden Sie im Abschnitt mit dem Titel „Ändern der Grenze für die AutoVervollständigen-Liste“.
Die Grenzen lauten wie folgt:
  • Outlook 2016: 1.000 Einträge
  • Outlook 2013: 1.000 Einträge
  • Outlook 2010: 1.000 Einträge
  • Outlook 2007: 2.000 Einträge
  • Outlook 2003: 1.000 Einträge
 

Aktivieren der AutoVervollständigen-Funktion

In diesem Abschnitt wird erläutert, wie Sie die AutoVervollständigen-Funktion aktivieren bzw. deaktivieren.
Outlook 2010, Outlook 2013 und Outlook 2016
Um die AutoVervollständigen-Einstellungen aufzurufen, befolgen Sie diese Schritte: 
  1. Klicken Sie im Menü „Datei" auf „Optionen".
  2. Wählen Sie die Registerkarte E-Mail aus.
  3. Scrollen Sie etwa bis zur Hälfte nach unten, bis Sie Nachrichten senden sehen. Stellen Sie sicher, dass das Kontrollkästchen Beim Ausfüllen der Zeilen "An", "Cc" und "Bcc" Namen mithilfe der AutoVervollständigen-Liste vorschlagen aktiviert ist.

    Fenster „Nachrichten senden“, Kontrollkästchen „Beim Ausfüllen der Zeilen 'An', 'Cc' und 'Bcc' Namen mithilfe der AutoVervollständigen-Liste vorschlagen“ aktiviert
Outlook 2003 und Outlook 2007
Um die AutoVervollständigen-Einstellungen aufzurufen, befolgen Sie die Schritte:
  1. Klicken Sie auf Extras und dann auf Optionen.
  2. Klicken Sie auf die Schaltfläche E-Mail-Optionen.
  3. Klicken Sie auf die Schaltfläche Erweiterte E-Mail-Optionen.
  4. Stellen Sie sicher, dass das Kontrollkästchen „Beim Ausfüllen der Adressfelder ähnliche Namen vorschlagen" aktiviert ist. (Der Screenshot für diesen Schritt folgt.)

    Fenster „Erweiterte E-Mail-Optionen“, Kontrollkästchen „Beim Ausfüllen der Adressfelder ähnliche Namen vorschlagen“ aktiviert
 

Importieren von NK2-Dateien in Outlook 2010, Outlook 2013 und Outlook 2016

Microsoft Office Outlook 2007 und frühere Versionen speichern die AutoVervollständigen-Liste in einer Spitznamendatei (NK2-Datei) auf der Festplatte. Outlook 2010, Outlook 2013 und Outlook 2016 speichern die AutoVervollständigen-Liste als eine verborgene Nachricht in Ihrem primären Nachrichtenspeicher. Outlook 2010, Outlook 2013 und Outlook 2016 erlauben das Importieren der älteren NK2-Dateien.

Weitere Informationen dazu, wie Sie NK2-Dateien in Outlook 2010 importieren, finden Sie auf der folgenden Microsoft-Website:

Kopieren der AutoVervollständigen-Liste

Die Schritte zum Exportieren und Importieren der AutoVervollständigen-Liste sind je nach verwendeter Outlook-Version unterschiedlich.
Outlook 2010, Outlook 2013 und Outlook 2016
Um die AutoVervollständigen-Liste in Outlook 2010, Outlook 2013 und Outlook 2016 zu kopieren, befolgen Sie diese Schritte:

Schritt 1

Um die AutoVervollständigen-Postfachnachricht zu exportieren, befolgen Sie diese Schritte:
  1. Beenden Sie Outlook, und schließen Sie dann Outlook Web Access oder Outlook Web App (OWA) auf allen Arbeitsstationen, die mit Ihrem Postfach verbunden sind.
  2. Laden Sie das Hilfsprogramm MFCMAPI von http://mfcmapi.codeplex.com herunter, und installieren Sie es.
  3. Führen Sie mfcmapi.exe aus.
  4. Klicken Sie im Menü Sitzung auf Anmeldung.
  5. Wenn Sie nach einem Profil gefragt werden, wählen Sie den gewünschten Profilnamen aus, und klicken Sie dann auf OK.
  6. Suchen Sie im oberen Fenster die Zeile, die Ihrem Postfach entspricht, und doppelklicken Sie darauf.
  7. Erweitern Sie im Navigationsfenster auf der linken Seite Stammcontainer, und erweitern Sie dann Oberste Ebene des Informationsspeichers oder IPM_SUBTREE.
  8. Klicken Sie mit der rechten Maustaste auf den Ordner Posteingang, und klicken Sie dann auf Zugehörige Inhaltstabelle öffnen. Durch diesen Schritt wird ein neues MFCMAPI-Fenster geöffnet, das verschiedene Eigenschaften enthält.
  9. Klicken Sie unter der Spalte Betreff mit der rechten Maustaste auf das Element mit dem Betreff IPM.Configuration.Autocomplete, und klicken Sie dann auf Nachricht exportieren. Durch diesen Schritt wird das Fenster Save Message To File (Nachricht in Datei speichern) geöffnet.
  10. Wählen Sie in der Dropdown-Liste MSG-Datei (UNICODE) aus, und klicken Sie dann auf OK.
  11. Wählen Sie einen Ordnerspeicherort aus, an dem die Nachricht gespeichert werden soll, und klicken Sie dann auf Speichern. Notieren Sie sich diesen Pfad.
Schritt 2

Um die AutoVervollständigen-Postfachnachricht zu importieren, befolgen Sie diese Schritte.
  1. Beenden Sie Outlook, und schließen Sie dann Outlook Web Access oder Outlook Web App (OWA) auf allen Arbeitsstationen, die mit Ihrem Postfach verbunden sind.
  2. Laden Sie das Hilfsprogramm MFCMAPI von http://mfcmapi.codeplex.com herunter, und installieren Sie es.
  3. Führen Sie mfcmapi.exe aus.
  4. Klicken Sie im Menü Sitzung auf Anmeldung.
  5. Wenn Sie nach einem Profil gefragt werden, wählen Sie den gewünschten Profilnamen aus, und klicken Sie dann auf OK.
  6. Suchen Sie im oberen Fenster die Zeile, die Ihrem Postfach entspricht, und doppelklicken Sie darauf.
  7. Erweitern Sie im Navigationsfenster auf der linken Seite Stamm - Postfach, und erweitern Sie dann Oberste Ebene des Informationsspeichers oder IPM_SUBTREE.
  8. Klicken Sie mit der rechten Maustaste auf den Ordner Posteingang, und klicken Sie dann auf Zugehörige Inhaltstabelle öffnen. Durch diesen Schritt wird ein neues MFCMAPI-Fenster geöffnet, das verschiedene Eigenschaften enthält.
  9. Um doppelte Einträge zu vermeiden, müssen Sie die vorhandene AutoVervollständigen-Nachricht löschen.

    Hinweis Bevor Sie die Nachricht IPM.Configuration.Autocomplete löschen, müssen Sie die Nachricht anhand der im Abschnitt „Exportieren des AutoVervollständigen-Zwischenspeichers“ beschriebenen Schritte exportieren.

    Um die vorhandene AutoVervollständigen-Nachricht zu löschen, befolgen Sie diese Schritte:
     
    1. Suchen Sie in der Spalte Betreff das Element mit dem Betreff IPM.Configuration.Autocomplete.
    2. Klicken Sie mit der rechten Maustaste auf das Element, und klicken Sie dann auf Nachricht löschen. Dadurch wird das Fenster Element löschen geöffnet.
    3. Wählen Sie in der Dropdown-Liste Permanent deletion (deletes to deleted item retention if supported) (Endgültig löschen (Löschen mit Aufbewahrungszeit für gelöschte Elemente, falls unterstützt) aus, und klicken Sie dann auf OK.
  10. Klicken Sie im Menü Ordner auf Importieren, und klicken Sie dann auf Von MSG.
  11. Suchen Sie die MSG-Datei, die Sie in Schritt 11 des Abschnitts „Exportieren der AutoVervollständigen-Liste“ erstellt haben, und klicken Sie dann auf OK.
  12. Wählen Sie im Fenster Load MSG (MSG laden), das angezeigt wird, Load message into current folder (Nachricht in aktuellen Ordner laden) in der Liste Load style (Ladestil) aus, und klicken Sie anschließend auf OK.
Die AutoVervollständigen-Informationen werden aus der Datei IPM.Configuration.Autocomplete_<Hexadezimalcode>.msg importiert, wobei der Platzhalter<Hexadezimalcode> für eine lange Zeichenfolge aus Zahlen und Buchstaben steht.
Outlook 2003 und Outlook 2007

Die Schritte zum Kopieren der AutoVervollständigen-Liste in Outlook 2003 und Outlook 2007 sind andere. Das liegt daran, dass Outlook 2003 und Outlook 2007 die AutoVervollständigen-Liste in der NK2-Datei speichern.

Um die AutoVervollständigen-Liste in Outlook 2007 zu kopieren, rufen Sie die folgende Microsoft-Website auf:

Kopieren der AutoVervollständigen-Liste auf einen anderen Computer

Entfernen einzelner Einträge aus der AutoVervollständigen-Liste

Um einzelne Einträge aus dem AutoVervollständigen-Zwischenspeicher zu löschen, befolgen Sie diese Schritte:
  1. Öffnen Sie eine neue E-Mail-Nachricht.
  2. Geben Sie die ersten Buchstaben des AutoVervollständigen-Eintrags ein, den Sie entfernen möchten.
  3. Wenn der Eintrag in der Liste der vorgeschlagenen Namen angezeigt wird, bewegen Sie den Mauszeiger über den Namen, bis er markiert wird, ohne auf ihn zu klicken.
  4. Wenn neben dem markierten Namen das Symbol „X“ angezeigt wird, klicken Sie auf das X, um den Namen aus der Liste zu entfernen oder drücken Sie die „Löschen"-Taste auf der Tastatur.

Löschen der gesamten AutoVervollständigen-Liste

In diesem Abschnitt wird erläutert, wie Sie die AutoVervollständigen-Liste löschen.
Outlook 2010, Outlook 2013 und Outlook 2016

Verwenden Sie eine der folgenden beiden Methoden, um die AutoVervollständigen-Liste in Outlook 2010, Outlook 2013 und Outlook 2016 zu löschen.

Methode 1

  1. Öffnen Sie Outlook.
  2. Klicken Sie auf der Registerkarte Datei auf Optionen.
  3. Klicken Sie auf die Registerkarte E-Mail.
  4. Klicken Sie unter Nachrichten senden auf AutoVervollständigen-Liste leeren.

    Fenster „Outlook-Optionen“
  5. Klicken Sie auf Ja.

Methode 2

Starten Sie Outlook mit der Befehlszeilenoption /CleanAutoCompleteCache. Gehen Sie hierzu wie folgt vor:
  1. Klicken Sie auf Start und anschließend auf Ausführen.
  2. Geben Sie „Outlook.exe /CleanAutoCompleteCache" ein.

    Hinweis Wenn Outlook nicht am Standardspeicherort installiert ist, müssen Sie den Pfad von „Outlook.exe“ angeben.
Outlook 2003 und Outlook 2007
Um die AutoVervollständigen-Liste in Outlook 2003 und Outlook 2007 zu löschen, müssen Sie die NK2-Datei manuell löschen. Gehen Sie folgendermaßen vor, um die NK2-Datei zu löschen:
  1. Beenden Sie Outlook.
  2. Klicken Sie auf „Start" und dann auf „Computer".
  3. Klicken Sie auf „Organisieren" und danach auf „Ordner- und Suchoptionen".
  4. Klicken Sie auf der Registerkarte „Ansicht" auf „Ausgeblendete Dateien, Ordner und Laufwerke anzeigen".
  5. Klicken Sie auf „OK".
  6. Klicken Sie auf „Start", klicken Sie auf „Alle Programme", klicken Sie auf „Zubehör" und klicken Sie anschließend auf „Ausführen".
  7. Geben Sie im Dialogfeld „Ausführen" den folgenden Befehl (einschließlich der Anführungszeichen) ein und klicken Sie danach auf „OK":

    "C:\ Benutzer\Benutzername\AppData\Roaming\Microsoft\Outlook"


    Hinweis: Benutzername in diesem Pfad ist der Name des aktuell angemeldeten Windows-Benutzers.
  8. Klicken Sie mit der rechten Maustaste auf die NK2-Datei mit dem Namen des Profils, das Sie zurücksetzen möchten und klicken Sie anschließend auf „Umbenennen". 
  9. Benennen Sie die Datei in „Profilname.bak" um und drücken Sie die Eingabetaste.
  10. Starten Sie Outlook.
 

Probleme mit dem AutoVervollständigen-Zwischenspeicher

In diesem Abschnitt werden bekannte Probleme beschrieben, die beim AutoVervollständigen-Zwischenspeicher auftreten können. Der AutoVervollständigen-Zwischenspeicher kann mit der Zeit beschädigt werden und speichert möglicherweise keine neuen Einträge. Wenn dies geschieht, können Sie versuchen, einzelne Einträge aus der Liste zu entfernen. Informationen zur entsprechenden Vorgehensweise finden Sie im Abschnitt mit dem Titel „Entfernen einzelner Einträge aus der AutoVervollständigen-Liste“. Wenn das Problem auf diese Weise nicht behoben werden konnte, kann die ganze AutoVervollständigen-Liste zurückgesetzt werden. Informationen zur entsprechenden Vorgehensweise finden Sie im Abschnitt mit dem Titel „Löschen der gesamten AutoVervollständigen-Liste“.
 

Ändern der Grenze für die AutoVervollständigen-Liste

Da diese Konfiguration nicht getestet wurde, empfehlen wir sie nicht. Wenn Sie eine größere AutoVervollständigen-Liste haben, könnten Sie auch eine größere Anzahl zwischengespeicherter Einträge verlieren, wenn Ihr AutoVervollständigen-Zwischenspeicher aufgrund von Beschädigung unbrauchbar wird. Mit diesem Vorbehalt können Sie die folgenden Registrierungsdaten verwenden, um die Grenze der AutoVervollständigen-Liste in Outlook zu erhöhen.

Wichtig Dieser Abschnitt bzw. die Methoden- oder Aufgabenbeschreibung enthält Hinweise zum Ändern der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Als Schutzmaßnahme sollten Sie vor der Bearbeitung der Registrierung eine Sicherungskopie erstellen. So ist gewährleistet, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen und Wiederherstellen einer Sicherungskopie der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
 
322756 Sichern und Wiederherstellen der Registrierung in Windows
  1. Beenden Sie Outlook.
  2. Starten Sie den Registrierungs-Editor.
     
    • Drücken Sie in Windows 8.x die Windows-Taste, geben Sie regedit ein, und drücken Sie dann die EINGABETASTE.
    • Klicken Sie in Windows 7 und Windows Vista auf Start, geben Sie in das Feld Suche starten die Zeichenfolgeregedit ein, und drücken Sie die EINGABETASTE.
  3. Klicken Sie auf den folgenden Registrierungsunterschlüssel:
     
    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoNameCheck

    Hinweis: Der Platzhalter „x.0" in diesem Registrierungsunterschlüssel steht für Ihre Version von Microsoft Office. Verwenden Sie den entsprechenden Wert aus der folgenden Liste.

    Outlook 2016 = 16.0
    Outlook 2013 = 15.0
    Outlook 2010 = 14.0
    Outlook 2007 = 12.0
    Outlook 2003 = 11.0
  4. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie anschließend auf DWORD-Wert.
  5. Geben Sie MaxNickNames ein, und drücken Sie dann die EINGABETASTE.
  6. Klicken Sie im Menü Bearbeiten auf Ändern.
  7. Geben Sie den neuen Wert für die Grenze ein, und klicken Sie dann auf OK.

    Hinweise
    • Achten Sie darauf, die Zahl in Dezimalform einzugeben. Dies ist die korrekte Form für die Eingabe der Zahl.
    • Versuchen Sie, die Grenze nur geringfügig zu erhöhen, um die neue Grenze zu testen. Um z. B. die Grenze in Outlook 2013 um 20 Prozent zu erhöhen, würden Sie für den MaxNickNames-Wert „1200" eingeben.
  8. Beenden Sie den Registrierungs-Editor.
  9. Starten Sie Outlook.
Hinweis Der MaxNickNames-Registrierungswert gibt nur die nicht standardmäßige Grenze an. Daher können Sie diesen Wert auch verwenden, um die Grenze des Spitznamen-Zwischenspeichers zu senken.