Benutzerdefinierte Entität wird nicht nach dem Importieren einer Lösung

Gilt für: Microsoft Dynamics CRM 2011

Problembeschreibung


Nach dem Importieren einer Lösung in einer anderen Organisation benutzerdefinierte Entität nicht angezeigt wird.

Ursache


Dies geschieht, wenn die Projektmappe kein SiteMap als Komponente verfügt.

Dies kann auch geschehen, wenn Sie nach dem Importieren der Lösung nicht Anpassungen veröffentlichen.

Problemlösung


Lösung 1:
SiteMap in die Lösung integrieren und die Lösung erneut exportieren. Importieren Sie dann die Lösung in einer anderen Organisation.
  1. Klicken Sieauf Lösungen , und öffnen Sie die Projektmappe, die Sie ändern möchten.
  2. Klicken Sie auf Client Extensionsund auf Vorhandenes wählen Sie Siteübersicht aus.
  3. Klicken Sie auf Speichern.
  4. Lösung exportieren auf und führen Sie den Export-Assistenten um Ihre Lösung zu exportieren.

Lösung 2:
Passen Sie die importierte benutzerdefinierte Entität für die Organisation, die Lösung importiert wurde die Entität im Bereich anzeigen, wie Arbeitsplatz möchten an.
  1. Klicken Sieauf Anpassen und auf System anpassen.
  2. Komponenten- Entitäten erweitert und wählen Sie die Entität, die Sie ändern möchten.
  3. Wählen Sie die Bereiche, in denen diese Entität angezeigt Bereiche die benutzerdefinierte Entität angezeigt.
Lösung 3:

Veröffentlichen Sie alle Anpassung:
  1. Klicken Sieauf Anpassen und auf System anpassen.
  2. Klicken Sie auf Alle Anpassung veröffentlichen.
Veröffentlichen Sie nur die benutzerdefinierte Entität:
  1. Klicken Sieauf Anpassen und auf System anpassen.
  2. Komponenten- Entitäten erweitert und wählen Sie die Entität, die Sie veröffentlichen möchten.
  3. Klicken Sie auf der Multifunktionsleiste auf Veröffentlichen .