Fehler beim Konfigurieren von Microsoft Dynamics CRM 2011-Client für Outlook, während "Profil laden" Teil der Konfigurations-Assistent

Problembeschreibung

Wenn Microsoft Dynamics CRM 2011 Outlook-Client zu konfigurieren, tritt ein Fehler nach der Eingabe des Benutzers Windows Live Id und "Profil laden" Teil des Assistenten.

In der Crm50ClientConfig.log tritt folgender Fehler auf:

Fehler | Ausnahme: Bei Microsoft.Interop.Mapi.CRcwMsgServiceAdmin.CreateMsgServiceEx (String ServiceName Zeichenfolge DisplayName IntPtr-UIParam, IMsgServiceAdmin_CreateMsgService_Flags-Flags)
bei Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.InstallCrmDatastore (Guid OrganizationId Guid UserId Zeichenfolge ServerUrl, Organisationsname Zeichenfolge, Zeichenfolge DisplayName)
bei Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure (IProgressEventHandler ProgressEventHandler)
bei Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure (Objekt StateInfo)

Die Crm50ClientConfig.log befindet sich in den folgenden Verzeichnissen:

Windows7/2008
%userprofile%\AppData\Local\Microsoft\MSCRM\Logs

WindowsXP/2003
%userprofile%\Local Settings\Application Data\MSCRM\Logs

Ursache

Der oben angegebene Fehler auftreten, wenn eine der folgenden Situationen zutrifft:

Ursache 1:
Die Datei "MAPISVC.inf" existiert nicht in der richtigen Position.

Ursache 2:
Die Microsoft Dynamics CRM-Dienste werden nicht auf die Datei "MAPISVC.inf" registriert

Problemlösung

Lösung 1:

Um uns Lösung 1 für Sie ausführen, lesen Sie den Abschnitt "Fix it für mich". Wenn Lösung 1 durchführen möchten, lesen Sie den Abschnitt "Problem manuell beheben".

Automatisch mit Fix it beheben lassen



Auflösung 1 automatisch zu senden, klicken Sie auf die Fix it -Schaltfläche oder den Link. Klicken Sie im Dialogfeld Dateidownload auf Ausführen , und führen Sie die Schritte im Fix it -Assistenten aus.




Hinweise
  • Dieser Assistent ist nur auf Englisch verfügbar. Die automatische Korrektur funktioniert jedoch auch für andere Sprachversionen von Windows.
  • Wenn Sie gerade nicht auf dem Computer arbeiten, auf dem das Problem auftritt, speichern Sie die Fix it Fehlerbehebung auf ein Flashlaufwerk oder CD und führen diese dann auf dem Computer, auf dem das Problem auftritt, aus.

Wechseln Sie dann zum Abschnitt "Wurde das Problem behoben?".



Lassen Sie mich das Problem manuell beheben

1. der Speicherort der Datei "MAPISVC.inf" hängt von der Architektur von Windows als auch Outlook. Folgt MAPISVC.inf Datei vorhanden ist, auf der Architektur von Windows und Outlook basiert.

32-Bit oder X86 Version von Windows und Outlook:
C:\Windows\System32\mapisvc.inf
C:\Program Files\Common Files\System\MSMAPI\1033\mapisvc.inf

64-Bit oder X64 Version von Windows und Outlook:
C:\Program Files\Common Files\System\MSMAPI\1033\mapisvc.inf
C:\windows\SysWOW64\mapisvc.inf

32-Bit oder X86 Version von Outlook mit einem 64-Bit oder X64 Version von Windows:
C:\Programme\Gemeinsame Dateien (x86) \Common Files\System\MSMAPI\1033\mapisvc.inf
C:\windows\SysWOW64\mapisvc.inf

2 sollten Sie die Datei "MAPISVC.inf" nicht in einem dieser Speicherorte vorhanden ist, in die UserProfile suchen:
Windows7/2008
%userprofile%\AppData\Local\Microsoft\Outlook

WindowsXP/2003
%userprofile%\Local Settings\Application Data\Microsoft\Outlook

3. wenn die MAPISVC.inf-Datei in das Benutzerprofil vorhanden ist, kopieren Sie sie in den richtigen Verzeichnissen basierend auf der Architektur von Windows und Outlook.

4. Wenn Sie nicht sicher welche Architektur für Windows oder Outlook verwenden sind, gehen Sie folgendermaßen vor:
Windows:
Klicken Sie auf Windows-Start-Schaltfläche
b. gehen auf Programme > Zubehör
c. Maustaste auf Befehlszeile und wechseln Sie zu "Ausführen als Administrator"
d. Führen Sie d. folgenden Befehl:
Reg Query "HKLM\System\CurrentControlSet\Control\Session Manager\Environment" v PROCESSOR_ARCHITECTURE

Zurückgegeben, würde die folgenden Ergebnisse dafür sein, dass das Betriebssystem eine 64-Bit-Betriebssystem ist:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment
PROCESSOR_ARCHITECTURE REG_SZ AMD64

Zurückgegeben, würde die folgenden Ergebnisse dafür sein, dass das Betriebssystem eine 32-Bit-Betriebssystem ist:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment
PROCESSOR_ARCHITECTURE REG_SZ x86

Wenn Windows eine 32-Bit-Betriebssystem ist, werden Outlook eine 32-Bit-Anwendung. Wenn Windows 64-Bit-Betriebssystem ist, kann Outlook-Anwendung eine 32-Bit oder 64-Bit-Anwendung jedoch. Outlook 2003 und Outlook 2007 werden nur als 32-Bit-Programme unterstützt. Outlook 2010 hat jedoch beide Architektur:

So ermitteln Sie die Version Outlook 2010 gehen Sie folgendermaßen vor:
Klicken Sie auf Windows-Start-Schaltfläche
b. gehen auf Programme > Zubehör
c. Maustaste auf Befehlszeile und wechseln Sie zu "Ausführen als Administrator"
d. Führen Sie d. folgenden Befehl basierend auf der Version von Office:
Reg Query "HKLM\Software\Microsoft\Office\14.0\Outlook" v Bitness

Lösung 2:

Wenn Microsoft Dynamics CRM-Dienste nicht auf die Datei "MAPISVC.inf" registriert sind wir manuell die Datei "MAPISVC.inf" diese Einträge hinzufügen und an den richtigen Speicherorten ablegen.

Zur Behebung dieses Problems erhalten Sie Support für Microsoft Dynamics CRM-Hilfe.

Wurde das Problem behoben?

  • Überprüfen Sie, ob das Problem behoben ist. Wenn das Problem behoben ist, Sie sind mit diesem Abschnitt fertig. Wenn das Problem nicht behoben ist, können Sie sich an den Support wenden.
  • Wir schätzen Ihr Feedback. Um Feedback zu geben oder über Probleme mit dieser Lösung zu informieren, schreiben Sie einen Kommentar im "Fix it für mich"-Blog, oder senden Sie uns eine E-Mail.
Eigenschaften

Artikelnummer: 2538692 – Letzte Überarbeitung: 10.01.2017 – Revision: 1

Microsoft Dynamics CRM 2011

Feedback