Falsche Fehlermeldung für fehlende ADML-Dateien

Dieser Artikel bietet eine Lösung für ein Problem, bei dem falsche Fehlermeldungen zurückgegeben werden, wenn ADML-Dateien fehlen.

Gilt für: Windows Server 2012 R2
Ursprüngliche KB-Nummer: 2688272

Symptome

SR-Symptome:

Der EN-US-Domänencontroller versucht, einen Einstellungsbericht für ein Gruppenrichtlinienobjekt zu erstellen. Der Bericht wird mit der Meldung erstellt:

Eine geeignete Ressourcendatei konnte für die Datei \\domainname.com\sysvol\domainname.com\Policies\PolicyDefinitions\anyfile.admx nicht gefunden werden (Fehler = 2): Das System kann die angegebene Datei nicht finden.
Die admx-Dateien, die als fehlend gemeldet werden, sind im angegebenen Ordner vorhanden.

Repro-Symptome:

Beim Umbenennen des Ordners, der die entsprechenden ADML-Dateien enthält, wird der Folgende Fehler zurückgegeben:

Für die Datei \\domainname.com\sysvol\domainname.com\Policies\PolicyDefinitions\anyfile.admx (Fehler = 3) konnte keine geeignete Ressourcendatei gefunden werden: Der angegebene Pfad kann vom System nicht gefunden werden.
Dieser Fehler tritt auch auf, wenn der Ordner EN-US nicht vorhanden ist und fehlt.

Das Bearbeiten der betroffenen Gruppenrichtlinienobjekte wird unmöglich, Berichte sind ungenau. Das Problem tritt nicht auf die gleiche Weise auf, wenn andere Sprachdateien und -ordner fehlen, da EN-US die Fallbacksprache ist und stattdessen geladen wird, wenn eine andere Sprache fehlt.

Ursache

Um Berichte zu generieren oder das Gruppenrichtlinienobjekt zu bearbeiten, müssen die ADMX-Datei und die entsprechende ADML-Sprachdatei geladen werden. Je nachdem, welcher Benutzer in der Muttersprache den Bearbeitungs-/Berichterstellungsvorgang anfordert, wird die ADML-Datei im entsprechenden Sprachordner (en for en, de for de, an so weiter) durchsucht. Wenn der abfragende Benutzer z. B. Englisch wünscht und im zentralen GPO-Speicher nur die deutschen ADML-Dateien installiert sind, tritt ein solcher Fehler auf.

Die Fehlerberichterstattung ist falsch, da sie auf die ADMX-Datei als fehlt verweist, während diese Datei am angegebenen Speicherort vorhanden ist.

Lösung

Wenn Sie die ADML-Dateien für die abgefragte Sprache im richtigen Ordner verfügbar machen, wird das Problem behoben. Weitere Informationen finden Sie unter Erstellen des zentralen Speichers für Gruppenrichtlinie Administrative Vorlagendateien in Windows Vista.

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, sollten Sie die Informationen sammeln, indem Sie die unter Sammeln von Informationen mithilfe von TSS für Gruppenrichtlinie Probleme beschriebenen Schritte ausführen.