32-Bit-Browser-Anwendung möglicherweise nicht erwartungsgemäß in Internet Explorer 10

Problembeschreibung

Wenn Sie Internet Explorer 10 auf dem Desktop auf einem 64-Bit-Version von Windows 8 Add-ons ausführen für 32-Bit-Browser erstellt werden (z. B. Symbolleisten, Browserhilfsobjekte (BHOs) und ActiveX Steuerelemente) funktionieren nicht wie erwartet.

Dieses Problem tritt bei der folgenden Registrierungseintrag auf 0 festgelegt ist:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\TabProcGrowth

Ursache

Internet Explorer 10-Manager-Prozess ist immer ein 64-Bit-Prozess in 64-Bit-Versionen von Windows 8. Dies ist eine Änderung der Architektur in Internet Explorer 10. Standardmäßig können registerkartenprozesse 32-Bit- oder 64-Bit-Prozesse sein, außer wenn der TabProcGrowth -Registrierungseintrag auf 0 festgelegt ist. Wenn dieser Registrierungseintrag auf 0 festgelegt ist, führen Sie die Registerkarten in demselben Prozess aus wie der Manager Prozess, der in diesem Fall ein 64-Bit Prozess ist. Einige Browser-Add-Ons haben jedoch keine 64-Bit-Version. Daher arbeiten sie nicht erwartungsgemäß.

PROBLEMUMGEHUNG

Wichtig Dieser Abschnitt bzw. die Methode oder Aufgabe enthält Schritte, die erklären, wie Sie die Registrierung ändern. Allerdings können schwerwiegende Probleme auftreten, wenn Sie die Registrierung falsch ändern. Stellen Sie daher sicher, dass Sie die folgenden Schritte sorgfältig ausführen. Sichern Sie die Registry für zusätzlichen Schutz, bevor Sie sie ändern. Anschließend können Sie die Registrierung wiederherstellen, falls ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
322756 zum Sichern und Wiederherstellen der Registrierung in Windows
Sollen wir dieses dieses Problem für sie beheben, dann gehen Sie zum Abschnitt "Fix it für mich". Wenn Sie das Problem selbst beheben möchten, lesen Sie den Abschnitt "Problem manuell beheben".

Automatisch mit Fix it beheben lassen

Um dieses Problem zu beheben, klicken Sie auf die Fix it -Schaltfläche oder den Link. Klicken Sie im Dialogfeld Dateidownload auf Ausführen , und führen Sie die Schritte im Fix it -Assistenten aus.



Notes

Lassen Sie mich das Problem manuell beheben

Weitere Informationen

Weitere Informationen zum Registrierungseintrag TabProcGrowth finden Sie auf der folgenden Microsoft MSDN-Website:Weitere Informationen zu Problemen, die auftreten können, wenn Sie eine 64-Bit-Version von Internet Explorer als Standardversion verwenden, gehen Sie auf der folgenden Microsoft MSDN-Website:
Eigenschaften

Artikelnummer: 2716529 – Letzte Überarbeitung: 23.01.2017 – Revision: 1

Windows Internet Explorer 10, Windows 8, Windows 8 Enterprise

Feedback