XCON: Client-SMTP-Authentifizierung ist aktiviert, Relay funktioniert jedoch nicht, Fehlermeldung: 550 Relay nicht zulässig

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
275575 XCON: Client SMTP Authentication Is Enabled, But Relay Does Not Work, Error Message: 550 No Relay Allowed

Problembeschreibung

Der SMTP-Dienst (SMTP = Simple Mail Transfer Protocol) von Exchange Server 5.5, Exchange 2000 oder Microsoft Internet Information Services (IIS) ist darauf konfiguriert, ein Relay für Clients zuzulassen, die sich authentifizieren. Ein Client, wie zum Beispiel Outlook Express, versucht, E-Mail über SMTP zu versenden, der Versuch schlägt jedoch fehl. Es werden eine oder mehrere der folgenden Fehlermeldungen angezeigt:
550 No relay allowed (Relay nicht zulässig)
-oder-
550 Relay Denied (Relay verweigert)
-oder-
550 5.7.1 Unable to relay for <firma.com> (Kein Relay möglich für <firma.com>)
Weitere mögliche Symptome sind:
  • Wenn Sie versuchen, über Telnet eine Verbindung zum Internet Mail-Dienst von Exchange Server herzustellen, enthält die Antwort anstelle des erwarteten Hostnamens eine Reihe von Sternchen (*). Beispiel:
    250 *********************
  • Wenn Sie den ESMTP-Befehl (ESMTP = Extended SMTP) EHLO ausführen lassen, erhalten Sie eine Antwort, die der folgenden ähnelt:
    500 Unrecognized command (Unbekannter Befehl)
    Tatsächlich werden jedoch keinerlei ESMTP-Befehle akzeptiert.

Ursache

Prüfen Sie, ob ein Cisco PIX-Router vorhanden ist. Auf dem Cisco PIX-Router ist standardmäßig eine Software mit dem Namen "MailGuard" oder "MailHost" aktiv. Bei einer Standardinstallation hat diese Software jedoch einen anderen Namen, nämlich "FIXUP PROTOCOL SMTP 25".

Diese Software kann die Ausführung von ESMTP-Befehlen wie EHLO verhindern. Da Sie keine ESMTP-Konversation mit dem Exchange Server-Computer initiieren können, kann der ESMTP-Befehl AUTH nicht ausgeführt werden, was zur Folge hat, dass sich der Client nicht bei dem Exchange Server-Computer authentifizieren kann und ein Relay für E-Mail-Nachrichten nicht funktioniert.

Lösung

Deaktivieren Sie das Mail Guard-Feature auf der Cisco PIX-Firewall. Weitere Informationen erhalten Sie von der Firma Cisco.

Weitere Informationen

Mail Guard ermöglicht Verbindungen zu einem internen E-Mail-Host ausschließlich über den TCP-Port 25. Diese Software protokolliert sämtliche SMTP-Aktivitäten und lässt nur die SMTP-Serverbefehle zu, die in RFC 821 (Abschnitt 4.5.1) aufgeführt sind.

Weitere Informationen finden Sie in folgendem Artikel der Microsoft Knowledge Base:

190366 XFOR: Cannot Reply to Messages Through a Cisco PIX Firewall
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Informationen zur Kontaktaufnahme mit Cisco finden Sie in einem der folgenden Artikel der Microsoft Knowledge Base:
65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z
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Eigenschaften

Artikelnummer: 275575 – Letzte Überarbeitung: 07.03.2004 – Revision: 1

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