SharePoint 2010-Verwaltungsshell wird mit Windows PowerShell 3.0 nicht geladen.

Problembeschreibung

Nachdem Sie Microsoft SharePoint Server 2010 und Windows PowerShell 3.0 auf einem Server installieren, wird eine oder beide der folgenden Fehlermeldungen beim Starten von SharePoint 2010-Verwaltungsshell:

Fehlermeldung 1
Die lokale Farm kann nicht zugegriffen werden. Cmdlets mit ' FeatureDependencyId ' sind nicht registriert.
Fehlermeldung 2
Microsoft SharePoint ist nicht mit Microsoft .net Runtime-Version 4.0.30319.17929 unterstützt.

PROBLEMUMGEHUNG

Um dieses Problem zu umgehen, ändern Sie Feld Zielwert für SharePoint 2010-Verwaltungsshell . Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Startund anschließend mit der Maustaste SharePoint 2010-Verwaltungsshell.
  2. Klicken Sie auf Eigenschaften.
  3. Klicken Sie auf der Registerkarte Verknüpfung im Eigenschaftenfenster von SharePoint 2010 Management Shell.
  4. Geben Sie im Feld Ziel den folgenden Wert:

    C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -Version 2.0 - NoExit "& 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\POWERSHELL\Registration\\sharepoint.ps1'"

Eigenschaften

Artikelnummer: 2796733 – Letzte Überarbeitung: 10.01.2017 – Revision: 1

Microsoft SharePoint Server 2010, Microsoft SharePoint Server 2010 Service Pack 1

Feedback