Problembehandlung bei beschädigten Dokumenten in Word für Mac

Zusammenfassung

Dieser Artikel enthält Verfahren zur Problembehandlung, mit denen Sie beschädigte Dateien in Microsoft Word für Mac identifizieren und in einigen Fällen solche Dateien wiederherzustellen.

Beschädigte Dokumentdateien können dazu führen, dass eine Programm ein ungewöhnliches Verhalten. Dieses Verhalten tritt auf, weil das Programm falsche Informationen aus der beschädigten Datei empfangen.

Weitere Informationen

So identifizieren Sie eine beschädigte Datei

Beschädigte Dateien verursachen häufig nicht Verhalten Teil Programmentwurf – beispielsweise, inkorrektes nicht und Formatierung, nicht lesbare Zeichen auf dem Bildschirm, Fehlermeldungen während der Verarbeitung, System hängt oder stürzt ab beim Laden oder Einsehen der Datei oder einem anderen ungewöhnlichen Verhalten, das den normalen Betrieb des Programms zugeschrieben werden kann. Dieses Verhalten können auch durch andere Faktoren als beschädigtes Dokument verursacht werden. Führen Sie diese Tipps zur Problembehandlung, um andere Faktoren auszuschließen:

  • Überprüfen Sie in andere Dokumente ein ähnliches Verhalten.
  • Überprüfen Sie in anderen Programmen ein ähnliches Verhalten.
  • Die betreffende Datei auf einen anderen Computer, und versuchen Sie, das Verhalten zu reproduzieren.
  • Verwenden Sie einen anderen Druckertreiber und versuchen Sie, das Verhalten zu reproduzieren. Gehen Sie folgendermaßen vor, um einen anderen Druckertreiber verwenden:

    1. Wählen Sie im Apple -Menü Auswahl .
    2. Wählen Sie in der Auswahleinen anderen Druckertreiber und schließen Sie die Auswahl.
    3. Markieren Sie in Word für Mac Seite einrichten im Menü Datei , um sicherzustellen, dass Sie ausgewählt Druckertreiber in Word für Mac aktiviert ist
  • Benennen Sie alle Vorlagen, die das Dokument an, und versuchen Sie dann, das Verhalten zu reproduzieren.
  • Starten Sie den Computer wieder mit der Erweiterung deaktiviert alle Programme deaktivieren, die (wie Beenden-and-Stay-Resident Programme [TSRs], Schriftarten-Manager und Bildschirmschoner) ausgeführt werden. Versuchen Sie, das Verhalten zu reproduzieren. Weitere Informationen zum Starten des Computers mit der Erweiterung von finden Sie der Microsoft Knowledge Base:

    263159 Behandlung von Erweiterung Konflikte auf dem Macintosh
Tritt das Problem nur bei einem einzigen Dokument, nachdem Sie die vorangegangenen Schritte durchgeführt, ist das Dokument möglicherweise beschädigt. Wenn es unerwartet beendet werden, bevor die Datei geschlossen wurde, und die Funktion "AutoWiederherstellen" aktiviert wurde, wurde möglicherweise eine AutoWiederherstellen-Datei erstellt. AutoWiederherstellen-Datei können Sie die Datei wiederherstellen.

Die AutoWiederherstellen-Funktion in Word für Mac versucht, automatisch ein Dokument Wiederherstellen von Text aus, der offenen Word für Mac nicht mehr reagiert. Beim Neustart Word für Mac es reagiert (hängt), wird ein Dialogfeld mit folgender Meldung angezeigt:
Trat beim Öffnen der DateinameDatei beschädigt. Teil des Dokuments kann möglicherweise wiederhergestellt werden. Jetzt wiederherstellen?
Hinweis: diese Wiederherstellung kann einige Zeit dauern, abhängig von der Größe des Dokuments und der Schaden im Dokument.

Nach der Wiederherstellung des Dokuments sofort verwenden Sie den Befehl Speichern unter im Menü Datei , das Dokument unter einem neuen Namen speichern. Dadurch werden das ursprüngliche Dokument für andere Wiederherstellungsversuche. Diese automatische Wiederherstellungsmethode entfernt alle Formatierung, Grafiken und Objekte aus dem Dokument.

In diesem Artikel beschriebenen Methoden können Sie über die ursprüngliche Formatierung aus dem beschädigten Dokument wiederherzustellen.

Weitere Informationen über die Funktion "AutoWiederherstellen" finden Sie "Verhindern Datenverlust von Word und Wiederherstellen verloren Dokumente" in Word für Mac- Hilfe.

Korrektur ein beschädigtes Dokuments

Es gibt verschiedene Techniken, mit denen Sie versuchen, ein beschädigtes Dokument zu beheben. Die Methode hängt von Art und Schwere des Schadens und Verhalten ist. Obwohl viele dieser Methoden häufig erfolgreich sind, kann nicht jedes beschädigtes Dokument wiederhergestellt werden. Halten eine Sicherungskopie eines Dokuments ist am besten für die Wiederherstellung.

Die folgenden Schritte sind in zwei Abschnitte unterteilt: "Wenn die Datei können werden öffnen in Word für Mac" und "Wenn die Datei kann nicht werden öffnen in Word für Mac" Verwenden Sie den entsprechenden Abschnitt für Ihre Situation.

Wenn die Datei in Word für Mac geöffnet werden kann

Wenn Sie die Datei in Word für Mac öffnen können, verwenden Sie eine der folgenden Methoden.

Methode 1: Konvertieren Sie die Datei in ein anderes Format

Die Datei in ein anderes Format konvertieren und dann in das systemeigene Format konvertieren.

Dies ist die einfachste und umfassendste Dokument Wiederherstellungsmethode. immer versuchen Sie es zuerst. Speichern Sie die Datei im Rich Text Format (RTF). Dieses Format behält die Formatierung in Word für Mac-Dokument. Nach dem Speichern der Datei in RTF konvertieren aus RTF öffnen Sie die Datei in Word für Mac Wenn diese Methode erfolgreich ist, wird Schaden an der Datei während der Konvertierung entfernt.

Gehen Sie folgendermaßen vor, um die Datei im RTF-Format zu speichern:

  1. Klicken Sie im Menü Datei auf Speichern unter.
  2. Klicken Sie auf der Liste , und wählen Sie Rich-Text-Format.
  3. Ändern Sie den Namen des Dokuments. (Dies wird empfohlen, die Schritte mit ursprünglichen unveränderten Dokument fortgesetzt werden kann.)
  4. Klicken Sie auf Speichern.
Der Schaden besteht weiterhin nach dem Speichern der Datei als RTF, versuchen Sie, die Datei in einem der folgenden Dateiformate speichern:

  • Andere Formate Textverarbeitung
  • Nur Text
Hinweis: Speichern einer Datei im Nur-Text-Format häufig behebt das Problem Schäden; ist jedoch die gesamte Formatierung verloren, einschließlich Grafiken und Feld Codes in Word für Mac. Diese Methode erfordert mehr formatieren. Daher verwenden sie erst andere Dateiformate nicht das Problem zu beheben.


Weitere Verlust von Visual Basic for Applications-Code in Word für Mac-Dokumente in andere Formate konvertiert werden, klicken Sie auf die folgenden Artikelnummer der Microsoft Knowledge Base:

184153 WD98: VBA-Code nach der Konvertierung in ein anderes verloren

Methode 2: Kopieren Sie alles mit Ausnahme der letzten Absatzmarke in ein neues Dokument

Word für Mac associates eine Vielzahl von Formatierung mit der letzten Absatzmarke, insbesondere Abschnitt und Formatierung. Wenn Sie alles in der Datei, mit Ausnahme der letzten Absatzmarke in eine neue Datei kopieren, kann der Schaden im Originaldokument zurückgelassen.

Alles mit Ausnahme der letzten Absatzmarke kopieren im Dokument folgendermaßen vor:

  1. Öffnen Sie das Dokument, das das unerwartete Verhalten aufweist.
  2. Klicken Sie im Menü Bearbeiten auf Alles markieren.
  3. Das ausgewählte Dokument drücken Sie Befehl + Umschalt + linke Richtungstaste. (Dies nur die letzte Absatzmarke aus der Auswahl entfernt.)
  4. Wählen Sie im Menü Bearbeiten auf Kopieren.
  5. Wählen Sie im Menü Datei auf Neues Dokument.
  6. Wählen Sie im neuen Dokument Einfügen im Menü Bearbeiten .

    Hinweis: In dem neuen Dokument möglicherweise abschnittsformatierung oder Formatierung anwenden.

Methode 3: Kopieren der unbeschädigten Teile der Datei in eine neue Datei

Manchmal bestimmen Sie den Speicherort der Beschädigung in der Datei Datei oder um festzustellen, wann das Verhalten testen. Eine weitere Möglichkeit, zu bestimmen, welcher Bereich der Datei beschädigt ist entweder eine Seite oder eine Reihe von Seiten in eine neue Datei kopieren. Speichern Sie die neue Datei, und prüfen Sie, ob das ursprüngliche Verhalten. Wenn das Verhalten nicht mehr auftritt, weiterhin Seiten speichern und testen, bis das ursprüngliche Verhalten kopiert.

Wenn Sie finden können, welcher Bereich der Datei beschädigt ist, können Sie alles mit Ausnahme der beschädigte Bereich in eine neue Datei kopieren und führen Sie diese Schritte, um Ihr Dokument wiederherzustellen:

  1. Kopieren Sie die unbeschädigten Teile des Dokuments, und fügen Sie sie in eine neue Datei (nicht möchten Absatz markieren der Auswahl, da diese Absatzmarke falsche Informationen enthalten kann).
  2. Speichern Sie eine Kopie des Dokuments im Nur-Text-Format.
  3. Öffnen Sie die nur-Text-Datei.
  4. Kopieren Sie den Text aus dieser Datei, und fügen Sie ihn in die Datei mit der unbeschädigten Teil der Datei.
  5. Formatieren Sie die Abschnitte des Dokuments, das Sie in Schritt 4 eingefügt und dann speichern.

Wenn die Datei NICHT in Word für Mac geöffnet werden kann

Wenn Sie die Datei in Word für Mac öffnen können, verwenden Sie eine der folgenden Methoden.

Methode 1: Fügen Sie die Datei in ein leeres Dokument

Wenn Sie eine Datei zum Kopieren des Textes (mit Ausnahme der letzten Absatzmarke) öffnen können, um die Datei in ein neues Dokument möglicherweise. Dies fügt eine neue letzte Absatzmarke auf die Datei, die Sie korrigieren. Gehen Sie hierzu folgendermaßen vor:

  1. Erstellen Sie ein neues Dokument basierend auf der Vorlage Normal.
  2. Klicken Sie im Menü Einfügen auf Datei. Wählen Sie das beschädigte Dokument und klicken Sie dann auf OK.

Methode 2: Verwenden des Befehls Verknüpfung einfügen, das Dokument mit einem Link öffnen

Diese Methode verwendet ein "dummy" Dokument eine Verknüpfung erstellen und dann wird die Verknüpfung zwischen dem "dummy" Dokument und das beschädigte Dokument.

Gehen Sie eine Verknüpfung einfügen-Operation verwenden, um ein beschädigtes Dokument öffnen

  1. Schließen Sie alle geöffneten Dokumente in Word für Mac, und öffnen Sie ein neues leeres Dokument.
  2. Geben Sie Test.
  3. Markieren Sie das Wort Testein. Klicken Sie im Menü Bearbeiten auf Kopieren.
  4. Klicken Sie im Menü Datei auf neu und öffnen Sie ein neues leeres Dokument.
  5. Klicken Sie im Menü Bearbeiten auf Einfügen. Klicken Sie im Dialogfeld Inhalte einfügen auf Verknüpfung einfügen. Im Feld als auf Formatierten Text (RTF)klicken Sie auf OK
  6. Klicken Sie im Menü Bearbeiten auf Links.
  7. Klicken Sie im Dialogfeld Links auf Quelle ändern. Suchen Sie und wählen Sie das Dokument, das Sie wiederherstellen möchten, klicken Sie im Dialogfeld Öffnen . Klicken Sie auf Öffnen , und klicken Sie dann auf OK.
  8. Beim Öffnen des Dokuments klicken Sie im Menü Datei auf Speichern unter . Geben Sie einen neuen Namen für das Dokument, und klicken Sie dann auf Speichern.
  9. Klicken Sie bei geöffnetem Dokument im Menü Bearbeiten auf Links .
  10. Klicken Sie im Dialogfeld Links auf Links unterbrochen. Klicken Sie im Dialogfeld auf Ja, um die Verknüpfung aufheben.
Hinweis: nach der Link fehlerhaft ist, sollten Sie das Dokument speichern, bevor Sie es schließen oder ändern.

Methode 3: Öffnen Sie die Datei mit "Text aus beliebiger Datei wiederherstellen"

Als letzte Möglichkeit können Sie den speziellen Konverter "Text aus beliebiger Datei wiederherstellen" beschädigte Dokumente manuell zu öffnen. Dieser Konverter entfernt alle Formatierungen, Grafiken und eingebettete Objekte aus der Datei und behält nur lesbaren Text (ASCII-Zeichen). Aufgrund der Art, dass Word für Mac-Dokument-Dateien strukturiert und gespeichert werden der Text getrennten oder dupliziert.

Selbst die einfachsten Dateien muss erhebliche formatieren. Mit kleineren Dateien möchten Sie öffnen einen neuen zweiten Dokuments und kopieren und Einfügen von Text aus das wiederhergestellte Dokument in ein neues Dokument da viel unerwünschten wiederhergestellt Text.

Wenn Sie den Konverter "Text aus beliebiger Datei wiederherstellen" verwenden, um ein Dokument zu öffnen, gehen Sie folgendermaßen vor:

  1. Klicken Sie im Menü Datei auf Öffnen.
  2. Klicken Sie auf die Liste , und klicken Sie auf Text aus beliebiger Datei wiederherstellen.
  3. Suchen Sie den Ordner mit der beschädigten Datei, und wählen Sie dann die Datei.
  4. Klicken Sie auf Öffnen.
Hinweis: der Wiederherstellungsprozess kann einige Zeit dauern, abhängig von der Größe des Dokuments sowie die Art des Schadens. Sobald die Wiederherstellung abgeschlossen ist, klicken Sie im Menü Datei auf Öffnen , und ändern Sie Dateityp zurück zu Word-Dokumenten oder Lesbare Dateien.

Tipp: an dieser Stelle die wiederhergestellte Datei unter einem neuen Namen speichern. Dies verhindert, dass das ursprüngliche Dokument versehentlich überschrieben und das ursprüngliche Dokument für andere Wiederherstellungsversuche verfügbar bleibt.


Methode 4: Als Kopie öffnen

Gehen Sie folgendermaßen vor, um eine Kopie eines beschädigten Dokuments zu öffnen:
  1. Schließen Sie alle geöffneten Dokumente.
  2. Klicken Sie im Menü Datei auf Öffnen .
  3. Wählen Sie Kopieren aus Öffnen .
  4. Wählen Sie die beschädigte Datei.
  5. Klicken Sie auf Öffnen.
Eigenschaften

Artikelnummer: 285393 – Letzte Überarbeitung: 23.01.2017 – Revision: 1

Microsoft Word 2004 for Mac, Microsoft Word X für Macintosh, Microsoft Word 2001 für Macintosh

Feedback