Wiederherstellen von E-Mail-Nachrichten in Outlook mithilfe des Tools zum Reparieren des Posteingangs

Wenn Sie ein Small Business-Kunde sind, finden Sie auf der Website Support für Kleinunternehmen weitere Ressourcen zur Fehlerbehebung und nützliche Informationen.
Eine Microsoft Outlook 2000-Version dieses Artikels finden Sie unter
197316 .
Eine Outlook 2000 (IMO)-Version dieses Artikels finden Sie unter
197315 .
Eine Microsoft Outlook 98-Version dieses Artikels finden Sie unter
181325 .

Zusammenfassung

Sie können das Tool zum Reparieren des Posteingangs (Scanpst.exe) verwenden, um Ordner und Elemente aus einer beschädigten Persönliche Ordner-Datei (.pst) oder Offlineordnerdatei (.ost) in Microsoft Outlook 2010, Outlook 2007, Outlook 2003 und Outlook 2002 wiederherzustellen. "Scanpst.exe" wird bei der Installation von Microsoft Office oder Microsoft Outlook automatisch installiert. "Scanpst.exe" ist nicht als Download verfügbar.

Dieser Artikel enthält eine genaue Beschreibung der Funktionen des Tools zum Reparieren des Posteingangs und Erläuterungen dazu, wie PST- oder OST-Dateien auf Fehler überprüft und gefundene Fehler behoben werden.

Verwenden des Tools zum Reparieren des Posteingangs

Gehen Sie folgendermaßen vor, um mit dem Tool zum Reparieren des Posteingangs Elemente aus einer beschädigten PST- oder OST-Datei wiederherzustellen.


Video: Reparieren der Persönlichen Ordner-Dateien (.pst) in Outlook (Video in englischer Sprache)



Hinweis Die in den folgenden Abschnitten aufgeführten Beispiele verdeutlichen die Verwendung des Tools zum Reparieren des Posteingangs bei einer PST-Datei, das gleiche Vorgehen kann aber auch bei einer Offlineordnerdatei (.ost) verwendet werden.

Erweitern Sie Schritt 1: Ausführen des Tools zum Reparieren des Posteingangs für Diagnose und Reparatur von Fehlern
Um die Daten wiederherzustellen, führen Sie zuerst das Tool zum Reparieren des Posteingangs aus. Weitere Informationen zum Ausführen des Tools zum Reparieren des Posteingangs finden Sie im folgenden Artikel der Microsoft Knowledge Base:
272227 Finden und Ausführen des Tools zum Reparieren des Posteingangs in Outlook
Hinweis Wenn Sie Outlook 2002 verwenden oder in Outlook 2003 eine PST-Datei verwenden, die in einer früheren Version erstellt wurde, funktioniert das Tool zum Reparieren des Posteingangs möglicherweise nicht, wenn die Größe der PST-Datei sich dem Limit von 2 GB nähert. Prüfen Sie daher die Dateigröße, bevor Sie fortfahren. Je nach der verwendeten Windows-Version kann sich die PST-Datei in einem der folgenden Ordner befinden.

Windows 7 oder Windows Vista: Laufwerk:\users\Benutzername\AppData\Local\Microsoft\Outlook

Windows XP und Windows 2000: Laufwerk:\Dokumente und Einstellungen\Benutzername\Lokale Einstellungen\Anwendungsdaten\Microsoft\Outlook

Wenn sich die Größe der Datei dem 2-GB-Limit nähert, können Sie die Datei mit dem Tool zum Verkürzen von PST- oder OST-Dateien verkleinern. Weitere Informationen zum Tool zur Verkürzung von PST- oder OST-Dateien finden Sie im folgenden Artikel der Microsoft Knowledge Base:
296088 Tool zum Verkürzen übergroßer PST- und OST-Dateien



Gehen Sie folgendermaßen vor, um das Tool zum Reparieren des Posteingangs manuell zu finden und auszuführen:
  1. Beenden Sie Outlook.
  2. Da "Scanpst.exe" eine versteckte Datei auf dem Computer ist, stellen Sie sicher, dass die Einstellung Alle Dateien und Ordner anzeigen in den Ordneroptionen aktiviert ist. Gehen Sie folgendermaßen vor, um die Einstellung zu überprüfen:
    1. In Windows 7 und Windows Server 2008 klicken Sie auf "Start", geben Sie Ordneroptionen im Feld Suchen ein, und klicken Sie dann auf Ordneroptionen.


      In früheren Versionen von Windows klicken Sie auf Start, geben Sie Ordner verwalten ein, und klicken Sie dann auf OK.


      Wenn Sie Windows Vista ausführen, klicken Sie mit der rechten Maustaste auf Ordner verwalten und dann auf Als Administrator ausführen. Doppelklicken Sie dann auf Ordneroptionen.
    2. Klicken Sie auf die Registerkarte Ansicht.

      Ordneroptionen
    3. Vergewissern Sie sich, dass unter Versteckte Dateien und Ordner das Kontrollkästchen Alle Dateien und Ordner anzeigen aktiviert ist, und klicken Sie dann auf OK.
  3. Klicken Sie auf Start und dann auf Suchen bzw. Suche, je nach verwendeter Windows-Version.
  4. Geben Sie in das Feld Suchen den Begriff Scanpst.exe ein. Wenn Sie die Datei Scanpst.exe nicht über Suchen oder Suche finden können, suchen Sie an den folgenden Speicherorten nach der Datei. Wo sich die Datei befindet, hängt von der verwendeten Windows-Version ab:
    • Laufwerk:\Programme\Microsoft Office\OFFICEnn
      wobei nn gleich 10 für Office XP, 11 für Office 2003, 12 für das 2007 Office-System und 14 für Office 2010 ist.
    • Laufwerk:\Programme\Gemeinsame Dateien\System\Mapi\1031\
    • Laufwerk:\Programme\Gemeinsame Dateien\System\Mapi\1033\NT
    • Laufwerk:\Programme\Gemeinsame Dateien\System\MSMAPI\1031\
    • Laufwerk:\Programme(x86)\Microsoft Office\Officenn
      wobei nn gleich 10 für Office XP, 11 für Office 2003, 12 für das 2007 Office-System und 14 für Office 2010 ist.
    • Laufwerk:\Programme(x86)\Gemeinsame Dateien\System\Mapi\1031\
    • Laufwerk:\Programme(x86)\Gemeinsame Dateien\System\MSMAPI\1031\
  5. Doppelklicken Sie auf Scanpst.exe, um das Programm zu öffnen.
  6. Klicken Sie auf Durchsuchen, um die PST-Datei zu suchen.
    Hinweis Bei Outlook 2010 unter Windows 7 ist der Standardspeicherort der PST-Datei Laufwerk:\Benutzer\Benutzername\Dokumente\Outlook-Dateien. Bei Outlook 2010 unter Windows Server 2003 oder Windows XP lautet der Standardspeicherort Laufwerk:\Dokumente und Einstellungen\Benutzername\Eigene Dokumente\Outlook-Dateien.
  7. Klicken Sie auf Start. Das Tool zum Reparieren des Posteingangs überprüft die Datei und meldet, ob Fehler gefunden wurden.
  8. Klicken Sie auf OK.
Nachdem Sie das Tool zum Reparieren des Posteingangs ausgeführt und Outlook neu gestartet haben, sollte in Outlook im linken Navigationsbereich eine Liste der wiederhergestellten Ordner angezeigt werden. Der nächste Schritt besteht darin, die wiederhergestellten Elemente in Ihrem Profil in eine neue Persönliche Ordner-Datei (.pst) zu verschieben. Fahren Sie hierzu mit "Schritt 2: Wiederherstellen der reparierten Elemente" fort.

Erweitern Sie Schritt 2: Wiederherstellen der reparierten Elemente
Nachdem Sie das Tool zum Reparieren des Posteingangs ausgeführt haben, sind Sie bereit, die reparierten Elemente wiederherzustellen. Erstellen Sie dazu zuerst eine neue Persönliche Ordner-Datei (.pst) in Ihrem Profil. Dann können Sie die wiederhergestellten Elemente in die neue Persönliche Ordner-Datei (.pst) verschieben.
  1. Nachdem Sie das Tools zum Reparieren des Posteingangs ausgeführt haben, starten Sie Outlook. Wenn Sie mehrere Profile in Outlook verwenden, stellen Sie sicher, dass Sie das Profil auswählen, das die Persönliche Ordner-Datei (.pst) enthält, die Sie zu reparieren versucht haben.
  2. Klicken Sie im Menü Ansicht oder Go auf Ordnerliste, um die Ordnerlistenansicht zu aktivieren.
  3. In der Ordnerliste sollten die folgenden wiederhergestellten Ordner angezeigt werden:

    Wiederhergestellte Persönliche Ordner

    Kalender
    Kontakte
    Gelöschte Objekte
    Posteingang
    Journal
    Hinweise
    Postausgang
    Gesendete Objekte
    Aufgaben

    Diese wiederhergestellten Ordner sind gewöhnlich leer, weil es sich um eine neu erstellte PST-Datei handelt. Überprüfen Sie auch den Ordner Elemente ohne Zuordnung. Dieser Ordner enthält Ordner und Elemente, die das Tool zum Reparieren des Posteingangs wiederhergestellt hat. Elemente, die sich nicht im Ordner "Elemente ohne Zuordnung" befinden, können möglicherweise nicht repariert werden.
  4. Erstellen Sie eine neue Persönliche Ordner-Datei (.pst) in Ihrem Profil. Die Schritte können, je nach der verwendeten Outlook-Version, unterschiedlich sein.

    Outlook 2010
    1. Klicken Sie auf dem Menüband auf Datei und im Menü dann auf die Registerkarte Info.
    2. Klicken Sie auf Kontoeinstellungen und dann erneut auf Kontoeinstellungen.
    3. Klicken Sie auf die Registerkarte Datendateien .
    4. Kicken Sie auf Hinzufügen, um das Dialogfeld Outlook-Datendateien erstellen oder öffnen.
    5. Geben Sie einen Dateinamen für die neue Outlook-Dateidatei (.pst) ein, und klicken Sie anschließend auf OK.
    6. In Ihrem Profil müsste sich nun eine neue Outlook-Datendatei (.pst) befinden.
    Outlook 2007
    1. Klicken Sie im Menü Datei auf Datendateiverwaltung.
    2. Klicken Sie auf Hinzufügen, um das Dialogfeld Neue Outlook-Datendatei zu öffnen.
    3. Aktivieren Sie im Dialogfeld Speichertypen die Option Persönliche Ordner (.pst) für Office Outlook, und klicken Sie anschließend auf OK.
    4. Wählen Sie im Dialogfeld Outlook-Datendatei erstellen oder öffnen ein Verzeichnis und einen Dateinamen für die neue Persönliche Ordner-Datei (.pst) aus, und klicken Sie anschließend auf Öffnen.
    5. Klicken Sie auf OK.
    6. In Ihrem Profil müsste sich nun eine neue Persönliche Ordner-Datei (.pst) befinden.
    Outlook 2003
    1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie anschließend auf Outlook-Datendatei.
    2. Klicken Sie auf OK, um das Dialogfeld Outlook-Datendatei erstellen oder öffnen zu öffnen.
    3. Geben Sie einen Dateinamen für die neue Persönliche Ordner-Datei (.pst) ein, und klicken Sie anschließend auf OK, um das Dialogfeld Persönliche Ordner erstellen zu öffnen.
    4. Geben Sie einen Dateinamen für die neue Persönliche Ordner-Datei (.pst) ein, und klicken Sie anschließend auf OK.
    5. In Ihrem Profil müsste sich nun eine neue Persönliche Ordner-Datei (.pst) befinden.
    Outlook 2002
    1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Persönliche Ordner-Datei (.pst).
    2. Klicken Sie auf Erstellen, um das Dialogfeld Persönliche Ordner erstellen zu öffnen.
    3. Geben Sie einen Dateinamen für die neue Persönliche Ordner-Datei (.pst) ein, und klicken Sie anschließend auf OK.
    4. In Ihrem Profil müsste sich nun eine neue Persönliche Ordner-Datei (.pst) befinden.
  5. Ziehen Sie die wiederhergestellten Elemente vom Ordner Elemente ohne Zuordnung in die neue Persönliche Ordner-Datei (.pst).
  6. Wenn Sie alle Elemente verschoben haben, können Sie die Datei "Wiederhergestellte Persönliche Ordner" (. pst) aus Ihrem Profil entfernen. Dies umfasst den Ordner Elemente ohne Zuordnung.
  7. Wenn Sie mit den wiederhergestellten Informationen zufrieden sind, sind Sie fertig. Wenn Sie jedoch versuchen möchten, weitere Informationen wiederherzustellen, fahren Sie mit "Schritt 3: Wiederherstellen reparierter Elemente aus der Sicherungsdatei" fort.


Erweitern Sie Schritt 3: Wiederherstellen reparierter Elemente aus der Sicherungsdatei
Wenn Sie das Tool zum Reparieren des Posteingangs ausführen, ist die Option zum Erstellen einer Sicherungskopie der ursprünglichen Persönlichen Ordner-Datei (.pst) automatisch aktiviert. Diese Option erstellt auf dem Computer eine Datei mit dem Namen "Dateiname.bak" (ohne die Anführungszeichen). Bei dieser Datei handelt es sich um eine Kopie der ursprünglichen "Dateiname.pst"-Datei mit einer anderen Erweiterung. Wenn Sie glauben, dass nach Ausführen von Schritt 2 noch weitere Elemente fehlen, können Sie versuchen, folgendermaßen weitere Informationen aus dieser Sicherungsdatei wiederherzustellen.

Hinweis Wenn Sie Ihre ursprüngliche Persönliche Ordner-Datei (.pst) nicht öffnen konnten, bevor Sie das Tool zum Reparieren des Posteingangs ausgeführt haben, funktionieren die folgenden Vorgehensweisen möglicherweise nicht. Wenn es nicht funktioniert, dann können Sie keine zusätzlichen Informationen wiederherstellen. Wenn Sie die Datei öffnen konnten, sind Sie möglicherweise mithilfe des folgenden Verfahrens in der Lage, weitere Elemente aus der beschädigten Persönliche Ordner-Datei (.pst) wiederherzustellen.
  1. Suchen Sie die BAK-Datei. Sie befindet sich im Ordner Ihrer ursprünglichen Persönlichen Ordner-Datei (.pst).
  2. Erstellen Sie eine Kopie der BAK-Datei, und geben Sie ihr einen neuen Namen mit der Erweiterung ".pst". Nennen Sie die Datei beispielsweise "Neuer Name.pst" (ohne die Anführungszeichen).
  3. Importieren Sie die im vorstehenden Schritt erstellte Datei "Neuer Name.pst" mithilfe des Import/Export-Assistenten in Outlook. Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie im Menü Datei auf Importieren/Exportieren.


      Hinweis In Outlook 2010 klicken Sie auf dem Menüband auf die Registerkarte Datei, dann auf Öffnen und schließlich auf Importieren.

      Microsoft Outlook-Datei (Dialogfeld)
    2. Klicken Sie auf Aus anderen Programmen oder Dateien importieren, und klicken Sie anschließend auf Weiter.

      Importieren/Exportieren (Dialogfeld)
    3. Klicken Sie auf Outlook-Datendatei (.pst) und anschließend auf Weiter.

      Importieren einer Datei
    4. Klicken Sie unter Zu importierende Datei auf Durchsuchen, und doppelklicken Sie dann auf die Datei "Neuer Name.pst".

      Importieren einer Outlook-Datendatei
    5. Klicken Sie unter Optionen auf Keine Duplikate importieren, und klicken Sie anschließend auf Weiter.
    6. Wählen Sie unter Ordner, aus dem Sie importieren möchten die Persönliche Ordner-Datei (.pst) aus, und aktivieren Sie die Option Unterordner einbeziehen.
    7. Klicken Sie auf Elemente in denselben Ordner importieren in, und wählen Sie dann Ihren neuen Persönlichen Ordner (.pst) aus.
    8. Klicken Sie auf Fertig stellen.
    Hinweis Denken Sie daran, dass die Sicherungsdatei die ursprüngliche beschädigte Datei ist. Möglicherweise werden Sie feststellen, dass Sie neben den im Ordner "Elemente ohne Zuordnung" wiederhergestellten Elementen keine weiteren Elemente wiederherstellen können. Wenn Sie die Datei "NeuerName.pst" nicht in Outlook importieren können, sind leider alle Informationen verloren, die sich nicht im Ordner "Elemente ohne Zuordnung" befinden.


    Das Tool zum Reparieren des Posteingangs kann nicht jedes Problem reparieren, das erkannt wird. In manchen Fällen können Elemente nicht wiederhergestellt werden, wenn sie dauerhaft gelöscht oder irreparabel beschädigt wurden.

Weitere Informationen

Bei weitergehendem Interesse finden Sie in diesem Abschnitt eine genaue Beschreibung der Funktionen des Tools zum Reparieren des Posteingangs und Erläuterungen dazu, wie PST- oder OST-Dateien auf Fehler überprüft und gefundene Fehler behoben werden.

Funktionen der Anwendung "Posteingang reparieren"

Wenn Sie das Tool zum Reparieren des Posteingangs für eine Persönliche Ordner-Datei (.pst) ausführen, geschieht Folgendes:
  • Das Tool zum Reparieren des Posteingangs analysiert die Verzeichnisstruktur und die Elementkopfzeilen der Persönlichen Ordner-Datei (.pst) und versucht, alle Ordner und Elemente wiederherzustellen.
  • Wenn die Anwendung "Posteingang reparieren" die Persönliche Ordner-Datei (.pst) wiederherstellt, bedeutet dies, dass die Anwendung Probleme gefunden und soweit möglich repariert hat.
  • Die Anwendung "Posteingang reparieren" versucht, jede Datei in eine Persönliche Ordner-Datei (.pst) umzuwandeln. Wenn Sie beispielsweise eine ausführbare Datei in "Beispiel.pst" (ohne Anführungszeichen) umbenennen, ändert das Tool die Datei in eine bereitstellbare PST-Datei.
  • Das Tool zum Reparieren des Posteingangs erstellt eine Sicherungskopie der Persönlichen Ordner-Datei (.pst), bevor versucht wird, die Datei zu reparieren.

Wie das Tool zum Reparieren des Posteingangs Fehler prüft und korrigiert

ScanPST entdeckt und korrigiert vor allem Fehler in den internen Datenstrukturen der PST-Datei. Eine PST-Datei ist eine Datenbankdatei. Daher werden Strukturen wie BTrees und Referenzzähler bei Bedarf überprüft und repariert. Diese Objekte der unteren Ebene haben keine Kenntnis von den Strukturen der oberen Ebene, wie Nachrichten, Kalenderelemente usw., die auf ihnen aufgebaut sind.


Wenn ScanPST feststellt, dass ein bestimmter Struktur- oder Tabellenblock nicht lesbar oder beschädigt ist, entfernt ScanPST ihn. Wenn jener Block Bestandteil eines bestimmten Outlook-Elements war, wird dieses Element bei seiner Überprüfung entfernt.


Sie erwarten dieses Verhalten möglicherweise nicht, aber das Entfernen des Elements ist angesichts der Umstände das geeignete Vorgehen. Diese spezielle Situation tritt sehr selten auf, und sie wird immer in der Protokolldatei der ScanPST-Anwendung verzeichnet.


Offensichtlichere Änderungen auf einer höheren Ebene, die Sie feststellen werden, betreffen Ordner und Nachrichten.


Ordner

ScanPST untersucht jeden Ordner in der PST-Datei und führt die folgenden Vorgänge aus:
  1. ScanPST stellt sicher, dass dem Ordner die korrekten Tabellen zugeordnet sind.
  2. ScanPST überprüft jede Zeile in jeder Tabelle und stellt sicher, dass die Nachricht oder der Unterordner im System vorliegt.
  3. Wenn ScanPST die Nachricht bzw. den Unterordner nicht finden kann, entfernt ScanPST die Zeile aus der Tabelle.
  4. Wenn ScanPST die Nachricht bzw. den Unterordner findet, überprüft ScanPST die Nachricht bzw. den Ordner.
  5. Schlägt die Überprüfung fehl, wird die Nachricht bzw. der Ordner als beschädigt angesehen und aus der Tabelle entfernt sowie aus der Datenbank gelöscht.
  6. Wenn die Überprüfung erfolgreich abgeschlossen wird, führt ScanPST eine weitere Analyse durch, um sicherzustellen, dass die nun wiederhergestellten Werte der Nachricht mit den Werten in der Tabelle übereinstimmen. Beschädigte Ordner werden bei Bedarf von Grund auf neu erstellt. Diese Ordner enthalten keine Benutzerdaten.
Nachrichten

Bei den meisten Benutzern werden Vorgänge im Zusammenhang mit Nachrichten auftreten, da ein beschädigtes Element wahrscheinlich dazu führt, dass ein Bestandteil aus der PST-Datei gelöscht wird. ScanPST führt bei Nachrichten die folgenden Vorgänge durch:
  1. ScanPST führt grundlegende Überprüfungen von Anlagentabellen und Empfängertabellen durch. Dieser Vorgang ähnelt der Art und Weise, wie ein Ordner mit den in ihm enthaltenen Nachrichten umgeht.
  2. Sobald die Überprüfung der Empfängertabelle ergeben hat, dass die Empfänger korrekt formatiert sind, nimmt ScanPST die erforderlichen Änderungen vor, damit diese gültigen Inhalte der Empfängertabelle mit den Empfängereigenschaften in der Nachricht synchronisiert werden können. ScanPST stellt überdies sicher, dass der übergeordnete Ordner der Nachricht auf einen gültigen Ordner verweist. Die folgenden Nachrichteneigenschaften werden überprüft um sicherzustellen, dass sie gültigen Datenformaten entsprechen:
    • PR_MESSAGE_CLASS

      ScanPST prüft, ob diese Eigenschaft vorliegt. Ist die Eigenschaft nicht vorhanden, wird sie auf IPM.Note gesetzt.
    • PR_MESSAGE_FLAGS

      Jedes Flag wird einzeln überprüft.
    • PR_SUBMIT_FLAGS

      Diese Überprüfung ähnelt dem Vorgang bei Nachrichtenkennzeichnungen.
    • PR_CLIENT_SUBMIT_TIME

      Wenn die Sendungskennzeichnungen anzeigen, dass die Nachricht als gesendet markiert ist, muss diese Eigenschaft vorliegen. Wenn die Sendungskennzeichen anzeigen, dass die Nachricht als gesendet markiert ist, wird der Zeitpunkt auf "Jetzt" festgelegt.
    • PR_SEARCH_KEY

      Diese Eigenschaft muss vorliegen. Existiert die Eigenschaft nicht, wird für sie eine zufällige GUID erstellt.
    • PR_CREATION_TIME

      Diese Eigenschaft muss vorliegen. Liegt die Eigenschaft nicht vor, ist der Zeitpunkt auf "Jetzt" gesetzt.
    • PR_LAST_MODIFICATION_TIME

      Diese Eigenschaft muss vorliegen. Liegt die Eigenschaft nicht vor, ist der Zeitpunkt auf "Jetzt" gesetzt.
    • PR_MESSAGE_SIZE

      Größen werden neu berechnet und mit gespeicherten Werten verglichen. Wenn die Größen etwas differieren, wird der berechnete Wert geschrieben.
    Für Eigenschaften, die sich auf den Text oder auf den Betreff beziehen, wird explizit keine Überprüfung durchgeführt, abgesehen von der impliziten Überprüfung auf unterer Ebene, die zuvor in diesem Artikel erörtert wurde. Die Eigenschaften, die sich auf das Anzeigen des Empfängers beziehen, werden geändert, damit sie mit der wiederhergestellten Empfängertabelle übereinstimmen. Sobald dieser Vorgang abgeschlossen ist, werden andere Algorithmen ausgeführt, um sämtliche verwaiste Nachrichten zu sammeln und in einem entsprechenden Ordner abzulegen.


    Weitere Informationen zu binären Strukturen (BTrees) finden Sie auf folgender Microsoft-Website:
Eigenschaften

Artikelnummer: 287497 – Letzte Überarbeitung: 31.01.2014 – Revision: 1

Feedback