WD2002: Warnung vor Makroviren wird angezeigt, obwohl in der Datei kein Makro enthalten ist

Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
290960 WD2002: Macro Virus Warning Appears When No Macros Exist in File
Für eine Microsoft Word 2000-Version dieses Artikels siehe 238851 .
Für eine Microsoft Word 97-Version dieses Artikels siehe 161515 .

Problembeschreibung

Wenn Sie ein Dokument oder eine Vorlage im Format von Microsoft Word 2002 öffnen, wird Ihnen möglicherweise die folgende Warnung vor Makroviren angezeigt, obwohl das Dokument bzw. die Vorlage keine Makros enthalten.
C:\<Pfad>\<Dateiname> enthält Makros.

Makros können Viren enthalten. Es ist sicherer, Makros zu deaktivieren. Wenn es sich jedoch um zuverlässige Makros handelt, kann die Funktionalität beeinträchtigt werden.

Ursache

Wenn Sie Makros aus einem Dokument oder einer Vorlage löschen, bleiben einige Makro-Speicherungskomponenten zurück. Die Funktion zum Schutz vor Makroviren findet diese Informationen, so dass die besagte Warnung angezeigt werden kann.

Abhilfe

Wenden Sie in Abhängigkeit von Ihrer spezifischen Situation eine der folgenden Methoden an, um dieses Problem zu umgehen.

Methode 1: Löschen verbliebener Makro-Speicherungskomponenten

Die Verwendung der hier aufgeführten Informationen, Makro- oder Programmcodes geschieht auf eigene Verantwortung. Microsoft stellt Ihnen diese Informationen sowie Makro- und Programmlistings ohne Gewähr auf Richtigkeit, Vollständigkeit und/oder Funktionalität sowie ohne Anspruch auf Support zur Verfügung. Die zur Verfügung gestellten Makro- und Programmierungsbeispiele sollen lediglich exemplarisch die Funktionsweise des Beispiels aufzeigen.

Weitere Informationen zu den von Microsoft angebotenen Supportoptionen finden Sie unter folgender Internetadresse:

Makros, die in Ihrem Word-Dokument oder Ihrer Word-Vorlage enthalten sind, werden in einem Modul gespeichert. Nachdem Sie Makros aus einem Dokument oder einer Vorlage gelöscht haben, bleibt das Modul, in dem die Makros gespeichert wurden, auch nach dem Löschen der Makros erhalten.

Um das Modul aus Ihrem Word-Dokument oder Ihrer Word-Vorlage zu löschen und zu verhindern, dass die Warnung vor Makroviren angezeigt wird, gehen Sie bitte folgendermaßen vor.

Anmerkung: Wenn Sie ein Modul entfernen, werden die darin enthaltenen Makros gelöscht.
  1. Öffnen Sie das Dokument bzw. die Vorlage, in dem/in der die Warnung vor Makroviren angezeigt wird.
  2. Zeigen Sie im Menü Extras auf Makro und klicken Sie dann auf Visual Basic-Editor.
  3. Im Fenster Projekt expandieren Sie das Projekt mit dem Dokument (der Vorlage). Das Dokument (die Vorlage) sollte jetzt etwa wie in dem folgenden Beispiel aussehen:
    Projekt (Dateiname)
    Anmerkung: Falls das Fenster Projekt nicht sichtbar ist, klicken Sie bitte im Menü Ansicht auf Projektexplorer. Um das Projekt mit dem Dokument (der Vorlage) zu expandieren, klicken Sie bitte auf das Pluszeichen links neben Projekt (Dateiname).
  4. Expandieren Sie den Ordner Module.
  5. Klicken Sie auf das Modul, um es auszuwählen. Klicken Sie zum Beispiel auf NeueMakros.

    Anmerkung: Der Name des aufgelisteten Moduls kann in dem Projekt mit Ihrem Dokument oder Ihrer Vorlage anders lauten. Er könnte beispielsweise "Modul1" oder auch anders lauten.
  6. Klicken Sie im Menü Datei auf Modulname entfernen. Klicken Sie auf Nein, wenn (sinngemäß) die folgende Meldung angezeigt wird:
    Möchten Sie <Modulname> exportieren, bevor Sie es entfernen?
    Anmerkung: Wenn Sie sich nicht sicher sind, ob das Modul, das Sie gerade entfernen, Makros enthält, klicken Sie auf Ja und exportieren Sie dann das Modul als Basics Files (*.bas).
  7. Wiederholen Sie die Schritte 5 und 6 für jedes Modul, das unter dem Modulordner für Projekt (Dateiname) aufgelistet ist.
  8. Klicken Sie im Menü Datei auf Schließen und zurück zu Microsoft Word.
  9. Speichern und schließen Sie das Word-Dokument (die Word-Vorlage).
Wenn Sie das Dokument (die Vorlage) öffnen, wird die Warnung vor Makroviren nicht mehr angezeigt.

Methode 2: Kopieren der Vorlage in eine neue Word-Datei

Anmerkung: Dieses Verfahren wenden Sie bitte an, wenn Ihre Word-Vorlage keine Makros enthält, aber die im Abschnitt "Problembeschreibung" genannte Warnung angezeigt wird, wenn Sie die Vorlage öffnen oder ein auf ihr basierendes Dokument erstellen möchten (indem Sie im Menü Datei auf Neu klicken). Erstellen Sie eine neue Vorlage, indem Sie die folgenden Schritte ausführen.

Anmerkung: Nachdem die Vorlage erstellt wurde, können Sie alle benutzerdefinierten Formatvorlagen, AutoText-Einträge etc. in die neue Vorlage kopieren. Achten Sie jedoch bitte darauf, keine Makros in diese neue Vorlage zu kopieren.
  1. Klicken Sie im Menü Datei auf Schließen, um die Datei zu schließen, in der die Warnung vor Makroviren angezeigt wird.
  2. Klicken Sie im Menü Datei auf Neu.
  3. Auf der Registerkarte Allgemein klicken Sie bitte auf die Option Leeres Dokument. Klicken Sie dann auf OK.
  4. Klicken Sie im Menü Einfügen auf Datei.
  5. Ändern Sie im Dialogfeld Datei einfügen den Eintrag unter Dateityp zu Dokumentvorlagen (*.dot).
  6. Ändern Sie den Eintrag unter Suchen in zu dem Ordner, der die Vorlage enthält, bei der das Problem auftritt. Ändern Sie den Eintrag unter Suchen in zum Beispiel zu dem folgenden Ordner:
    C:\WINDOWS\Anwendungsdaten\Microsoft\Vorlagen
    Anmerkung: Ihre Vorlage kann sich auch in einem anderen Ordner befinden.
  7. Wählen Sie die Vorlage aus, in der das Problem auftritt, und klicken Sie dann auf Einfügen.
  8. Klicken Sie im Menü Datei auf Speichern unter.
  9. Ändern Sie im Dialogfeld Speichern unter den Eintrag unter Dateityp zu Dokumentvorlage (*.dot).
  10. In das Feld Dateiname geben Sie einen Dateinamen für Ihre neue Vorlage ein. Klicken Sie dann auf Speichern.
  11. Klicken Sie im Menü Datei auf Schließen, um Ihre neue Vorlage zu schließen.
Makros oder etwaige Makro-Speicherungskomponenten aus Ihrer problematischen Vorlage werden nicht in der neuen Vorlage gespeichert. Wenn Sie die Vorlage öffnen oder ein darauf basierendes neues Dokument erstellen, wird die Warnung vor Makroviren nicht mehr angezeigt.

Methode 3: Speichern Sie das Word-Dokument im Rich Text-Format (RTF)

Anmerkung: Dieses Verfahren wenden Sie bitte an, wenn Ihr Word-Dokument zwar keine Makros enthält, in ihm aber immer die Makrovirenwarnung aus dem Abschnitt "Problembeschreibung" angezeigt wird.
  1. Öffnen Sie das Dokument, in dem die Warnung vor Makroviren angezeigt wird.
  2. Klicken Sie im Menü Datei auf Speichern unter.
  3. Im Dialogfeld Speichern unter klicken Sie im Feld Dateityp bitte auf Rich Text-Format (*.rtf). Klicken Sie danach auf Speichern. Klicken Sie auf Ja, wenn (sinngemäß) die folgende Meldung angezeigt wird:
    Wenn das Dokument im Richt Text-Format gespeichert wird, werden alle Makros verloren gehen. Möchten Sie das Dokument dennoch in diesem Format speichern?
  4. Klicken Sie im Menü Datei auf Schließen, um das Dokument im Rich Text-Format zu schließen, das Sie gerade gespeichert haben.
  5. Klicken Sie im Menü Datei auf Öffnen, um das Dokument im Rich Text-Format zu öffnen, das Sie in Schritt 3 gespeichert haben.
  6. Klicken Sie im Menü Datei auf Speichern unter.
  7. Im Dialogfeld Speichern unter klicken Sie im Feld Dateityp bitte auf Word-Dokument (*.doc). Klicken Sie danach auf Speichern. Wenn Sie die Datei wieder unter ihrem ursprünglichen Dateinamen speichern möchten, klicken Sie bei der folgenden Meldung bitte auf Ja:
    Die Datei <Dateiname> existiert bereits. Wollen Sie die existierende Datei ersetzen?
  8. Schließen Sie das Dokument und öffnen Sie es danach wieder.
Makros oder etwaige Makro-Speicherungskomponenten werden nicht in Ihrem neuen Dokument gespeichert. Wenn Sie das Dokument öffnen, wird die Warnung vor Makroviren nicht mehr angezeigt.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Makro-Speicherungskomponenten sind erst dann in einem Word-Dokument oder einer Word-Vorlage zu finden, wenn Sie ein Makro in der Datei gespeichert haben. Diese Komponenten sind unterstützende Strukturen für das Vorhandensein und Speichern von Makros in einer Datei. Wenn Sie alle Makros in einer Datei löschen, werden dadurch die Makro-Speicherungskomponenten nicht gelöscht. Die Microsoft Word 2002-Funktion zur Warnung vor Makroviren entdeckt die Makro-Speicherungskomponenten in der Datei und zeigt daher beim Öffnen der Datei die Makrovirenwarnung an.

Gehen Sie folgendermaßen vor, um Makros aus einem Word-Dokument zu entfernen:
  1. Öffnen Sie die Datei in Word.
  2. Zeigen Sie im Menü Extras auf Makro und klicken Sie dann auf Makros.
  3. Im Dialogfeld Makros wählen Sie bitte einen Makronamen aus und klicken danach auf Löschen. Dadurch wird das Makro aus der Datei entfernt.
  4. Wiederholen Sie Schritt 3 für alle Makros, die Sie entfernen möchten.


Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Eigenschaften

Artikelnummer: 290960 – Letzte Überarbeitung: 27.10.2003 – Revision: 1

Feedback