Fehler während der Desktopeinrichtung, und der Desktopspeicherort ist nicht verfügbar, wenn Sie sich zum ersten Mal bei Windows anmelden

Dieser Artikel bietet Hilfe bei der Behebung eines Problems, bei dem das Laden von Profilen fehlschlägt, wenn die ntuser.dat- oder usrclass.dat-Datei als schreibgeschützt definiert ist oder der Profilbenutzer nicht über die entsprechenden Berechtigungen für diese beiden .dat-Dateien verfügt.

Gilt für: Windows 10 (alle Editionen), Windows Server 2012 R2
Ursprüngliche KB-Nummer: 3048895

Symptome

Nach der Installation des Updates in Sicherheitsrisiko im Windows-Benutzerprofildienst kann Rechteerweiterungen ermöglichen: 13. Januar 2015 (MS15-003) treten die folgenden Probleme auf:

  • Profile werden nicht geladen, wenn sich Benutzer zum ersten Mal bei einem Computer anmelden. Oder Sie melden sich bei einem Computer an, auf dem die Richtlinie das zwischengespeicherte Profil nach einem Datumsintervall löscht, wenn Sie sich abmelden.

    Hinweis

    Anmeldungen, die obligatorische Benutzerprofile oder vdi (Virtual Desktop Infrastructure) verwenden, können ebenfalls betroffen sein.

  • Profile werden nicht geladen, wenn Sich Benutzer mithilfe von zwischengespeicherten Benutzerprofilen anmelden.

  • Dienste werden aufgrund von Fehlern beim Laden von Profilen nicht gestartet. Zu den betroffenen Diensten zählen unter anderem die folgenden Dienste:

    • Lokaler Dienst
    • Netzwerkdienst
    • MSSQL

Wenn dieses Problem auftritt, werden verwandte Ereignisse protokolliert. Sehen Sie sich die Ereignisse an, die in Ereignisanzeige protokolliert werden.

Der Prozessmonitor kann darauf hinweisen, dass ein CreateFile-Vorgang mit einem ACCESS DENIED-Ergebnis zum folgenden Pfad fehlschlägt, je nachdem, wie der Dateizugriff eingeschränkt ist: <Laufwerk>:\Dokumente & Settings\<username>\local settings\Application Data\Microsoft\Windows\UsrClasss.dat.

Der Screenshot des Prozessmonitors ist hier zu sehen:

Der Prozessmonitor gibt an, dass ein CreateFile-Vorgang mit einem ACCESS DENIED-Ergebnis fehlschlägt.

Weitere Informationen finden Sie unter Details zum Fehler, die im Prozessmonitor angezeigt werden.

Ursache

Update 3021674 fügt Überprüfungen auf den Zugriff auf die Ntuser.dat und die Usrclass.dat-Dateien hinzu.

Lösung

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Überprüfen Sie, ob das Read ONLY-Flag für NTUSER festgelegt ist. DAT oder USERCLASS. DAT-Datei für das Profil, das nicht geladen werden kann.

    Neue Benutzerprofile werden von C:\users\default\ während der anmeldung zum ersten Mal des Kontos abgeleitet. Wenn Profile nicht mit Signaturen geladen werden können, die mit den im Abschnitt "Symptome" beschriebenen Signaturen übereinstimmen, überprüfen Sie, ob das Read-Only Bit für NTUSER aktiviert ist. DAT und USRCLASS. DAT-Dateien im Profilverzeichnis für die betreffenden Benutzer oder Dienstkonten.

    NTUSER. DAT in Windows Vista und höheren Versionen von Windows befindet sich unter C:\users\default\ntuser.dat. Frühere Betriebssysteme verfügen über andere Pfade, z. B. C:\Dokumente und Einstellungen\<Benutzername>\ntuser.dat.

    Die USRCLASS. Die DAT-Datei befindet sich in der Regel entlang eines Pfads wie C:\Dokumente und Einstellungen<user_name>\Lokale Einstellungen\Anwendungsdaten\Microsoft\Windows\UsrClass.dat oder C:\Users<user_name>\AppData\Local\Microsoft\Windows.

    Klicken Sie in Windows Explorer mit der rechten Maustaste auf NTUSER. DAT- oder USRCLASS-Datei für das relevante Standardbenutzer- oder zwischengespeicherte Benutzerprofil. Das Kontrollkästchen Schreibgeschützt sollte deaktiviert sein. Wenn dieses Kontrollkästchen aktiviert ist, führt dies zu Fehlern beim Laden des Profils.

    Stellen Sie sicher, dass die Option Schreibgeschützt in NTUSER deaktiviert ist. DAT-Eigenschaften.

  2. Überprüfen Sie die Ntfs-Dateisystemberechtigungen für NTUSER. DAT oder USERCLASS. DAT-Datei im zwischengespeicherten Profilverzeichnis, das nicht geladen werden kann.

Im folgenden Screenshot hat der Testbenutzer CONTOSO/testUser die vollständige Kontrolle über NTUSER. DAT (nicht dargestellt) und USRCLASS.DAT. Jeder ist nicht in der ACL-Editor Gruppe aufgeführt.

NTFS File System ACLS für DAT-Dateien Erweiterte NTFS-Dateisystem-ACLS für DAT-Dateien
Die Berechtigung des Testbenutzers, die auf der Registerkarte Sicherheit von UsrClass.dat Eigenschaften angezeigt wird.
Die Berechtigung des Testbenutzers, die unter Erweiterte Sicherheitseinstellungen für UsrClass.dat angezeigt wird.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.

Weitere Informationen

Ereignisse, die in Ereignisanzeige protokolliert werden

Protokollname Ereignisabsender Ereignis-ID Ereignismeldungstext
App Microsoft-Windows-User Profiles Service 1542 Windows kann keine Klassenregistrierungsdatei laden.
DETAIL : Nicht angegebener Fehler
Die Klassenregistrierungsdatei kann nicht geladen werden.
DETAIL - Unbekannter Fehler
App Dienststeuerungs-Manager 7005 Der LoadUserProfile-Aufruf ist mit dem folgenden Fehler fehlgeschlagen:
Die angegebene Datei wurde nicht gefunden.
App Dienststeuerungs-Manager 7024 Der SQL Server -Dienst (MSSQLSERVER) wurde mit dienstspezifischem Fehler 2148081668 (0x80092004) beendet.
App Userenv 1500 Windows kann Sie nicht anmelden, da Ihr Profil nicht geladen werden kann. Überprüfen Sie, ob Sie mit dem Netzwerk verbunden sind oder ob Ihr Netzwerk ordnungsgemäß funktioniert. Wenn dieses Problem weiterhin besteht, wenden Sie sich an Ihren Netzwerkadministrator. DETAIL: Das System kann die angegebene Datei nicht finden.
App Userenv 1502 Windows kann das lokal gespeicherte Profil nicht laden. Mögliche Ursachen für diesen Fehler sind unzureichende Sicherheitsrechte oder ein beschädigtes lokales Profil. Wenn dieses Problem weiterhin besteht, wenden Sie sich an Ihren Netzwerkadministrator.

Details des Fehlers, die im Prozessmonitor angezeigt werden

ProMon-DetailsDie folgende Meldung wird im Prozessmonitor angezeigt:

Gewünschter Zugriff: Generischer Lese-/Schreibzugriff, Disposition: Offen, Optionen: Synchrone E/A Ohne Warnung, Nicht-Verzeichnisdatei, Attribute: H, ShareMode: Lesen, Schreiben, ZuordnungSgröße: n/a, Identitätswechsel: <SID>

Der folgende Screenshot zeigt die Details des Prozessmonitors:

Details zum Fehler, die im Prozessmonitor angezeigt werden.